aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorFelix Domke <tmbinc@elitedvb.net>2009-01-26 01:29:32 +0100
committerFelix Domke <tmbinc@elitedvb.net>2009-01-26 01:29:32 +0100
commit36f9940bb3637b4ac2aa6e3da9cd20088e6d241f (patch)
tree3a6af378e2d6c7a3e38ee0d53dc18df3ef83c615 /packages
parent86127d597029d8b396d59a3afb4a27c8fb44dd51 (diff)
downloadopenembedded-36f9940bb3637b4ac2aa6e3da9cd20088e6d241f.tar.gz
twisted-web2: work around sometimes-not-appearing connectionLost
Diffstat (limited to 'packages')
-rw-r--r--packages/twisted/twisted-web2/fix-connectionlost.patch12
-rw-r--r--packages/twisted/twisted-web2_8.1.0.bb3
2 files changed, 14 insertions, 1 deletions
diff --git a/packages/twisted/twisted-web2/fix-connectionlost.patch b/packages/twisted/twisted-web2/fix-connectionlost.patch
new file mode 100644
index 0000000000..fadf7348ff
--- /dev/null
+++ b/packages/twisted/twisted-web2/fix-connectionlost.patch
@@ -0,0 +1,12 @@
+--- TwistedWeb2-8.1.0/twisted/web2/channel/http.py 2007-01-02 00:41:33.000000000 +0100
++++ TwistedWeb2-8.1.0/twisted/web2/channel/http.py 2009-01-24 07:21:29.000000000 +0100
+@@ -845,6 +845,9 @@
+ # probably a client abort, so lose the connection.
+ if self.chanRequest:
+ self.transport.loseConnection()
++
++ # Workaround for enigma2's webinterface.
++ self.transport.loseConnection()
+
+ def connectionLost(self, reason):
+ self.factory.outstandingRequests-=1
diff --git a/packages/twisted/twisted-web2_8.1.0.bb b/packages/twisted/twisted-web2_8.1.0.bb
index f84923ca33..6230ef256c 100644
--- a/packages/twisted/twisted-web2_8.1.0.bb
+++ b/packages/twisted/twisted-web2_8.1.0.bb
@@ -10,7 +10,8 @@ LICENSE = "LGPL"
DEPENDS = "twisted twisted-native"
RDEPENDS = "twisted python-netserver"
-SRC_URI = "http://tmrc.mit.edu/mirror/twisted/Web2/8.1/TwistedWeb2-${PV}.tar.bz2"
+SRC_URI = "http://tmrc.mit.edu/mirror/twisted/Web2/8.1/TwistedWeb2-${PV}.tar.bz2\
+ file://fix-connectionlost.patch;patch=1;pnum=1"
S = "${WORKDIR}/TwistedWeb2-${PV}"
inherit distutils