aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorFelix Domke <tmbinc@elitedvb.ne>2007-11-25 18:25:46 +0000
committerFelix Domke <tmbinc@elitedvb.ne>2007-11-25 18:25:46 +0000
commit421c3a5b23a5072fd83fb9932e7b6f3c84218343 (patch)
tree3e8ae2bf15665748f2e42f27674cba46111b466d /packages
parent1b56b756259d4dbb90b3899e5368fe72f2ab4a94 (diff)
downloadopenembedded-421c3a5b23a5072fd83fb9932e7b6f3c84218343.tar.gz
dbus: backport from .dev
Diffstat (limited to 'packages')
-rw-r--r--packages/dbus/dbus-1.0.1/.mtn2git_empty0
-rw-r--r--packages/dbus/dbus-1.0.1/cross.patch10
-rw-r--r--packages/dbus/dbus-1.0.1/dbus-1.init96
-rw-r--r--packages/dbus/dbus-1.0.1/dbus-exploit-fix.patch21
-rw-r--r--packages/dbus/dbus-1.0.1/fix-install-daemon.patch13
-rw-r--r--packages/dbus/dbus-1.0.2/.mtn2git_empty0
-rw-r--r--packages/dbus/dbus-1.0.2/cross.patch10
-rw-r--r--packages/dbus/dbus-1.0.2/dbus-1.init110
-rw-r--r--packages/dbus/dbus-1.0.2/fix-install-daemon.patch13
-rw-r--r--packages/dbus/dbus-1.0.2/fix-waitpid.patch11
-rw-r--r--packages/dbus/dbus-c++-native_svn.bb21
-rw-r--r--packages/dbus/dbus-c++/.mtn2git_empty0
-rw-r--r--packages/dbus/dbus-c++/fix-linking.patch13
-rw-r--r--packages/dbus/dbus-c++_svn.bb19
-rw-r--r--packages/dbus/dbus-glib-0.74/.mtn2git_empty0
-rw-r--r--packages/dbus/dbus-glib-0.74/no-examples.patch8
-rw-r--r--packages/dbus/dbus-glib-0.74/no-introspect.patch14
-rw-r--r--packages/dbus/dbus-glib-native-0.74/.mtn2git_empty0
-rw-r--r--packages/dbus/dbus-glib-native-0.74/run-with-tmp-session-bus.patch23
-rw-r--r--packages/dbus/dbus-glib-native_0.74.bb21
-rw-r--r--packages/dbus/dbus-glib_0.74.bb28
-rw-r--r--packages/dbus/dbus-native_1.0.1.bb31
-rw-r--r--packages/dbus/dbus-python_0.71.bb12
-rw-r--r--packages/dbus/dbus.inc66
-rw-r--r--packages/dbus/dbus_1.0.1.bb5
-rw-r--r--packages/dbus/dbus_1.0.2.bb14
26 files changed, 551 insertions, 8 deletions
diff --git a/packages/dbus/dbus-1.0.1/.mtn2git_empty b/packages/dbus/dbus-1.0.1/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/dbus/dbus-1.0.1/.mtn2git_empty
diff --git a/packages/dbus/dbus-1.0.1/cross.patch b/packages/dbus/dbus-1.0.1/cross.patch
new file mode 100644
index 0000000000..268a3ae3de
--- /dev/null
+++ b/packages/dbus/dbus-1.0.1/cross.patch
@@ -0,0 +1,10 @@
+--- /tmp/configure.in 2006-11-09 21:47:10.000000000 +0100
++++ dbus-0.95/configure.in 2006-11-09 21:48:13.108554000 +0100
+@@ -719,6 +719,7 @@
+ exit (0);
+ ]])],
+ [ac_cv_have_abstract_sockets=yes],
++ [ac_cv_have_abstract_sockets=no],
+ [ac_cv_have_abstract_sockets=no]
+ )])
+ AC_LANG_POP(C)
diff --git a/packages/dbus/dbus-1.0.1/dbus-1.init b/packages/dbus/dbus-1.0.1/dbus-1.init
new file mode 100644
index 0000000000..38e7574ad5
--- /dev/null
+++ b/packages/dbus/dbus-1.0.1/dbus-1.init
@@ -0,0 +1,96 @@
+#! /bin/sh
+# -*- coding: utf-8 -*-
+# Debian init.d script for D-BUS
+# Copyright © 2003 Colin Walters <walters@debian.org>
+
+set -e
+
+DAEMON=/usr/bin/dbus-daemon
+NAME=dbus
+DAEMONUSER=messagebus
+PIDDIR=/var/run/dbus
+PIDFILE=$PIDDIR/pid
+UUIDDIR=/var/lib/dbus
+DESC="system message bus"
+EVENTDIR=/etc/dbus-1/event.d
+
+test -x $DAEMON || exit 0
+
+# Source defaults file; edit that file to configure this script.
+ENABLED=1
+PARAMS=""
+if [ -e /etc/default/dbus ]; then
+ . /etc/default/dbus
+fi
+
+test "$ENABLED" != "0" || exit 0
+
+start_it_up()
+{
+ if [ ! -d $PIDDIR ]; then
+ mkdir -p $PIDDIR
+ chown $DAEMONUSER $PIDDIR
+ chgrp $DAEMONUSER $PIDDIR
+ fi
+ if [ -e $PIDFILE ]; then
+ PIDDIR=/proc/$(cat $PIDFILE)
+ if [ -d ${PIDDIR} -a "$(readlink -f ${PIDDIR}/exe)" = "${DAEMON}" ]; then
+ echo "$DESC already started; not starting."
+ else
+ echo "Removing stale PID file $PIDFILE."
+ rm -f $PIDFILE
+ fi
+ fi
+
+ if [ ! -d $UUIDDIR ]; then
+ mkdir -p $UUIDDIR
+ chown $DAEMONUSER $UUIDDIR
+ chgrp $DAEMONUSER $UUIDDIR
+ fi
+
+ dbus-uuidgen --ensure
+
+ echo -n "Starting $DESC: "
+ start-stop-daemon --start --quiet --pidfile $PIDFILE \
+ --user $DAEMONUSER --exec $DAEMON -- --system $PARAMS
+ echo "$NAME."
+ if [ -d $EVENTDIR ]; then
+ run-parts --arg=start $EVENTDIR
+ fi
+}
+
+shut_it_down()
+{
+ if [ -d $EVENTDIR ]; then
+ run-parts --reverse --arg=stop $EVENTDIR
+ fi
+ echo -n "Stopping $DESC: "
+ start-stop-daemon --stop --quiet --pidfile $PIDFILE \
+ --user $DAEMONUSER
+ # We no longer include these arguments so that start-stop-daemon
+ # can do its job even given that we may have been upgraded.
+ # We rely on the pidfile being sanely managed
+ # --exec $DAEMON -- --system $PARAMS
+ echo "$NAME."
+ rm -f $PIDFILE
+}
+
+case "$1" in
+ start)
+ start_it_up
+ ;;
+ stop)
+ shut_it_down
+ ;;
+ restart|force-reload)
+ shut_it_down
+ sleep 1
+ start_it_up
+ ;;
+ *)
+ echo "Usage: /etc/init.d/$NAME {start|stop|restart|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/packages/dbus/dbus-1.0.1/dbus-exploit-fix.patch b/packages/dbus/dbus-1.0.1/dbus-exploit-fix.patch
new file mode 100644
index 0000000000..7d36dbdf22
--- /dev/null
+++ b/packages/dbus/dbus-1.0.1/dbus-exploit-fix.patch
@@ -0,0 +1,21 @@
+https://bugs.freedesktop.org/show_bug.cgi?id=9142
+
+[..] the use case was the following. There
+are three processes A, B, and C. All of them add the same match (same value). A
+is started first, then B, and lastly C. Now, B and C are closed: if B is closed
+before C, A's match is removed; but if C is closed before B, A's match is not
+removed (no buggy behaviour). (B and C call dbus_bus_remove_match on exit.)
+
+diff -pur 0.61-osso23/bus/signals.c 0.61-osso23.new/bus/signals.c
+--- 0.61-osso23/bus/signals.c 2006-11-23 16:46:52.589602192 +0200
++++ 0.61-osso23.new/bus/signals.c 2006-11-23 16:49:28.873843376 +0200
+@@ -1067,6 +1067,9 @@ match_rule_equal (BusMatchRule *a,
+ if (a->flags != b->flags)
+ return FALSE;
+
++ if (a->matches_go_to != b->matches_go_to)
++ return FALSE;
++
+ if ((a->flags & BUS_MATCH_MESSAGE_TYPE) &&
+ a->message_type != b->message_type)
+ return FALSE;
diff --git a/packages/dbus/dbus-1.0.1/fix-install-daemon.patch b/packages/dbus/dbus-1.0.1/fix-install-daemon.patch
new file mode 100644
index 0000000000..c31786357d
--- /dev/null
+++ b/packages/dbus/dbus-1.0.1/fix-install-daemon.patch
@@ -0,0 +1,13 @@
+Index: dbus-0.94/bus/Makefile.am
+===================================================================
+--- dbus-0.94.orig/bus/Makefile.am 2006-10-01 17:36:18.000000000 +0200
++++ dbus-0.94/bus/Makefile.am 2006-10-14 21:40:05.000000000 +0200
+@@ -110,7 +110,7 @@
+ $(mkinstalldirs) $(DESTDIR)$(DBUS_DAEMONDIR); \
+ chmod 755 $(DESTDIR)$(DBUS_DAEMONDIR); \
+ fi
+- $(INSTALL_PROGRAM) dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR)
++ $(INSTALL_PROGRAM) .libs/dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR)
+ $(mkinstalldirs) $(DESTDIR)$(localstatedir)/run/dbus
+ $(mkinstalldirs) $(DESTDIR)$(configdir)/system.d
+ $(mkinstalldirs) $(DESTDIR)$(datadir)/dbus-1/services
diff --git a/packages/dbus/dbus-1.0.2/.mtn2git_empty b/packages/dbus/dbus-1.0.2/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/dbus/dbus-1.0.2/.mtn2git_empty
diff --git a/packages/dbus/dbus-1.0.2/cross.patch b/packages/dbus/dbus-1.0.2/cross.patch
new file mode 100644
index 0000000000..268a3ae3de
--- /dev/null
+++ b/packages/dbus/dbus-1.0.2/cross.patch
@@ -0,0 +1,10 @@
+--- /tmp/configure.in 2006-11-09 21:47:10.000000000 +0100
++++ dbus-0.95/configure.in 2006-11-09 21:48:13.108554000 +0100
+@@ -719,6 +719,7 @@
+ exit (0);
+ ]])],
+ [ac_cv_have_abstract_sockets=yes],
++ [ac_cv_have_abstract_sockets=no],
+ [ac_cv_have_abstract_sockets=no]
+ )])
+ AC_LANG_POP(C)
diff --git a/packages/dbus/dbus-1.0.2/dbus-1.init b/packages/dbus/dbus-1.0.2/dbus-1.init
new file mode 100644
index 0000000000..0725083c69
--- /dev/null
+++ b/packages/dbus/dbus-1.0.2/dbus-1.init
@@ -0,0 +1,110 @@
+#! /bin/sh
+# -*- coding: utf-8 -*-
+# Debian init.d script for D-BUS
+# Copyright © 2003 Colin Walters <walters@debian.org>
+
+set -e
+
+DAEMON=/usr/bin/dbus-daemon
+NAME=dbus
+DAEMONUSER=messagebus
+PIDDIR=/var/run/dbus
+PIDFILE=$PIDDIR/pid
+UUIDDIR=/var/lib/dbus
+DESC="system message bus"
+EVENTDIR=/etc/dbus-1/event.d
+
+test -x $DAEMON || exit 0
+
+# Source defaults file; edit that file to configure this script.
+ENABLED=1
+PARAMS=""
+if [ -e /etc/default/dbus ]; then
+ . /etc/default/dbus
+fi
+
+test "$ENABLED" != "0" || exit 0
+
+start_it_up()
+{
+ if [ ! -d $PIDDIR ]; then
+ mkdir -p $PIDDIR
+ chown $DAEMONUSER $PIDDIR
+ chgrp $DAEMONUSER $PIDDIR
+ fi
+ if [ -e $PIDFILE ]; then
+ PIDDIR=/proc/$(cat $PIDFILE)
+ if [ -d ${PIDDIR} -a "$(readlink -f ${PIDDIR}/exe)" = "${DAEMON}" ]; then
+ echo "$DESC already started; not starting."
+ else
+ echo "Removing stale PID file $PIDFILE."
+ rm -f $PIDFILE
+ fi
+ fi
+
+ if [ ! -d $UUIDDIR ]; then
+ mkdir -p $UUIDDIR
+ chown $DAEMONUSER $UUIDDIR
+ chgrp $DAEMONUSER $UUIDDIR
+ fi
+
+ dbus-uuidgen --ensure
+
+ echo -n "Starting $DESC: "
+ start-stop-daemon --start --quiet --pidfile $PIDFILE \
+ --user $DAEMONUSER --exec $DAEMON -- --system $PARAMS
+ echo "$NAME."
+ if [ -d $EVENTDIR ]; then
+ run-parts --arg=start $EVENTDIR
+ fi
+}
+
+shut_it_down()
+{
+ if [ -d $EVENTDIR ]; then
+ # TODO: --reverse when busybox supports it
+ run-parts --arg=stop $EVENTDIR
+ fi
+ echo -n "Stopping $DESC: "
+ start-stop-daemon --stop --quiet --pidfile $PIDFILE \
+ --user $DAEMONUSER
+ # We no longer include these arguments so that start-stop-daemon
+ # can do its job even given that we may have been upgraded.
+ # We rely on the pidfile being sanely managed
+ # --exec $DAEMON -- --system $PARAMS
+ echo "$NAME."
+ rm -f $PIDFILE
+}
+
+reload_it()
+{
+ echo -n "Reloading $DESC config: "
+ dbus-send --print-reply --system --type=method_call \
+ --dest=org.freedesktop.DBus \
+ / org.freedesktop.DBus.ReloadConfig > /dev/null
+ # hopefully this is enough time for dbus to reload it's config file.
+ echo "done."
+}
+
+case "$1" in
+ start)
+ start_it_up
+ ;;
+ stop)
+ shut_it_down
+ ;;
+ reload|force-reload)
+ reload_it
+ ;;
+ restart)
+ shut_it_down
+ sleep 1
+ start_it_up
+ ;;
+ *)
+ echo "Usage: /etc/init.d/$NAME {start|stop|restart|reload|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/packages/dbus/dbus-1.0.2/fix-install-daemon.patch b/packages/dbus/dbus-1.0.2/fix-install-daemon.patch
new file mode 100644
index 0000000000..c31786357d
--- /dev/null
+++ b/packages/dbus/dbus-1.0.2/fix-install-daemon.patch
@@ -0,0 +1,13 @@
+Index: dbus-0.94/bus/Makefile.am
+===================================================================
+--- dbus-0.94.orig/bus/Makefile.am 2006-10-01 17:36:18.000000000 +0200
++++ dbus-0.94/bus/Makefile.am 2006-10-14 21:40:05.000000000 +0200
+@@ -110,7 +110,7 @@
+ $(mkinstalldirs) $(DESTDIR)$(DBUS_DAEMONDIR); \
+ chmod 755 $(DESTDIR)$(DBUS_DAEMONDIR); \
+ fi
+- $(INSTALL_PROGRAM) dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR)
++ $(INSTALL_PROGRAM) .libs/dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR)
+ $(mkinstalldirs) $(DESTDIR)$(localstatedir)/run/dbus
+ $(mkinstalldirs) $(DESTDIR)$(configdir)/system.d
+ $(mkinstalldirs) $(DESTDIR)$(datadir)/dbus-1/services
diff --git a/packages/dbus/dbus-1.0.2/fix-waitpid.patch b/packages/dbus/dbus-1.0.2/fix-waitpid.patch
new file mode 100644
index 0000000000..80c431809c
--- /dev/null
+++ b/packages/dbus/dbus-1.0.2/fix-waitpid.patch
@@ -0,0 +1,11 @@
+--- /tmp/dbus-launch.c 2007-02-05 18:43:24.000000000 +0100
++++ dbus-1.0.2/tools/dbus-launch.c 2007-02-05 18:43:37.675251000 +0100
+@@ -622,7 +622,7 @@
+
+ exit_with_session = FALSE;
+ config_file = NULL;
+-
++ signal(SIGCHLD, SIG_DFL);
+ prev_arg = NULL;
+ i = 1;
+ while (i < argc)
diff --git a/packages/dbus/dbus-c++-native_svn.bb b/packages/dbus/dbus-c++-native_svn.bb
new file mode 100644
index 0000000000..5599aeb1d2
--- /dev/null
+++ b/packages/dbus/dbus-c++-native_svn.bb
@@ -0,0 +1,21 @@
+require dbus-c++_${PV}.bb
+inherit native
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-c++"
+# actually dbus-native and expat-native, but even the bearest build machine should have that nowadays...
+DEPENDS = ""
+
+do_compile() {
+ oe_runmake -C src libdbus-c++-1.la
+ oe_runmake -C tools dbusxx-xml2cpp
+ install -m 0755 tools/dbusxx-xml2cpp ${STAGING_BINDIR_NATIVE}
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install() {
+ :
+}
+
diff --git a/packages/dbus/dbus-c++/.mtn2git_empty b/packages/dbus/dbus-c++/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/dbus/dbus-c++/.mtn2git_empty
diff --git a/packages/dbus/dbus-c++/fix-linking.patch b/packages/dbus/dbus-c++/fix-linking.patch
new file mode 100644
index 0000000000..822216916b
--- /dev/null
+++ b/packages/dbus/dbus-c++/fix-linking.patch
@@ -0,0 +1,13 @@
+Index: dbus/tools/Makefile.am
+===================================================================
+--- dbus.orig/tools/Makefile.am
++++ dbus/tools/Makefile.am
+@@ -16,7 +16,7 @@ endif
+ bin_PROGRAMS = dbusxx-xml2cpp dbusxx-introspect
+
+ dbusxx_xml2cpp_SOURCES = xml.h xml.cpp xml2cpp.h xml2cpp.cpp
+-dbusxx_xml2cpp_LDADD = $(libdbus_cxx_la)
++dbusxx_xml2cpp_LDADD = $(libdbus_cxx_la) -lexpat
+
+ dbusxx_introspect_SOURCES = introspect.h introspect.cpp
+ dbusxx_introspect_LDADD = $(libdbus_cxx_la)
diff --git a/packages/dbus/dbus-c++_svn.bb b/packages/dbus/dbus-c++_svn.bb
new file mode 100644
index 0000000000..5be58741dc
--- /dev/null
+++ b/packages/dbus/dbus-c++_svn.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "C++ bindings for dbus"
+LICENSE = "LGPL"
+SECTION = "libs"
+DEPENDS = "dbus dbus-c++-native expat"
+
+SRC_URI = "svn://dev.openwengo.org/svn/openwengo/wengophone-ng/branches/wengophone-dbus-api/libs;module=dbus;proto=http"
+# file://fix-linking.patch;patch=1"
+S = "${WORKDIR}/dbus"
+
+inherit autotools pkgconfig
+
+do_compile_prepend() {
+ find . -name "Makefile.am" |xargs sed -i -e 's,$(top_builddir)/tools/dbusxx-xml2cpp,dbusxx-xml2cpp,'
+}
+
+FILES_${PN}-dbg += "${bindir}/dbusxx-xml2cpp ${bindir}/dbusxx-introspect"
+FILES_${PN}-dev += "${bindir}/.dev"
+FILES_${PN} = "${libdir}/*.so.*"
+
diff --git a/packages/dbus/dbus-glib-0.74/.mtn2git_empty b/packages/dbus/dbus-glib-0.74/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/dbus/dbus-glib-0.74/.mtn2git_empty
diff --git a/packages/dbus/dbus-glib-0.74/no-examples.patch b/packages/dbus/dbus-glib-0.74/no-examples.patch
new file mode 100644
index 0000000000..483153db74
--- /dev/null
+++ b/packages/dbus/dbus-glib-0.74/no-examples.patch
@@ -0,0 +1,8 @@
+--- dbus-glib-0.70/dbus/Makefile.am.orig 2006-07-23 16:04:43.000000000 +0200
++++ dbus-glib-0.70/dbus/Makefile.am 2006-07-23 16:04:52.000000000 +0200
+@@ -1,4 +1,4 @@
+-SUBDIRS = . examples
++SUBDIRS = .
+
+ INCLUDES=-I$(top_srcdir) $(DBUS_CFLAGS) $(DBUS_GLIB_CFLAGS) $(DBUS_GLIB_TOOL_CFLAGS) -DDBUS_COMPILATION=1 -DDBUS_LOCALEDIR=\"$(prefix)/@DATADIRNAME@/locale\"
+
diff --git a/packages/dbus/dbus-glib-0.74/no-introspect.patch b/packages/dbus/dbus-glib-0.74/no-introspect.patch
new file mode 100644
index 0000000000..9115801f71
--- /dev/null
+++ b/packages/dbus/dbus-glib-0.74/no-introspect.patch
@@ -0,0 +1,14 @@
+Index: dbus-glib-0.73/tools/Makefile.am
+===================================================================
+--- dbus-glib-0.73.orig/tools/Makefile.am 2006-10-25 21:10:36.000000000 +0200
++++ dbus-glib-0.73/tools/Makefile.am 2006-10-27 10:07:35.000000000 +0200
+@@ -3,9 +3,6 @@
+ nodist_libdbus_glib_HEADERS = dbus-glib-bindings.h
+ libdbus_glibdir = $(includedir)/dbus-1.0/dbus
+
+-dbus-glib-bindings.h: dbus-bus-introspect.xml $(top_builddir)/dbus/dbus-binding-tool$(EXEEXT)
+- $(top_builddir)/dbus/dbus-binding-tool --mode=glib-client --prefix=dbus_bus --output=dbus-glib-bindings.h dbus-bus-introspect.xml
+-
+ BUILT_SOURCES = dbus-glib-bindings.h dbus-bus-introspect.xml
+
+ if USE_INTROSPECT_XML
diff --git a/packages/dbus/dbus-glib-native-0.74/.mtn2git_empty b/packages/dbus/dbus-glib-native-0.74/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/dbus/dbus-glib-native-0.74/.mtn2git_empty
diff --git a/packages/dbus/dbus-glib-native-0.74/run-with-tmp-session-bus.patch b/packages/dbus/dbus-glib-native-0.74/run-with-tmp-session-bus.patch
new file mode 100644
index 0000000000..ba117d0309
--- /dev/null
+++ b/packages/dbus/dbus-glib-native-0.74/run-with-tmp-session-bus.patch
@@ -0,0 +1,23 @@
+Index: dbus-glib-0.72/tools/run-with-tmp-session-bus.sh
+===================================================================
+--- dbus-glib-0.72.orig/tools/run-with-tmp-session-bus.sh 2006-09-27 14:27:25.000000000 +0200
++++ dbus-glib-0.72/tools/run-with-tmp-session-bus.sh 2006-10-27 10:13:57.000000000 +0200
+@@ -30,16 +30,15 @@
+ echo "escaped service dir is: $ESCAPED_SERVICE_DIR" >&2
+
+ ## create a configuration file based on the standard session.conf
+-cat $DBUS_TOP_SRCDIR/tools/session.conf | \
++cat $datadir/dbus/session.conf | \
+ sed -e 's/<servicedir>.*$/<servicedir>'$ESCAPED_SERVICE_DIR'<\/servicedir>/g' | \
+ sed -e 's/<include.*$//g' \
+ > $CONFIG_FILE
+
+ echo "Created configuration file $CONFIG_FILE" >&2
+
+-export PATH=$DBUS_TOP_BUILDDIR/bus:$PATH
+ ## the libtool script found by the path search should already do this, but
+-export LD_LIBRARY_PATH=$DBUS_TOP_BUILDDIR/dbus/.libs:$LD_LIBRARY_PATH
++export LD_LIBRARY_PATH=$libdir:$LD_LIBRARY_PATH
+
+ unset DBUS_SESSION_BUS_ADDRESS
+ unset DBUS_SESSION_BUS_PID
diff --git a/packages/dbus/dbus-glib-native_0.74.bb b/packages/dbus/dbus-glib-native_0.74.bb
new file mode 100644
index 0000000000..d76cc043d4
--- /dev/null
+++ b/packages/dbus/dbus-glib-native_0.74.bb
@@ -0,0 +1,21 @@
+SECTION = "base"
+PR = "r0"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+DESCRIPTION = "message bus system for applications to talk to one another"
+LICENSE = "GPL"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-${PV}.tar.gz \
+ file://run-with-tmp-session-bus.patch;patch=1"
+
+inherit autotools pkgconfig gettext native
+
+S = "${WORKDIR}/dbus-glib-${PV}"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-glib-${PV}"
+DEPENDS = "glib-2.0-native dbus-native"
+
+do_stage() {
+ oe_runmake install
+ install -d ${STAGING_DATADIR}/dbus
+ install -m 0644 tools/dbus-bus-introspect.xml ${STAGING_DATADIR}/dbus
+ install -m 0644 tools/dbus-glib-bindings.h ${STAGING_DATADIR}/dbus
+}
diff --git a/packages/dbus/dbus-glib_0.74.bb b/packages/dbus/dbus-glib_0.74.bb
new file mode 100644
index 0000000000..0a34c738c3
--- /dev/null
+++ b/packages/dbus/dbus-glib_0.74.bb
@@ -0,0 +1,28 @@
+SECTION = "base"
+PR = "r0"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+DESCRIPTION = "message bus system for applications to talk to one another"
+LICENSE = "GPL"
+DEPENDS = "expat glib-2.0 virtual/libintl dbus-glib-native dbus"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-${PV}.tar.gz \
+ file://no-examples.patch;patch=1 \
+ file://no-introspect.patch;patch=1"
+
+inherit autotools pkgconfig gettext
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${libdir}/dbus-1.0/include ${bindir}/dbus-glib-tool"
+
+do_configure_prepend() {
+ install -m 0644 ${STAGING_DATADIR_NATIVE}/dbus/dbus-bus-introspect.xml ${S}/tools/
+ install -m 0644 ${STAGING_DATADIR_NATIVE}/dbus/dbus-glib-bindings.h ${S}/tools/
+}
+
+do_stage () {
+ oe_libinstall -so -C dbus libdbus-glib-1 ${STAGING_LIBDIR}
+
+ autotools_stage_includes
+}
+
+FILES_${PN}-dev += "${bindir}/dbus-binding-tool"
diff --git a/packages/dbus/dbus-native_1.0.1.bb b/packages/dbus/dbus-native_1.0.1.bb
new file mode 100644
index 0000000000..a897ae5bba
--- /dev/null
+++ b/packages/dbus/dbus-native_1.0.1.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "message bus system for applications to talk to one another"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+LICENSE = "GPL"
+SECTION = "base"
+
+PR = "r0"
+
+DEPENDS = "glib-2.0-native libxml2-native expat-native"
+
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-1.0.1"
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
+ file://cross.patch;patch=1 \
+ "
+
+inherit autotools pkgconfig gettext native
+
+S = "${WORKDIR}/dbus-${PV}"
+
+EXTRA_OECONF = "--disable-qt --disable-qt3 --disable-gtk --disable-tests \
+ --disable-checks --disable-xml-docs --disable-doxygen-docs \
+ --with-xml=expat --without-x"
+
+do_stage () {
+ oe_runmake install
+ autotools_stage_all
+
+ # for dbus-glib-native introspection generation
+ install -d ${STAGING_DATADIR}/dbus
+ install -m 0644 bus/session.conf ${STAGING_DATADIR}/dbus/session.conf
+}
diff --git a/packages/dbus/dbus-python_0.71.bb b/packages/dbus/dbus-python_0.71.bb
index 7c80a1be3c..a2d9bd70b3 100644
--- a/packages/dbus/dbus-python_0.71.bb
+++ b/packages/dbus/dbus-python_0.71.bb
@@ -1,14 +1,10 @@
-DEFAULT_PREFERENCE="-1"
-
-SECTION = "devel/python"
-PRIORITY = "optional"
-HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
DESCRIPTION = "message bus system for applications to talk to one another - python bindings"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
LICENSE = "GPL"
+SECTION = "devel/python"
+DEPENDS = "python-pyrex-native dbus dbus-glib"
PR = "r0"
-DEPENDS = "python-native"
-SRC_URI = "http://freedesktop.org/software/dbus/releases/dbus-python-${PV}.tar.gz \
- file://cross.patch;patch=1"
+SRC_URI = "http://freedesktop.org/software/dbus/releases/dbus-python-${PV}.tar.gz"
inherit distutils
diff --git a/packages/dbus/dbus.inc b/packages/dbus/dbus.inc
new file mode 100644
index 0000000000..b60cc661eb
--- /dev/null
+++ b/packages/dbus/dbus.inc
@@ -0,0 +1,66 @@
+SECTION = "base"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+DESCRIPTION = "message bus system for applications to talk to one another"
+LICENSE = "GPL"
+DEPENDS = "expat glib-2.0 virtual/libintl"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://freedesktop.org/software/dbus/releases/dbus-${PV}.tar.gz \
+ file://cross.patch;patch=1 \
+ file://tmpdir.patch;patch=1 \
+ file://dbus-1.init \
+ "
+
+inherit autotools pkgconfig update-rc.d gettext
+
+INITSCRIPT_NAME = "dbus-1"
+INITSCRIPT_PARAMS = "defaults"
+
+CONFFILES_${PN} = "${sysconfdir}/dbus-1/system.conf ${sysconfdir}/dbus-1/session.conf"
+
+FILES_${PN} = "${bindir}/dbus-daemon* ${bindir}/dbus-uuidgen ${bindir}/dbus-launch ${bindir}/dbus-cleanup-sockets ${bindir}/dbus-send ${bindir}/dbus-monitor ${sysconfdir} ${datadir}/dbus-1/services ${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${libdir}/dbus-1.0/include ${bindir}/dbus-glib-tool"
+
+pkg_postinst_dbus() {
+#!/bin/sh
+
+# can't do adduser stuff offline
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+MESSAGEUSER=messagebus
+MESSAGEHOME=/var/run/dbus
+
+mkdir -p $MESSAGEHOME || true
+chgrp "$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || addgroup "$MESSAGEUSER"
+chown "$MESSAGEUSER"."$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || adduser -S -h "$MESSAGEHOME" -H -D -G "$MESSAGEUSER" "$MESSAGEUSER"
+
+grep -q netdev: /etc/group || addgroup netdev
+
+}
+
+EXTRA_OECONF = "--disable-qt --disable-qt3 --disable-gtk --disable-tests \
+ --disable-checks --disable-xml-docs --disable-doxygen-docs \
+ --with-xml=expat --without-x"
+
+
+do_stage () {
+ oe_libinstall -so -C dbus libdbus-1 ${STAGING_LIBDIR}
+
+ autotools_stage_includes
+
+ mkdir -p ${STAGING_LIBDIR}/dbus-1.0/include/dbus/
+ install -m 0644 dbus/dbus-arch-deps.h ${STAGING_LIBDIR}/dbus-1.0/include/dbus/
+}
+
+do_install_append () {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/dbus-1.init ${D}${sysconfdir}/init.d/dbus-1
+}
+
+python populate_packages_prepend () {
+ if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
+ bb.data.setVar('PKG_dbus', 'dbus-1', d)
+}
diff --git a/packages/dbus/dbus_1.0.1.bb b/packages/dbus/dbus_1.0.1.bb
new file mode 100644
index 0000000000..f5e4aa16ea
--- /dev/null
+++ b/packages/dbus/dbus_1.0.1.bb
@@ -0,0 +1,5 @@
+require dbus.inc
+
+SRC_URI += "file://dbus-exploit-fix.patch;patch=1"
+
+PR = "r4"
diff --git a/packages/dbus/dbus_1.0.2.bb b/packages/dbus/dbus_1.0.2.bb
new file mode 100644
index 0000000000..f51265e434
--- /dev/null
+++ b/packages/dbus/dbus_1.0.2.bb
@@ -0,0 +1,14 @@
+require dbus.inc
+
+DEFAULT_PREFERENCE = "1"
+
+PR = "r8"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
+ file://tmpdir.patch;patch=1 \
+ file://dbus-1.init \
+ file://cross.patch;patch=1 \
+ file://fix-install-daemon.patch;patch=1"
+
+
+