aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 21:40:15 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 21:40:15 +0000
commit6ad3b4f697a0c942756e8c1c05ada98f2669804a (patch)
tree7f39b0f022767feb793941959ad735b5a45826f4 /packages
parente564befdc5026563800453603ab26a12d61cf1cd (diff)
downloadopenembedded-6ad3b4f697a0c942756e8c1c05ada98f2669804a.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/22 21:15:37+01:00 (none)!koen Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into lieve.(none):/data/build/oe/clean-tree/openembedded 2005/02/22 21:15:01+01:00 (none)!koen matchbox-wm_svn.bb: update mb-wm_svn to prevent mallum from kicking me in the face 2005/02/22 21:05:04+01:00 dyndns.org!reenoo gst-plugins: explicitely disable gconf. 2005/02/22 20:17:24+01:00 dyndns.org!reenoo Merge oe-devel@oe-devel.bkbits.net:openembedded into sugarcube.dyndns.org:/home2/oe/bakery/openembedded 2005/02/22 20:16:01+01:00 dyndns.org!reenoo gst-plugins: really fix lame configure check. disable libcaca. BKrev: 421ba6bfimvQbljcKhXB50bufAKm4A
Diffstat (limited to 'packages')
-rw-r--r--packages/gstreamer/files/lame-autoconf.patch21
-rw-r--r--packages/gstreamer/gst-plugins_0.8.6.bb55
-rw-r--r--packages/matchbox-wm/matchbox-wm_svn.bb12
3 files changed, 83 insertions, 5 deletions
diff --git a/packages/gstreamer/files/lame-autoconf.patch b/packages/gstreamer/files/lame-autoconf.patch
index e69de29bb2..3fb85e7d88 100644
--- a/packages/gstreamer/files/lame-autoconf.patch
+++ b/packages/gstreamer/files/lame-autoconf.patch
@@ -0,0 +1,21 @@
+--- gst-plugins-0.8.6.orig/configure.ac 2004-11-25 16:41:47.000000000 +0100
++++ gst-plugins-0.8.6/configure.ac 2005-02-22 19:02:58.000000000 +0100
+@@ -1135,8 +1135,9 @@
+ GST_CHECK_LIBHEADER(LAME, mp3lame, lame_init, -lm, lame/lame.h, HAVE_LAME="yes" LAME_LIBS="-lmp3lame -lm")
+ ])
+ dnl is lame presets available
++if test "x$HAVE_LAME" = "xyes"; then
+ LAME_CFLAGS=""
+-AC_TRY_RUN([
++AC_TRY_COMPILE([
+ #include <lame/lame.h>
+ int main (int argc, char *argv[])
+ {
+@@ -1144,6 +1145,7 @@
+ return 0;
+ }
+ ],[LAME_CFLAGS="-DGSTLAME_PRESET"],[LAME_CFLAGS=""])
++fi
+ AC_SUBST(LAME_CFLAGS)
+ AC_SUBST(LAME_LIBS)
+
diff --git a/packages/gstreamer/gst-plugins_0.8.6.bb b/packages/gstreamer/gst-plugins_0.8.6.bb
index e69de29bb2..7e737fc14b 100644
--- a/packages/gstreamer/gst-plugins_0.8.6.bb
+++ b/packages/gstreamer/gst-plugins_0.8.6.bb
@@ -0,0 +1,55 @@
+LICENSE = GPL
+DESCRIPTION = "Plugins for GStreamer"
+SECTION = "x11/libs"
+PRIORITY = "optional"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+PR = "r2"
+
+DEPENDS = "gstreamer libmikmod libmad libogg tremor libvorbis libid3tag gpe-soundserver gconf"
+
+SRC_URI = "http://gstreamer.freedesktop.org/src/gst-plugins/gst-plugins-${PV}.tar.bz2 \
+ file://try-esdsink.patch;patch=1 \
+ file://lame-autoconf.patch;patch=1"
+
+EXTRA_OECONF = "--disable-docs-build --disable-dependency-tracking --disable-aalib --disable-arts \
+ --disable-artsc --disable-libfame --disable-sdl --disable-shout2 \
+ --disable-gnome_vfs --disable-gconf --disable-libcaca"
+
+inherit autotools pkgconfig gconf
+
+acpaths = "-I ${S}/common/m4 -I ${S}/m4"
+
+LIBV = "0.8"
+
+plugin_postinst() {
+ if [ x"$D" = "x" ]; then
+ gst-register --gst-registry=/var/cache/gstreamer-0.8/registry.xml
+ fi
+}
+
+python populate_packages_prepend () {
+ gst_libdir = bb.data.expand('${libdir}/gstreamer-${LIBV}', d)
+ postinst = bb.data.getVar('plugin_postinst', d, 1)
+
+ do_split_packages(d, gst_libdir, '^libgst(.*)\.so$', 'gst-plugin-%s', 'GStreamer plugin for %s', postinst=postinst)
+ do_split_packages(d, gst_libdir, '^libgst(.*)\.l?a$', 'gst-plugin-%s-dev', 'GStreamer plugin for %s (development files)')
+}
+
+do_stage() {
+ autotools_stage_includes
+ while read a b; do
+ oe_libinstall -C gst-libs/gst/$a -so libgst$b ${STAGING_LIBDIR}
+ done <<EOF
+. interfaces-0.8
+audio audio
+audio audiofilter
+gconf gconf-0.8
+idct idct
+media-info media-info-0.8
+play play-0.8
+resample resample
+riff riff
+video video
+xwindowlistener xwindowlistener
+EOF
+}
diff --git a/packages/matchbox-wm/matchbox-wm_svn.bb b/packages/matchbox-wm/matchbox-wm_svn.bb
index ad6b67414b..606e3ebc01 100644
--- a/packages/matchbox-wm/matchbox-wm_svn.bb
+++ b/packages/matchbox-wm/matchbox-wm_svn.bb
@@ -13,12 +13,13 @@ S = "${WORKDIR}/matchbox-window-manager"
inherit autotools pkgconfig
FILES_${PN} = "${bindir} \
- ${datadir}/matchbox \
- ${datadir}/themes/blondie/matchbox \
- ${datadir}/themes/bluebox/matchbox \
- ${datadir}/themes/borillo/matchbox"
+ ${datadir}/matchbox \
+ ${sysconfdir}/matchbox \
+ ${datadir}/themes/blondie/matchbox \
+ ${datadir}/themes/Default/matchbox \
+ ${datadir}/themes/MBOpus/matchbox"
-EXTRA_OECONF = "--enable-composite --enable-startup-notification --enable-expat"
+EXTRA_OECONF = "--enable-composite --enable-startup-notification --disable-xrm"
pkg_postinst() {
update-alternatives --install ${bindir}/x-window-manager x-window-manager ${bindir}/matchbox-session 10
@@ -27,3 +28,4 @@ update-alternatives --install ${bindir}/x-window-manager x-window-manager ${bind
pkg_postrm() {
update-alternatives --remove x-window-manager ${bindir}/matchbox-session
}
+