aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-02-15 23:39:43 -0800
committerKhem Raj <raj.khem@gmail.com>2009-02-15 23:39:43 -0800
commit70c7efd81f4815832e4b7768eacd1daa2f8df03b (patch)
treeeba99d3ca3d1c81aa904a65f944416be8a4d4eea /packages
parent05ae151bd506b343d7f5de8f0610221393eb55ea (diff)
downloadopenembedded-70c7efd81f4815832e4b7768eacd1daa2f8df03b.tar.gz
yasr_0.6.9.bb: New recipe
Diffstat (limited to 'packages')
-rw-r--r--packages/yasr/files/yasr-0.6.9-gcc43.patch26
-rw-r--r--packages/yasr/files/yasr-0.6.9-remove-m4.patch29
-rw-r--r--packages/yasr/yasr_0.6.9.bb16
3 files changed, 71 insertions, 0 deletions
diff --git a/packages/yasr/files/yasr-0.6.9-gcc43.patch b/packages/yasr/files/yasr-0.6.9-gcc43.patch
new file mode 100644
index 0000000000..ee2b1a6ef7
--- /dev/null
+++ b/packages/yasr/files/yasr-0.6.9-gcc43.patch
@@ -0,0 +1,26 @@
+diff -NrU5 yasr-0.6.9.orig/yasr/yasr.h yasr-0.6.9/yasr/yasr.h
+--- yasr-0.6.9.orig/yasr/yasr.h 2008-06-29 01:23:44.000000000 +0200
++++ yasr-0.6.9/yasr/yasr.h 2008-06-29 01:37:00.000000000 +0200
+@@ -306,22 +306,10 @@
+ extern void opt_say(int num, int flag);
+ extern void opt_set(int num, void *val);
+ extern void opt_queue_empty(int ll);
+ extern void opt_write(FILE * fp);
+
+-/* openpty.c prototypes */
+-extern int openpty(int *, int *, char *, struct termios *, struct winsize *);
+-
+-/* cfmakeraw.c prototypes */
+-extern void cfmakeraw(struct termios *);
+-
+-/* login_tty.c prototypes */
+-extern int login_tty(int);
+-
+-/* forkpty.c prototypes */
+-extern int forkpty(int *, char *, struct termios *, struct winsize *);
+-
+ /* tbc - Would it be more efficient to ensure that "blank" grids always held
+ ascii 0x20 rather than ascii 0x00? */
+ #define y_isblank(ch) ((ch & 0xdf) == 0)
+ #define cblank(r, c) ((win->row[r][c] & 0xdf) == 0)
+ #define ttssend(x) if (x) tts_send(x, strlen(x))
diff --git a/packages/yasr/files/yasr-0.6.9-remove-m4.patch b/packages/yasr/files/yasr-0.6.9-remove-m4.patch
new file mode 100644
index 0000000000..fa05f0791f
--- /dev/null
+++ b/packages/yasr/files/yasr-0.6.9-remove-m4.patch
@@ -0,0 +1,29 @@
+diff -Naur yasr-0.6.9.orig/Makefile.am yasr-0.6.9/Makefile.am
+--- yasr-0.6.9.orig/Makefile.am 2008-02-02 06:44:05.000000000 -0600
++++ yasr-0.6.9/Makefile.am 2009-02-06 08:37:07.000000000 -0600
+@@ -7,7 +7,6 @@
+
+ SUBDIRS = \
+ $(yasr_DDIRS) \
+-m4 \
+ po
+
+ pkgdata_DATA = \
+@@ -25,4 +24,3 @@
+ README-fr \
+ README-ru
+
+-ACLOCAL_AMFLAGS = -I m4
+diff -Naur yasr-0.6.9.orig/configure.in yasr-0.6.9/configure.in
+--- yasr-0.6.9.orig/configure.in 2008-02-02 07:09:04.000000000 -0600
++++ yasr-0.6.9/configure.in 2009-02-06 08:36:43.000000000 -0600
+@@ -59,8 +59,7 @@
+ AM_GNU_GETTEXT(external)
+ AM_GNU_GETTEXT_VERSION([0.17])
+
+-AC_OUTPUT([ m4/Makefile
+-Makefile
++AC_OUTPUT([ Makefile
+ yasr/Makefile
+ acclogin/Makefile
+ po/Makefile.in
diff --git a/packages/yasr/yasr_0.6.9.bb b/packages/yasr/yasr_0.6.9.bb
new file mode 100644
index 0000000000..4d6fd28ede
--- /dev/null
+++ b/packages/yasr/yasr_0.6.9.bb
@@ -0,0 +1,16 @@
+# Copyright (C) 2009 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "Yet Another Screen Reader(yasr) is a \
+ general-purpose console screen reader"
+HOMEPAGE = "http://yasr.sf.net"
+LICENSE = "GPLv2"
+SECTION = "console/utils"
+SUGGESTS = "speech-dispatcher"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/yasr/yasr-${PV}.tar.gz \
+ file://yasr-0.6.9-gcc43.patch;patch=1 \
+ file://yasr-0.6.9-remove-m4.patch;patch=1 \
+ "
+
+inherit autotools