aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorRoger Monk <r-monk@ti.com>2009-02-18 14:05:11 +0100
committerKoen Kooi <koen@openembedded.org>2009-02-18 15:13:51 +0100
commit9485db7d15f237dea8cc841e6a1b5bc4930f15da (patch)
tree0dfce75146fe7e24d93eb0fc688cfe91fa464f89 /packages
parent09b88241b5e95c441544a02c50db885cbf6d8ee8 (diff)
downloadopenembedded-9485db7d15f237dea8cc841e6a1b5bc4930f15da.tar.gz
codec-engine: fix lpm build and clean up old files
Diffstat (limited to 'packages')
-rw-r--r--packages/dsplink/codec-engine_2.21.bb7
-rw-r--r--packages/dsplink/dsplink.inc34
-rw-r--r--packages/dsplink/dsplink_1.60.bb2
-rw-r--r--packages/dsplink/files/Makefile-dsplink-kbuild74
-rwxr-xr-xpackages/dsplink/files/Makefile.dsplink59
-rw-r--r--packages/dsplink/files/cmemk-class-device-27.diff11
-rw-r--r--packages/dsplink/files/dmai-built-with-angstrom.patch (renamed from packages/dsplink/files/built-with-angstrom.patch)0
-rw-r--r--packages/dsplink/files/dmai-do-not-panic-on-mixer-failure.patch (renamed from packages/dsplink/files/do-not-panic-on-mixer-failure.patch)0
-rw-r--r--packages/dsplink/files/dmai-support-32bit-align.patch (renamed from packages/dsplink/files/support-32bit-align.patch)0
-rw-r--r--packages/dsplink/files/dmai-unbreak-xdc-args.patch (renamed from packages/dsplink/files/unbreak-xdc-args.patch)0
-rw-r--r--packages/dsplink/files/dmai-update-cpu-name.patch (renamed from packages/dsplink/files/update-cpu-name.patch)0
-rw-r--r--packages/dsplink/files/dmai-update-fb-display.patch (renamed from packages/dsplink/files/update-fb-display.patch)0
-rw-r--r--packages/dsplink/files/dmai-update-v4l2-display.patch (renamed from packages/dsplink/files/update-v4l2-display.patch)0
-rw-r--r--packages/dsplink/files/lpm-make-symbol-warnings-fix.patch117
-rw-r--r--packages/dsplink/files/xdcpaths.mak232
-rw-r--r--packages/dsplink/readme.txt2
16 files changed, 142 insertions, 396 deletions
diff --git a/packages/dsplink/codec-engine_2.21.bb b/packages/dsplink/codec-engine_2.21.bb
index 5040867178..3ecef31235 100644
--- a/packages/dsplink/codec-engine_2.21.bb
+++ b/packages/dsplink/codec-engine_2.21.bb
@@ -8,7 +8,7 @@ RDEPENDS = "update-modules"
inherit module
# tconf from xdctools dislikes '.' in pwd :/
-PR = "r8"
+PR = "r9"
PV = "221"
# Get CE tarball from TI website, place in sources and calculate
@@ -19,8 +19,7 @@ SRC_URI = "http://install.tarball.in.source.dir/codec_engine_2_21.tar.gz \
file://cmem-class-device-27-and-sched-include-fix.patch;patch=1 \
file://dsplink-semaphore-27.patch;patch=1 \
file://lpm-device-create-and-semaphore-include-fix.patch;patch=1 \
- file://Makefile.dsplink \
- file://Makefile-dsplink-kbuild \
+ file://lpm-make-symbol-warnings-fix.patch;patch=1 \
file://Makefile-dsplink-gpp \
file://Makefile-dsplink-dsp \
"
@@ -76,7 +75,7 @@ do_compile_append() {
do_stage_append() {
install -d ${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/codecengine
- cp -pPrf ${S}/* ${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/codecengine/
+ cp -pPrf ${S}/* ${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/codecengine/
ln -sf ${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/codecengine/packages/ti/sdo/ce ${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/codecengine/cetools/packages/ti/sdo/
}
diff --git a/packages/dsplink/dsplink.inc b/packages/dsplink/dsplink.inc
index 002d08d2a7..f617a7e3d8 100644
--- a/packages/dsplink/dsplink.inc
+++ b/packages/dsplink/dsplink.inc
@@ -58,36 +58,42 @@ do_compile () {
unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
export KDIR=${STAGING_KERNEL_DIR}
- make -e all
+
+ make -e driver
+ make -e library
+ make -e samples
+
make -e -f ${WORKDIR}/Makefile-dsplink-dsp
+ cp -a * ${DSPLINK}/gpp/export/BIN/Linux/${DSPLINKPLATFORM}/RELEASE
#lpm bits
if [ -e ${S}/cetools/packages/ti/bios/power/ ] ; then
- echo "MVTOOL_PREFIX=${TARGET_PREFIX}" > ${S}/Rules.make
- echo "UCTOOL_PREFIX=${TARGET_PREFIX}" >> ${S}/Rules.make
- echo "LINUXKERNEL_INSTALL_DIR=${STAGING_KERNEL_DIR}" >> ${S}/Rules.make
- #export DSPLINK=${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/dsplink
-
+
# Build the DSP power manager kernel module
cd ${S}/cetools/packages/ti/bios/power/modules/${DSPPOWERSOC}/lpm
+ # Still need to move this into the patch file
if [ $(echo ${KERNEL_VERSION} | cut -c5,6) -gt 26 ] ; then
sed -i -e s:asm/semaphore:linux/semaphore: lpm_driver.c
fi
+ #what is this for?
rm -f *o
- make KERNEL_PATH=${STAGING_KERNEL_DIR} \
- KERNEL_SRC=${STAGING_KERNEL_DIR} \
- KERNEL_DIR=${STAGING_KERNEL_DIR} \
- KERNEL_VERSION=${KERNEL_VERSION} \
- TOOL_PREFIX=${TARGET_PREFIX} \
- DSPLINK_REPO=${DSPLINK}/../ \
- CC="${KERNEL_CC}" LD="${KERNEL_LD}" \
- AR="${KERNEL_AR}"
+
+ # lpm also needs KERNEL_INSTALL_DIR and MVTOOL_PREFIX which come from ti-paths.inc
+ export DSPLINK_REPO=${DSPLINK}/..
+ # should move the clean step into the clean stage..
+ #oe_runmake clean
+ oe_runmake
fi
#cmemk bits
if [ -e ${S}/cetools/packages/ti/sdo/linuxutils/cmem ] ; then
+ echo "MVTOOL_PREFIX=${TARGET_PREFIX}" > ${S}/Rules.make
+ echo "UCTOOL_PREFIX=${TARGET_PREFIX}" >> ${S}/Rules.make
+ echo "LINUXKERNEL_INSTALL_DIR=${STAGING_KERNEL_DIR}" >> ${S}/Rules.make
+ #export DSPLINK=${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/dsplink
+
# Build the cmem kernel module
# We unset CFLAGS because kernel modules need different ones, this is basically a verbatim copy of kernel.bbclass and module-base.bbclass
unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
diff --git a/packages/dsplink/dsplink_1.60.bb b/packages/dsplink/dsplink_1.60.bb
index 3814f6353e..127e559319 100644
--- a/packages/dsplink/dsplink_1.60.bb
+++ b/packages/dsplink/dsplink_1.60.bb
@@ -1,7 +1,7 @@
require dsplink.inc
# The tconf tool breaks if there is a '.' in your pwd
-PR = "r8"
+PR = "r9"
PE = "1"
PV = "160"
diff --git a/packages/dsplink/files/Makefile-dsplink-kbuild b/packages/dsplink/files/Makefile-dsplink-kbuild
deleted file mode 100644
index 0fdf896c86..0000000000
--- a/packages/dsplink/files/Makefile-dsplink-kbuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Composite Makefile
-DIRSEP=/
-
-TI_DSPLINK_RELATIVE_PATH := ../
-
-# include the CURRENTCFG.mk
-include $(DSPLINK)$(DIRSEP)config$(DIRSEP)BUILD$(DIRSEP)CURRENTCFG.MK
-
-# Generate the list of sources
-SOURCES :=
-include $(TI_DSPLINK_GPPROOT)$(DIRSEP)src$(DIRSEP)arch$(DIRSEP)SOURCES
-ARCH_SOURCES := $(addprefix $(TI_DSPLINK_RELATIVE_PATH)gpp$(DIRSEP)src$(DIRSEP)arch$(DIRSEP),$(SOURCES))
-SOURCES :=
-include $(TI_DSPLINK_GPPROOT)$(DIRSEP)src$(DIRSEP)ldrv$(DIRSEP)SOURCES
-LDRV_SOURCES := $(addprefix $(TI_DSPLINK_RELATIVE_PATH)gpp$(DIRSEP)src$(DIRSEP)ldrv$(DIRSEP),$(SOURCES))
-SOURCES :=
-include $(TI_DSPLINK_GPPROOT)$(DIRSEP)src$(DIRSEP)ldrv$(DIRSEP)$(TI_DSPLINK_GPPOS)$(DIRSEP)SOURCES
-LDRV_SOURCES += $(addprefix $(TI_DSPLINK_RELATIVE_PATH)gpp$(DIRSEP)src$(DIRSEP)ldrv$(DIRSEP)$(TI_DSPLINK_GPPOS)$(DIRSEP),$(SOURCES))
-SOURCES :=
-include $(TI_DSPLINK_GPPROOT)$(DIRSEP)src$(DIRSEP)gen$(DIRSEP)SOURCES
-GEN_SOURCES := $(addprefix $(TI_DSPLINK_RELATIVE_PATH)gpp$(DIRSEP)src$(DIRSEP)gen$(DIRSEP),$(SOURCES))
-SOURCES :=
-include $(TI_DSPLINK_GPPROOT)$(DIRSEP)src$(DIRSEP)pmgr$(DIRSEP)SOURCES
-PMGR_SOURCES := $(addprefix $(TI_DSPLINK_RELATIVE_PATH)gpp$(DIRSEP)src$(DIRSEP)pmgr$(DIRSEP),$(SOURCES))
-SOURCES :=
-include $(TI_DSPLINK_GPPROOT)$(DIRSEP)src$(DIRSEP)pmgr$(DIRSEP)$(TI_DSPLINK_GPPOS)$(DIRSEP)SOURCES
-PMGR_SOURCES += $(addpreifx $(TI_DSPLINK_RELATIVE_PATH)gpp$(DIRSEP)src$(DIRSEP)pmgr$(DIRSEP)$(TI_DSPLINK_GPPOS)$(DIRSEP),$(SOURCES))
-SOURCES :=
-include $(TI_DSPLINK_GPPROOT)$(DIRSEP)src$(DIRSEP)pmgr$(DIRSEP)$(TI_DSPLINK_GPPOS)$(DIRSEP)$(TI_DSPLINK_GPPOSVERSION)$(DIRSEP)SOURCES
-PMGR_SOURCES += $(addprefix $(TI_DSPLINK_RELATIVE_PATH)gpp$(DIRSEP)src$(DIRSEP)pmgr$(DIRSEP)$(TI_DSPLINK_GPPOS)$(DIRSEP)$(TI_DSPLINK_GPPOSVERSION)$(DIRSEP),$(SOURCES))
-SOURCES :=
-include $(TI_DSPLINK_GPPROOT)$(DIRSEP)src$(DIRSEP)osal$(DIRSEP)$(DIRSEP)SOURCES
-OSAL_SOURCES := $(addprefix $(TI_DSPLINK_RELATIVE_PATH)gpp$(DIRSEP)src$(DIRSEP)osal$(DIRSEP)$(DIRSEP),$(SOURCES))
-SOURCES :=
-include $(TI_DSPLINK_GPPROOT)$(DIRSEP)src$(DIRSEP)osal$(DIRSEP)$(TI_DSPLINK_GPPOS)$(DIRSEP)SOURCES
-OSAL_SOURCES += $(addprefix $(TI_DSPLINK_RELATIVE_PATH)gpp$(DIRSEP)src$(DIRSEP)osal$(DIRSEP)$(TI_DSPLINK_GPPOS)$(DIRSEP),$(SOURCES))
-SOURCES :=
-include $(TI_DSPLINK_GPPROOT)$(DIRSEP)src$(DIRSEP)osal$(DIRSEP)$(TI_DSPLINK_GPPOS)$(DIRSEP)$(TI_DSPLINK_GPPOSVERSION)$(DIRSEP)SOURCES
-OSAL_SOURCES += $(addprefix $(TI_DSPLINK_RELATIVE_PATH)gpp$(DIRSEP)src$(DIRSEP)osal$(DIRSEP)$(TI_DSPLINK_GPPOS)$(DIRSEP)$(TI_DSPLINK_GPPOSVERSION)$(DIRSEP),$(SOURCES))
-
-DSPLINK_SOURCES := $(ARCH_SOURCES) $(LDRV_SOURCES) $(GEN_SOURCES) $(OSAL_SOURCES) $(PMGR_SOURCES)
-DSPLINK_OBJS := $(foreach srcFile, $(DSPLINK_SOURCES),$(basename $(srcFile)).o)
-
-################################################################################################
-# USER SIDE
-# Generate the list of sources
-SOURCES :=
-include $(TI_DSPLINK_GPPROOT)$(DIRSEP)src$(DIRSEP)api$(DIRSEP)SOURCES
-API_SOURCES := $(addprefix $(TI_DSPLINK_RELATIVE_PATH)gpp$(DIRSEP)src$(DIRSEP)api$(DIRSEP),$(SOURCES))
-SOURCES :=
-include $(TI_DSPLINK_GPPROOT)$(DIRSEP)src$(DIRSEP)api$(DIRSEP)$(TI_DSPLINK_GPPOS)$(DIRSEP)SOURCES
-API_SOURCES += $(addprefix $(TI_DSPLINK_RELATIVE_PATH)gpp$(DIRSEP)src$(DIRSEP)api$(DIRSEP)$(TI_DSPLINK_GPPOS)$(DIRSEP),$(SOURCES))
-
-# CFLAGS
-EXTRA_CFLAGS = $(addprefix -D, $(TI_DSPLINK_GPP_DEFINES))
-EXTRA_CFLAGS += $(addprefix -I, $(TI_DSPLINK_GPP_INC_PATH))
-EXTRA_CFLAGS += -DEXPORT_SYMTAB
-EXTRA_CFLAGS += -DTRACE_KERNEL
-
-ifneq ($(KERNELRELEASE),)
-obj-m := dsplinkk.o
-libs-m := $(shell pwd)
-lib-m := $(foreach srcFile, $(API_SOURCES),$(basename $(srcFile)).o)
-dsplinkk-objs := $(DSPLINK_OBJS)
-else
-KDIR := /opt/montavista/pro/devkit/lsp/ti-davinci/linux-2.6.18_pro500
-PWD := $(shell pwd)
-all:
- $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules
-endif
-
-clean:
- find $(DSPLINK) -name "*.o" -exec rm {} \;
- rm -fr dsplinkk.ko dsplinkk.mod.c Module.symvers
diff --git a/packages/dsplink/files/Makefile.dsplink b/packages/dsplink/files/Makefile.dsplink
deleted file mode 100755
index f3228dd9e7..0000000000
--- a/packages/dsplink/files/Makefile.dsplink
+++ /dev/null
@@ -1,59 +0,0 @@
-#
-# ======== makeunix ========
-#
-
-# Import Tools Path from Rules.make
-#include Rules.make
-
-PROJECT_BASE_DIR = $(shell pwd)
-LINUXKERNEL_INSTALL_DIR:=some-path/kernel
-LINK_INSTALL_DIR := some-path/dsplink_1_51/dsplink
-
-# The prefix to be added before the GNU compiler tools (optionally including
-# path), i.e. "arm_v5t_le-" or "/opt/bin/arm_v5t_le-".
-GPPTOOL_DIR:=some-path/cross
-
-# ---- DSP tools ----
-DSP_BASE_CGTOOLS := some-path/cg6x_6_0_19
-DSP_BASE_BIOS := some-path/bios_5_32_03
-DSP_BASE_RTDX := some-path/bios_5_32_03/packages/ti/rtdx
-OSINC_PLATFORM1 := something
-ARCHIVER_AR := something
-
-
-# ---- construct Link build make vars ----
-GPP_MAKE_OPTS := COMPILER=$(GPPTOOL_DIR)/bin/arm-angstrom-linux-gnueabi-gcc \
- LINKER=$(GPPTOOL_DIR)/bin/arm-angstrom-linux-gnueabi-gcc \
- LD=$(GPPTOOL_DIR)/bin/arm-angstrom-linux-gnueabi-ld \
- ARCHIVER1=$(GPPTOOL_DIR)/bin/arm-angstrom-linux-gnueabi-ld \
- ARCHIVER2=$(GPPTOOL_DIR)/bin/arm-angstrom-linux-gnueabi-ld \
- CROSS_COMPILE=arm-angstrom-linux-gnueabi- \
- DSPLINK=$(LINK_INSTALL_DIR) \
- BASE_TOOLCHAIN=$(GPPTOOL_DIR) \
- BASE_BUILDOS=$(LINUXKERNEL_INSTALL_DIR) \
- ARCHIVER=$(ARCHIVER_AR) OSINC_PLATFORM=$(OSINC_PLATFORM1) \
-
-DSP_MAKE_OPTS := DSPLINK=$(DSPLINK) \
- DPPROOT=$(DSPLINK)/dsp \
- BASE_SABIOS=$(DSP_BASE_BIOS) \
- BASE_CGTOOLS=$(DSP_BASE_CGTOOLS) \
- BASE_RTDX=$(DSP_BASE_RTDX)
-
-
-# ======== all ========
-all: $(LINK_INSTALL_DIR)/packages/dsplink/gpp/export/BIN/Linux/Davinci/RELEASE/dsplinkk.ko
-
-$(LINK_INSTALL_DIR)/packages/dsplink/gpp/export/BIN/Linux/Davinci/RELEASE/dsplinkk.ko:
- @echo Building DSPLINK GPP driver, libs
- #make -s -C $(LINK_INSTALL_DIR)/gpp/src $(GPP_MAKE_OPTS)
- make -s -C $(DSPLINK)/gpp/src/samples $(GPP_MAKE_OPTS)
- @echo Building DSPLINK DSP libs and message sample for DaVinci...
- make -C $(DSPLINK)/dsp/src $(DSP_MAKE_OPTS)
- make -C $(DSPLINK)/dsp/src/samples $(DSP_MAKE_OPTS)
-
-# clean rules
-clean:
- @echo Cleaning DSPLINK GPP driver, libs
- make -s -C $(LINK_INSTALL_DIR)/gpp/src $(GPP_MAKE_OPTS) clean
- @rm -rf $(LINK_INSTALL_DIR)/gpp/export/BIN/*
- @rm -rf $(LINK_INSTALL_DIR)/gpp/export/INCLUDE/*
diff --git a/packages/dsplink/files/cmemk-class-device-27.diff b/packages/dsplink/files/cmemk-class-device-27.diff
deleted file mode 100644
index 1c51323457..0000000000
--- a/packages/dsplink/files/cmemk-class-device-27.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- /tmp/cmemk.c 2008-12-11 12:21:22.000000000 +0100
-+++ src/module/cmemk.c 2008-12-11 12:22:39.000000000 +0100
-@@ -1710,7 +1710,7 @@
- #ifdef USE_CLASS_DEVICE
- class_device_create(cmem_class, NULL, MKDEV(cmem_major, 0), NULL, "cmem");
- #else
-- device_create(cmem_class, NULL, MKDEV(cmem_major, 0), "cmem");
-+ device_create(cmem_class, NULL, MKDEV(cmem_major, 0), NULL, "cmem");
- #endif // USE_CLASS_DEVICE
- #endif // USE_CLASS_SIMPLE
- #endif // USE_UDEV
diff --git a/packages/dsplink/files/built-with-angstrom.patch b/packages/dsplink/files/dmai-built-with-angstrom.patch
index fc49789718..fc49789718 100644
--- a/packages/dsplink/files/built-with-angstrom.patch
+++ b/packages/dsplink/files/dmai-built-with-angstrom.patch
diff --git a/packages/dsplink/files/do-not-panic-on-mixer-failure.patch b/packages/dsplink/files/dmai-do-not-panic-on-mixer-failure.patch
index 20e1aece72..20e1aece72 100644
--- a/packages/dsplink/files/do-not-panic-on-mixer-failure.patch
+++ b/packages/dsplink/files/dmai-do-not-panic-on-mixer-failure.patch
diff --git a/packages/dsplink/files/support-32bit-align.patch b/packages/dsplink/files/dmai-support-32bit-align.patch
index 0ee817d9d9..0ee817d9d9 100644
--- a/packages/dsplink/files/support-32bit-align.patch
+++ b/packages/dsplink/files/dmai-support-32bit-align.patch
diff --git a/packages/dsplink/files/unbreak-xdc-args.patch b/packages/dsplink/files/dmai-unbreak-xdc-args.patch
index b9858d0615..b9858d0615 100644
--- a/packages/dsplink/files/unbreak-xdc-args.patch
+++ b/packages/dsplink/files/dmai-unbreak-xdc-args.patch
diff --git a/packages/dsplink/files/update-cpu-name.patch b/packages/dsplink/files/dmai-update-cpu-name.patch
index 052a8e3236..052a8e3236 100644
--- a/packages/dsplink/files/update-cpu-name.patch
+++ b/packages/dsplink/files/dmai-update-cpu-name.patch
diff --git a/packages/dsplink/files/update-fb-display.patch b/packages/dsplink/files/dmai-update-fb-display.patch
index 91c1dd15aa..91c1dd15aa 100644
--- a/packages/dsplink/files/update-fb-display.patch
+++ b/packages/dsplink/files/dmai-update-fb-display.patch
diff --git a/packages/dsplink/files/update-v4l2-display.patch b/packages/dsplink/files/dmai-update-v4l2-display.patch
index 8bb77d8473..8bb77d8473 100644
--- a/packages/dsplink/files/update-v4l2-display.patch
+++ b/packages/dsplink/files/dmai-update-v4l2-display.patch
diff --git a/packages/dsplink/files/lpm-make-symbol-warnings-fix.patch b/packages/dsplink/files/lpm-make-symbol-warnings-fix.patch
new file mode 100644
index 0000000000..031a16022f
--- /dev/null
+++ b/packages/dsplink/files/lpm-make-symbol-warnings-fix.patch
@@ -0,0 +1,117 @@
+diff -uNr codec_engine_2_21/cetools/packages/ti/bios/power/modules/omap3530/lpm/Makefile codec_engine_2_21_fix/cetools/packages/ti/bios/power/modules/omap3530/lpm/Makefile
+--- codec_engine_2_21/cetools/packages/ti/bios/power/modules/omap3530/lpm/Makefile 2008-11-05 00:38:57.000000000 +0000
++++ codec_engine_2_21_fix/cetools/packages/ti/bios/power/modules/omap3530/lpm/Makefile 2009-02-17 23:53:08.000000000 +0000
+@@ -1,5 +1,5 @@
+-#
+-# Copyright 2008 by Texas Instruments Incorporated.
++# --COPYRIGHT--,GPL
++# Copyright $(CPYYEAR) by Texas Instruments Incorporated.
+ #
+ # This program is free software: you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+@@ -12,31 +12,34 @@
+ #
+ # You should have received a copy of the GNU General Public License
+ # along with this program. If not, see <http://www.gnu.org/licenses/>
+-#
++# --/COPYRIGHT--
+ #
+
+ #
+ # This makefile will build the lpm_omap3530.ko driver.
+ #
+
++# If KERNELRELEASE is undefined, then this makefile has been invoked
++# directly from the command line. Invoke the kernel build system.
++ifeq ($(KERNELRELEASE),)
++
++
+ # Update these macros to reflect you environment.
+ #
+-# KERNEL_DIR = the Linux kernel source directory
+-# TOOL_PREFIX = the toolchain directory and decorated name prefix
++# LINUXKERNEL_INSTALL_DIR = the Linux kernel source directory
++# MVTOOL_PREFIX = the toolchain directory and decorated name prefix
+ # DSPLINK_REPO = the repository which contains DSP/BIOS LINK
+-# DSPLINK_BLD = the DSP/BIOS LINK build variant
+ #
+-KERNEL_DIR = /db/toolsrc/library/toolsC38/vendors/mvl/arm/omap3/OMAP35x_SDK_0.9.7/src/linux/kernel_org/2.6_kernel
+-TOOL_PREFIX = /db/toolsrc/library/toolsC38/vendors/cs/arm/arm-2007q3/bin/arm-none-linux-gnueabi-
+-DSPLINK_REPO = /db/atree/library/trees/power/power-d04x/imports
+-DSPLINK_BLD = Linux/OMAP3530/RELEASE
++LINUXKERNEL_INSTALL_DIR := _your_kernel_installation_
++MVTOOL_PREFIX := _your_codegen_installation_and_name_prefix_
++DSPLINK_REPO := _your_dsplink_repository_
+
+ # Set PROFILE to DEBUG or RELEASE
+ PROFILE = RELEASE
+
+ # Process DSPLINK flags
+ LINK_DIR = $(DSPLINK_REPO)/dsplink
+-LINK_PATH = $(LINK_DIR)/gpp/export/BIN/$(DSPLINK_BLD)
++LINK_PATH = $(LINK_DIR)/gpp/export/BIN/Linux/OMAP3530/RELEASE
+ LINK_ORIG := $(shell cat $(LINK_PATH)/DSPLINK.txt)
+ LINK_DEFS := $(shell cat $(LINK_PATH)/PMGR_defines.txt)
+ LINK_INCS := $(shell cat $(LINK_PATH)/PMGR_includes.txt)
+@@ -53,20 +56,11 @@
+ # add internal header files
+ LINK_INCS_INTERNAL = -I$(LINK_DIR)/gpp/export/INCLUDE/Linux/OMAP3530/internal
+
++ifneq ($(wildcard $(LINK_PATH)/Module.symvers),)
++EXTRA_SYMBOLS = $(LINK_PATH)/Module.symvers
++endif
+
+-# If KERNELRELEASE is defined, then this makefile has been invoked
+-# from the kernel build system. Use native build language.
+-ifneq ($(KERNELRELEASE),)
+-
+-obj-m := lpm_omap3530.o
+-lpm_omap3530-objs := lpm_driver.o lpm_omap.o tal_dsplink_gpp.o
+-
+-
+-# Otherwise, this makefile has been invoked directly from the
+-# command line. Invoke the kernel build system.
+-else
+-
+-MAKE_OPTS = ARCH=arm CROSS_COMPILE=$(TOOL_PREFIX)
++MAKE_OPTS = ARCH=arm CROSS_COMPILE=$(MVTOOL_PREFIX)
+ CFLAGS = -DUSE_UDEV -DOS_LINUX -DLINUX_KERNEL -D$(PROFILE) \
+ $(LINK_DEFS) $(LINK_INCS) $(LINK_INCS_INTERNAL)
+
+@@ -74,19 +68,28 @@
+ CFLAGS := -g $(CFLAGS)
+ endif
+
+-
++# Invoke the kernel build system
+ default:
+- $(MAKE) -C $(KERNEL_DIR) M=$(CURDIR) $(MAKE_OPTS) \
++ifneq ($(EXTRA_SYMBOLS),)
++ rm -f Module.symvers
++ cat $(foreach file, $(EXTRA_SYMBOLS), $(file)) >> Module.symvers
++endif
++ $(MAKE) -C $(LINUXKERNEL_INSTALL_DIR) M=$(CURDIR) $(MAKE_OPTS) \
+ EXTRA_CFLAGS="$(CFLAGS)" modules
+
+ .clean:
+- $(MAKE) -C $(KERNEL_DIR) M=$(CURDIR) $(MAKE_OPTS) clean
++ $(MAKE) -C $(LINUXKERNEL_INSTALL_DIR) M=$(CURDIR) $(MAKE_OPTS) clean
++ rm -f modules.order
+
+ .help:
+- $(MAKE) -C $(KERNEL_DIR) M=$(CURDIR) help
++ $(MAKE) -C $(LINUXKERNEL_INSTALL_DIR) M=$(CURDIR) help
+
+-endif
+-#
+-# @(#) ti.bios.power; 1, 1, 0,1; 11-5-2008 16:38:57; /db/atree/library/trees/power/power-d04x/src/
+-#
+
++# If KERNELRELEASE is defined, then this makefile has been invoked
++# from the kernel build system. Use native build language.
++else
++
++obj-m := lpm_omap3530.o
++lpm_omap3530-objs := lpm_driver.o lpm_omap.o tal_dsplink_gpp.o
++
++endif
diff --git a/packages/dsplink/files/xdcpaths.mak b/packages/dsplink/files/xdcpaths.mak
deleted file mode 100644
index 3df3bf6305..0000000000
--- a/packages/dsplink/files/xdcpaths.mak
+++ /dev/null
@@ -1,232 +0,0 @@
-#
-# ======== xdcpaths.mak ========
-# definition of XDC paths and commands
-#
-# This makefile constructs the "search path" for the XDC tools where it finds
-# numerous components and packages needed to build Codec Engine examples and
-# programs.
-#
-# USER NOTE:
-# 1) you must specify various <component>_INSTALL_DIRs directores below to
-# reflect your installation, where <component> is CE for Codec Engine,
-# BIOS for DSP/BIOS, etc.
-# 2) you must specify compiler path and name in CGTOOLS_* variables below
-# 3) you can remove some of the devices from the "DEVICES" list and/or remove
-# some of the types of binaries from the "PROGRAMS" list to reduce
-# the build time (and possibly avoid checking for presence of a component
-# you don't need)
-
-
-
-# (Optional) Remove from this list the devices you're not interested in building
-DEVICES := DM6446 DM355 DM6437 DM648 DM6467
-
-# (Optional) Remove from the list the types of programs you're not intersted in
-# building:
-# APP_CLIENT -- Arm client for codecs running on the DSP, on dual-CPU systems
-# DSP_SERVER -- DSP server with the codecs, running on the DSP, on dual-CPUs
-# APP_LOCAL -- Client+codecs in a single program, whether Arm only or DSP only
-PROGRAMS := APP_CLIENT DSP_SERVER APP_LOCAL
-
-
-# (Mandatory) Specify where various components are installed.
-# What you need depends on what device(s) you're building for, what type(s) of
-# programs you are building for, and whether your Codec Engine distribution
-# is a "big" one that contains all the minor components in its "cetools"
-# directory. The legend:
-# CE - Codec Engine (needed for Arm and for DSP)
-# XDC - XDC tools (Arm and DSP)
-# BIOS - DSP/BIOS (DSP only)
-# XDAIS - XDAIS header files (Arm and DSP)
-# FC - Framework components, various resource managers (ARM and DSP)
-# CMEM - Continuous memory manager (Arm only)
-# DSPLINK - Arm<->DSP communication software (Arm + DSP)
-#
-# you can omit directory specifications for the components you think you don't
-# need (will be warned if you do, based on your DEVICES + PROGRAMS selection
-# above).
-
-CE_INSTALL_DIR := SEDME_S
-XDC_INSTALL_DIR := SEDME_XDCTOOLSUNPACKDIR
-BIOS_INSTALL_DIR := SEDME_BIOSUNPACKDIR
-
-# no need to specify the installation directories below if your CE installation
-# has cetools/ directory on top
-USE_CETOOLS_IF_EXISTS := 1
-XDAIS_INSTALL_DIR := _your_xDAIS_installation_directory/xdais_6_10_01
-DSPLINK_INSTALL_DIR := _your_DSPLink_installation_directory/dsplink-davinci-v1.50-prebuilt
-CMEM_INSTALL_DIR := _your_CMEM_installation_directory/cmem_2_10
-FC_INSTALL_DIR := _your_FC_installation_directory/framework_components_2_10_01
-BIOSUTILS_INSTALL_DIR := _your_BIOSUTILS_installation_directory/biosutils
-
-
-# (Mandatory) specify correct compiler paths and names for the architectures
-# you'll be building for:
-
-# compiler path and name for Montavista Arm 9 toolchain. NOTE: make sure the
-# directory you specify has a "bin" subdirectory
-CGTOOLS_MVARM9 = /db/toolsrc/library/tools/vendors/mvl/arm/mvl4.0-new/montavista/pro/devkit/arm/v5t_le
-CC_MVARM9 = bin/arm_v5t_le-gcc
-
-# compiler path and name for TI C64x toolchain. NOTE: make sure the
-# directory you specify has a "bin" subdirectory
-CGTOOLS_C64P = /db/toolsrc/library/tools/vendors/ti/c6x/6.0.16/Linux
-CC_C64P = bin/cl6x
-
-# -----------------------------------------------------------------------------
-
-# figure out what categories of devices we are to build for
-ifneq (,$(findstring DM6446,$(DEVICES)))
- DEVICES_DAVINCI := 1
-endif
-ifneq (,$(findstring DM6467,$(DEVICES)))
- DEVICES_DAVINCI := 1
-endif
-ifneq (,$(findstring DM355,$(DEVICES)))
- DEVICES_ARMONLY := 1
-endif
-ifneq (,$(findstring DM6437,$(DEVICES)))
- DEVICES_DSPONLY := 1
-endif
-ifneq (,$(findstring DM648,$(DEVICES)))
- DEVICES_DSPONLY := 1
-endif
-
-# determine which components are necessary based on DEVICES and PROGRAMS
-REQUIRE_CE := 1
-REQUIRE_XDC := 1
-REQUIRE_XDAIS := 1
-REQUIRE_FC := 1
-
-ifneq (,$(findstring DM6446,$(DEVICES)))
- ifneq (, $(findstring APP_CLIENT, $(PROGRAMS) ))
- REQUIRE_LINK := 1
- REQUIRE_CMEM := 1
- endif
- ifneq (, $(findstring DSP_SERVER, $(PROGRAMS) ))
- REQUIRE_LINK := 1
- REQUIRE_BIOS := 1
- endif
-endif
-
-ifneq (,$(findstring DM6467,$(DEVICES)))
- ifneq (, $(findstring APP_CLIENT, $(PROGRAMS) ))
- REQUIRE_LINK := 1
- REQUIRE_CMEM := 1
- endif
- ifneq (, $(findstring DSP_SERVER, $(PROGRAMS) ))
- REQUIRE_LINK := 1
- REQUIRE_BIOS := 1
- endif
-endif
-
-ifneq (,$(findstring DM355,$(DEVICES)))
- ifneq (, $(findstring APP_LOCAL, $(PROGRAMS) ))
- REQUIRE_CMEM := 1
- endif
-endif
-
-ifneq (,$(findstring DM6437,$(DEVICES)))
- ifneq (, $(findstring APP_LOCAL, $(PROGRAMS) ))
- REQUIRE_BIOS := 1
- endif
-endif
-
-ifneq (,$(findstring DM648,$(DEVICES)))
- ifneq (, $(findstring APP_LOCAL, $(PROGRAMS) ))
- REQUIRE_BIOS := 1
- endif
-endif
-
-
-# Build the XDC path from the necessary components, verifying along the way
-# that the required compoments are present
-XDC_PATH :=
-
-ERRMSG = which is invalid (could not find file "$(TEST_FILE)"). Set this in <codec engine examples>/xdcpaths.mak! See the build documentation to correct this error.
-
-# CE_INSTALL_DIR is the location of your Codec Engine.
-ifeq ($(REQUIRE_CE), 1)
- TEST_FILE := $(CE_INSTALL_DIR)/packages/ti/sdo/ce/package.xdc
- ifeq ($(wildcard $(TEST_FILE)),)
- $(error CE_INSTALL_DIR is set to "$(CE_INSTALL_DIR)", $(ERRMSG))
- endif
- XDC_PATH := $(CE_INSTALL_DIR)/packages
-endif
-
-# Add cetools to XDCPATH if 1) $(USE_CETOOLS_IF_EXISTS) is set, and
-# 2) the CE distribution has "cetools/"
-USING_CETOOLS := 0
-ifeq ($(USE_CETOOLS_IF_EXISTS), 1)
- ifneq ($(wildcard $(CE_INSTALL_DIR)/cetools),)
- USING_CETOOLS := 1
- XDC_PATH := $(CE_INSTALL_DIR)/cetools/packages;$(XDC_PATH)
- endif
-endif
-ifeq ($(USING_CETOOLS),0)
- # XDAIS_INSTALL_DIR is the location of your XDAIS distribution
- ifeq ($(REQUIRE_XDAIS), 1)
- TEST_FILE := $(XDAIS_INSTALL_DIR)/packages/ti/xdais/package.xdc
- ifeq ($(wildcard $(TEST_FILE)),)
- $(error XDAIS_INSTALL_DIR is set to "$(XDAIS_INSTALL_DIR)", $(ERRMSG))
- endif
- XDC_PATH := $(XDC_PATH);$(XDAIS_INSTALL_DIR)/packages
- endif
-
- # DSPLINK_INSTALL_DIR is the location of your DSPLINK distribution
- ifeq ($(REQUIRE_LINK), 1)
- TEST_FILE := $(DSPLINK_INSTALL_DIR)/packages/dsplink/gpp/package.xdc
- ifeq ($(wildcard $(TEST_FILE)),)
- $(error DSPLINK_INSTALL_DIR is set to "$(DSPLINK_INSTALL_DIR)", $(ERRMSG))
- endif
- XDC_PATH := $(XDC_PATH);$(DSPLINK_INSTALL_DIR)/packages
- endif
-
- # CMEM_INSTALL_DIR is the location of your CMEM distribution
- ifeq ($(REQUIRE_CMEM), 1)
- TEST_FILE := $(CMEM_INSTALL_DIR)/packages/ti/sdo/linuxutils/cmem/package.xdc
- ifeq ($(wildcard $(TEST_FILE)),)
- $(error CMEM_INSTALL_DIR is set to "$(CMEM_INSTALL_DIR)", $(ERRMSG))
- endif
- XDC_PATH := $(XDC_PATH);$(CMEM_INSTALL_DIR)/packages
- endif
-
- # FC_INSTALL_DIR is the location of your Frameworks Components distribution
- ifeq ($(REQUIRE_FC), 1)
- TEST_FILE := $(FC_INSTALL_DIR)/packages/ti/sdo/fc/dskt2/package.xdc
- ifeq ($(wildcard $(TEST_FILE)),)
- $(error FC_INSTALL_DIR is set to "$(FC_INSTALL_DIR)", $(ERRMSG))
- endif
- XDC_PATH := $(XDC_PATH);$(FC_INSTALL_DIR)/packages
- endif
-
- # BIOSUTILS_INSTALL_DIR is the location of your BIOSUTILS distribution
- ifeq ($(REQUIRE_BIOS), 1)
- TEST_FILE := $(BIOSUTILS_INSTALL_DIR)/packages/ti/bios/utils/package.xdc
- ifeq ($(wildcard $(TEST_FILE)),)
- $(error BIOSUTILS_INSTALL_DIR is set to "$(BIOSUTILS_INSTALL_DIR)", $(ERRMSG))
- endif
- XDC_PATH := $(XDC_PATH);$(BIOSUTILS_INSTALL_DIR)/packages
- endif
-
-endif
-
-# BIOS_INSTALL_DIR is the location of your BIOS distribution
-ifeq ($(REQUIRE_BIOS), 1)
- TEST_FILE := $(BIOS_INSTALL_DIR)/packages/ti/bios/package.xdc
- ifeq ($(wildcard $(TEST_FILE)),)
- $(error BIOS_INSTALL_DIR is set to "$(BIOS_INSTALL_DIR)", $(ERRMSG))
- endif
- XDC_PATH := $(XDC_PATH);$(BIOS_INSTALL_DIR)/packages
-endif
-
-# XDC_INSTALL_DIR is the location of your XDCTOOLS installation.
-ifeq ($(REQUIRE_XDC), 1)
- TEST_FILE := $(XDC_INSTALL_DIR)/packages/xdc/package.xdc
- ifeq ($(wildcard $(TEST_FILE)),)
- $(error XDC_INSTALL_DIR is set to "$(XDC_INSTALL_DIR)", $(ERRMSG))
- endif
-endif
-
-# XDC_PATH is complete. Any other components you could add as
-# XDC_PATH := <your component>/packages;$(XDC_PATH)
diff --git a/packages/dsplink/readme.txt b/packages/dsplink/readme.txt
index f20be41d04..8dd71e6fee 100644
--- a/packages/dsplink/readme.txt
+++ b/packages/dsplink/readme.txt
@@ -3,7 +3,7 @@ placeholder for readme
todo with this package
- rename top level dsplink directory
- repartion code into different recipes - create codecengine-examples package
-- fix lpm build to pick up Module.symversion
+/DONE - fix lpm build to pick up Module.symversion
- cleanup device selection script - not good to just /d the targets - need cleaner solution
- staging needs work