aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2007-01-15 15:12:56 +0000
committerGraeme Gregory <dp@xora.org.uk>2007-01-15 15:12:56 +0000
commit13efca366dab9df6dead91a1273270ec2cbd068a (patch)
treeda6e15fe893b45ab8d9753c78689067d5651c723 /packages
parent8e87aa5a55e8f6c1b8f43b98a01efdd9bea5523f (diff)
downloadopenembedded-13efca366dab9df6dead91a1273270ec2cbd068a.tar.gz
abiword_2.5.0.bb : finish the .bb
Diffstat (limited to 'packages')
-rw-r--r--packages/abiword/abiword_2.5.0.bb6
-rwxr-xr-xpackages/abiword/files/cdump.pl32
2 files changed, 38 insertions, 0 deletions
diff --git a/packages/abiword/abiword_2.5.0.bb b/packages/abiword/abiword_2.5.0.bb
index 32b703c9ae..82d4e0e944 100644
--- a/packages/abiword/abiword_2.5.0.bb
+++ b/packages/abiword/abiword_2.5.0.bb
@@ -2,7 +2,13 @@ require abiword-2.5.inc
DEFAULT_PREFERENCE = "-1"
+SRC_URI += " file://cdump.pl "
+
PR = "r0"
RCONFLICTS = "abiword-embedded"
+do_compile_prepend () {
+ cp ${WORKDIR}/cdump.pl ${S}/src/tools/cdump/xp/
+}
+
diff --git a/packages/abiword/files/cdump.pl b/packages/abiword/files/cdump.pl
new file mode 100755
index 0000000000..76f9c8841b
--- /dev/null
+++ b/packages/abiword/files/cdump.pl
@@ -0,0 +1,32 @@
+#!/usr/bin/perl
+
+# This script replace the cdump tool we used to build the ap_wp_Splash.cpp
+# Because the cdump tool has to be run as a part of building the AW package,
+# it breaks cross-compilation. A perl script seemed like a generic solution
+
+
+if ($#ARGV != 1 )
+{
+ print "Usage: $0 datafile arrayname $#ARGV $ARGV[0] $ARGV[1]\n";
+ exit(-1);
+}
+
+open FROM, "<$ARGV[0]" or die "Could not open file $ARGV[0]";
+binmode FROM;
+
+print "unsigned char $ARGV[1] [] = {\n";
+
+while ($len = read(FROM, $buf, 16))
+{
+ foreach(split(//,$buf))
+ {
+ printf("0x%02x,", ord($_));
+ }
+
+ print "\n";
+}
+
+
+printf "};\nunsigned long $ARGV[1]_sizeof = sizeof($ARGV[1]);\n";
+
+close FROM; \ No newline at end of file