aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-03-06 13:23:14 +0100
committerKoen Kooi <koen@openembedded.org>2009-03-06 13:23:14 +0100
commit3355738d8c40c8fb8fb09e6a89895d57b8b4c80a (patch)
tree6fd65a2d3b5d937e347a9b8e1251eca70bd2a0e8 /packages
parentcdd27f17b730c0f5ba537fdee6a9086549f67410 (diff)
downloadopenembedded-3355738d8c40c8fb8fb09e6a89895d57b8b4c80a.tar.gz
gnash: add 0.8.5
Diffstat (limited to 'packages')
-rw-r--r--packages/gnash/gnash.inc2
-rw-r--r--packages/gnash/gnash_0.8.5.bb38
2 files changed, 39 insertions, 1 deletions
diff --git a/packages/gnash/gnash.inc b/packages/gnash/gnash.inc
index 29308b6c0a..3602f6fa90 100644
--- a/packages/gnash/gnash.inc
+++ b/packages/gnash/gnash.inc
@@ -1,7 +1,7 @@
DESCRIPTION = "Gnash is a GNU Flash movie player that supports many SWF v7 features"
HOMEPAGE = "http://www.gnu.org/software/gnash"
LICENSE = "GPL-2"
-DEPENDS = "libtool gtk+ cairo libxml2 libsdl-mixer zlib boost jpeg pango curl freetype \
+DEPENDS = "giflib libtool gtk+ cairo libxml2 libsdl-mixer zlib boost jpeg pango curl freetype \
${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'ffmpeg libmad', d)}"
PR = "r5"
diff --git a/packages/gnash/gnash_0.8.5.bb b/packages/gnash/gnash_0.8.5.bb
new file mode 100644
index 0000000000..fa9b3230e3
--- /dev/null
+++ b/packages/gnash/gnash_0.8.5.bb
@@ -0,0 +1,38 @@
+require gnash.inc
+
+DEPENDS += "gst-plugins-base"
+
+acpaths = " -Imacros"
+
+DEFAULT_PREFERENCE = "-1"
+
+# Boost lacks defines for lots of archs
+TARGET_CC_ARCH_append = " -I${STAGING_INCDIR}/libxml2 -DHAVE_POLL_H ${@[' -D_BIG_ENDIAN', ' -D_LITTLE_ENDIAN'][bb.data.getVar('SITEINFO_ENDIANESS', d, 1) == 'le']}"
+
+
+do_configure_prepend() {
+ sed -i -e 's:GNASH_PKG_FIND(libpng:GNASH_PKG_FIND(png:g' ${S}/configure.ac
+ for i in $(find ${S} -name "Makefile.am") ; do
+ sed -i -e s:LIBPNG:PNG:g $i
+ done
+ export CFLAGS="${CFLAGS} -lpng"
+}
+
+do_install_append() {
+ oe_runmake DESTDIR=${D} install-plugin
+}
+
+
+EXTRA_OECONF += " --without-included-ltdl \
+ --with-ltdl-include=${STAGING_INCDIR} \
+ --with-ltdl-lib=${STAGING_LIBDIR} \
+ --enable-plugins \
+ --enable-npapi \
+ --with-npapi-plugindir=${libdir}/mozilla/plugins \
+ --enable-mit-shm \
+ --enable-png \
+ --with-png-incl=${STAGING_INCDIR} \
+ --with-png-lib=${STAGING_LIBDIR} \
+ --enable-media=gst \
+ "
+