aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-03-04 16:14:27 -0800
committerKhem Raj <raj.khem@gmail.com>2009-03-04 16:14:27 -0800
commitc2f21de4041e962705e2e31dc7c50fed7877547a (patch)
treeae46e525d466ce7dc187444e72c1dd72bf178b63 /packages
parent855818b4dd7dfb941ddca58f823336026bfc557e (diff)
downloadopenembedded-c2f21de4041e962705e2e31dc7c50fed7877547a.tar.gz
coreutils-6.0: Make the install utility to honor STRIP environment variable
Diffstat (limited to 'packages')
-rw-r--r--packages/coreutils/coreutils-6.0/coreutils-install-use-STRIP.patch29
-rw-r--r--packages/coreutils/coreutils_6.0.bb3
2 files changed, 31 insertions, 1 deletions
diff --git a/packages/coreutils/coreutils-6.0/coreutils-install-use-STRIP.patch b/packages/coreutils/coreutils-6.0/coreutils-install-use-STRIP.patch
new file mode 100644
index 0000000000..1af9fb97b6
--- /dev/null
+++ b/packages/coreutils/coreutils-6.0/coreutils-install-use-STRIP.patch
@@ -0,0 +1,29 @@
+Index: coreutils-6.0/src/install.c
+===================================================================
+--- coreutils-6.0.orig/src/install.c 2009-03-04 15:37:45.000000000 -0800
++++ coreutils-6.0/src/install.c 2009-03-04 15:38:57.000000000 -0800
+@@ -526,7 +526,14 @@
+ strip (char const *name)
+ {
+ int status;
+- pid_t pid = fork ();
++ pid_t pid;
++ char *strip_name;
++
++ strip_name = getenv ("STRIP");
++ if (strip_name == NULL)
++ strip_name = "strip";
++
++ pid = fork ();
+
+ switch (pid)
+ {
+@@ -534,7 +541,7 @@
+ error (EXIT_FAILURE, errno, _("fork system call failed"));
+ break;
+ case 0: /* Child. */
+- execlp ("strip", "strip", name, NULL);
++ execlp (strip_name, "strip", name, NULL);
+ error (EXIT_FAILURE, errno, _("cannot run strip"));
+ break;
+ default: /* Parent. */
diff --git a/packages/coreutils/coreutils_6.0.bb b/packages/coreutils/coreutils_6.0.bb
index 4d4c049465..d0d082bc63 100644
--- a/packages/coreutils/coreutils_6.0.bb
+++ b/packages/coreutils/coreutils_6.0.bb
@@ -1,12 +1,13 @@
require coreutils.inc
-PR = "r2"
+PR = "r3"
SRC_URI = "\
ftp://alpha.gnu.org/gnu/coreutils/coreutils-${PV}.tar.bz2 \
file://man.patch;patch=1 \
file://oe-old-tools.patch;patch=1 \
file://futimens.patch;patch=1 \
+ file://coreutils-install-use-STRIP.patch;patch=1 \
file://onceonly.m4 \
"