aboutsummaryrefslogtreecommitdiffstats
path: root/qmatrix
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2004-11-02 18:54:40 +0000
committerMichael Lauer <mickey@vanille-media.de>2004-11-02 18:54:40 +0000
commitf9d59090277f62f66eb9b54c84e4c41cab27b812 (patch)
tree11bd241767459de48b6b110072dc1000f3ce7d09 /qmatrix
parent5bf7b7999d7a24843c9b62c2292f23c59d07942b (diff)
downloadopenembedded-f9d59090277f62f66eb9b54c84e4c41cab27b812.tar.gz
make qmatrix and qfish2 work w/ other machines as well
BKrev: 4187d7f0LjIyXvVnf3czUecMVIZBbw
Diffstat (limited to 'qmatrix')
-rw-r--r--qmatrix/qmatrix_1.1.0.oe43
1 files changed, 43 insertions, 0 deletions
diff --git a/qmatrix/qmatrix_1.1.0.oe b/qmatrix/qmatrix_1.1.0.oe
index e69de29bb2..1c366b4244 100644
--- a/qmatrix/qmatrix_1.1.0.oe
+++ b/qmatrix/qmatrix_1.1.0.oe
@@ -0,0 +1,43 @@
+DESCRIPTION = "A matrix Game, Qt/Embedded based Palmtop Environments Edition"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+SECTION = "opie/games"
+PRIORITY = "optional"
+PR = "r1"
+
+SRC_URI = "http://www.geocities.co.jp/SiliconValley-Oakland/8074/src/qmatrix-${PV}.tar.gz"
+S = "${WORKDIR}/qmatrix"
+
+inherit palmtop
+
+MACHTYPE = "sl300"
+MACHTYPE_corgi = "sl700"
+MACHTYPE_shepherd = "sl700"
+MACHTYPE_husky = "sl700"
+MACHTYPE_tosa = "sl700"
+
+do_configure_append() {
+ ln -v -f -s config/config-${MACHTYPE}.h config.h
+ ln -v -f -s config/config.mk-${MACHTYPE} config.mk
+ if [ "${MACHTYPE}" = "sl300" ]
+ then
+ ln -vfs bigFishSize.h areaSize.h
+ else
+ ln -vfs smallFishSize.h areaSize.h
+ fi
+ ln -v -f -s HiScoreRegConfig-${MACHTYPE}.h HiScoreRegConfig.h
+}
+
+do_compile_prepend() {
+ cd images && oe_runmake && cd ${S}
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/apps/Games
+ install -m 0644 desktop/qmatrix-${MACHTYPE}.desktop ${D}${palmtopdir}/apps/Games/qmatrix.desktop
+ install -d ${D}${palmtopdir}/bin
+ install -m 0755 qmatrix ${D}${palmtopdir}/bin/qmatrix
+ install -d ${D}${palmtopdir}/pics
+ install -m 0644 desktop/qmatrix.png ${D}${palmtopdir}/pics/
+ install -d ${D}${palmtopdir}/help/html/
+ install -m 0644 desktop/qmatrix.html ${D}${palmtopdir}/help/html/qmatrix.html
+}