aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/abiword/abiword-plugins_2.4.6.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/abiword/abiword-plugins_2.4.6.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/abiword/abiword-plugins_2.4.6.bb')
-rw-r--r--recipes/abiword/abiword-plugins_2.4.6.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/abiword/abiword-plugins_2.4.6.bb b/recipes/abiword/abiword-plugins_2.4.6.bb
new file mode 100644
index 0000000000..41652828bf
--- /dev/null
+++ b/recipes/abiword/abiword-plugins_2.4.6.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "AbiWord is a free word processing program similar to Microsoft(r) Word""
+HOMEPAGE = "http://www.abiword.org""
+SECTION = "x11/office"
+LICENSE = "GPLv2"
+DEPENDS = "libwpd librsvg goffice poppler"
+RDEPENDS = "abiword"
+
+PR = "r1"
+
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \
+ file://abiword-plugin-pdf-poppler.patch;patch=1;pnum=2"
+S = "${WORKDIR}/abiword-${PV}/abiword-plugins"
+
+inherit autotools
+
+PARALLEL_MAKE=""
+
+EXTRA_OECONF = "--without-libwmf --without-inter7eps"
+
+PACKAGES_DYNAMIC = "abiword-plugin-*"
+
+python populate_packages_prepend () {
+ abiword_libdir = bb.data.expand('${libdir}/AbiWord-2.4/plugins', d)
+
+ do_split_packages(d, abiword_libdir, '^libAbi(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
+}
+