aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/abiword
diff options
context:
space:
mode:
authorDenis 'Gnutoo' Carikli <GNUtoo@no-log.org>2010-01-01 16:30:46 +0100
committerDenis 'Gnutoo' Carikli <GNUtoo@no-log.org>2010-01-01 16:30:46 +0100
commitcbf0a993d3fb1efc496ea222e70aa44530aed1af (patch)
treefe5a12c7b4a8b2e08c0a92dfc5797faba9f86804 /recipes/abiword
parent732a0b122d1c0b0928cee833863a5fa60370efc9 (diff)
downloadopenembedded-cbf0a993d3fb1efc496ea222e70aa44530aed1af.tar.gz
abiword 2.8.1: multiple fixes
*Fixed compilation removing DOLT (from http://dolt.freedesktop.org/) fom configure.in, else it would file like this(output stripped) : .../doltlibtool: exec: .../libtool: cannot execute: No such file or directory note that it looks for libtool and not ${TARGET_ARCH}-angstrom-linux-libtool in my case,more informations are disponible reading the m4 dolt file here: http://cgit.freedesktop.org/dolt/tree/dolt.m4 *fixed libwmf problem: libwmf-config is a program that is used for knowing the compilations flags like that : libwmf-config --cflags -I/usr/include/freetype2 -I/usr/include ->But like the in example the host version was called and so some /usr/include were included into the build process, --with-libwmf-config=${STAGING_DIR} fixes it ->also depend on the native libwmf so it is not required on the host in order to build abiword *fixed runtime problem with the plugins: In the trunk(which regenerate configure files like we do), autogen-common.sh was called by autogen.sh And not calling it creates issues like for instance the absence of the the collab plugin in the installation directory
Diffstat (limited to 'recipes/abiword')
-rw-r--r--recipes/abiword/abiword_2.8.1.bb15
-rwxr-xr-xrecipes/abiword/files/autogen-common.sh28
-rw-r--r--recipes/abiword/files/nodolt.patch12
3 files changed, 52 insertions, 3 deletions
diff --git a/recipes/abiword/abiword_2.8.1.bb b/recipes/abiword/abiword_2.8.1.bb
index 8f9bbee2ee..34a03479c8 100644
--- a/recipes/abiword/abiword_2.8.1.bb
+++ b/recipes/abiword/abiword_2.8.1.bb
@@ -1,8 +1,10 @@
require abiword-2.5.inc
-PR = "r2"
+PR = "r3"
-SRC_URI = "http://www.abisource.com/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz"
+SRC_URI = "http://www.abisource.com/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \
+ file://autogen-common.sh \
+ file://nodolt.patch;patch=1"
do_configure() {
autotools_do_configure
@@ -13,8 +15,9 @@ EXTRA_OECONF = " --disable-static \
--enable-collab-backend-xmpp \
--enable-collab-backend-tcp \
--enable-collab-backend-service \
+ --with-libwmf-config=${STAGING_DIR} \
"
-
+DEPENDS += " libwmf-native "
RCONFLICTS = "abiword-embedded"
FILES_${PN} += "${libdir}/libabiword-*.so ${datadir}/mime-info ${datadir}/abiword-${SHRT_VER}/certs ${datadir}/abiword-${SHRT_VER}/ui ${datadir}/abiword-${SHRT_VER}/xsl* ${datadir}/abiword-${SHRT_VER}/mime-info ${datadir}/abiword-${SHRT_VER}/Pr*.xml"
@@ -23,6 +26,12 @@ FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/system.profil
PACKAGES_DYNAMIC = "abiword-meta abiword-plugin-*"
+do_configure_prepend () {
+ install -m 0755 ${WORKDIR}/autogen-common.sh ${S}/autogen-common.sh
+ cd ${S}
+ ./autogen-common.sh
+}
+
python populate_packages_prepend () {
abiword_libdir = bb.data.expand('${libdir}/abiword-2.8/plugins', d)
do_split_packages(d, abiword_libdir, '(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
diff --git a/recipes/abiword/files/autogen-common.sh b/recipes/abiword/files/autogen-common.sh
new file mode 100755
index 0000000000..c1f10e1a4d
--- /dev/null
+++ b/recipes/abiword/files/autogen-common.sh
@@ -0,0 +1,28 @@
+#!/bin/sh
+
+# find plugins Makefile templates
+find plugins -name Makefile.am | sed 's|.am$||g' > plugin-makefiles.m4
+
+# create plugin list
+(cd plugins && find . -maxdepth 1 -type d | grep -v '^\.$' | grep -v '\./\.' | sed 's|\./||g' | xargs echo) > plugin-list.m4
+
+# create conditionals for builtin plugins
+(for plugin in `cat plugin-list.m4`; do
+ u=`echo $plugin | tr '[:lower:]' '[:upper:]'`
+ echo 'AM_CONDITIONAL(['$u'_BUILTIN], test "$enable_'$plugin'_builtin" == "yes")'
+done) > plugin-builtin.m4
+
+# create plugin configuration
+find plugins -name plugin.m4 | xargs cat > plugin-configure.m4
+#to debug if plugin configuration code misbehaves (instead of the above line):
+#rm plugin-configure.m4
+#for f in $(find plugins -name plugin.m4); do
+# echo "AC_MSG_RESULT([plugin: $f])" >> plugin-configure.m4
+# cat $f >> plugin-configure.m4
+#done
+
+# find extra m4 files provided by plugins and symlink them
+for f in ` find ./plugins -name '*.m4' | grep -v 'plugin\.m4'`; do
+ ln -sf $f
+done
+
diff --git a/recipes/abiword/files/nodolt.patch b/recipes/abiword/files/nodolt.patch
new file mode 100644
index 0000000000..1546720804
--- /dev/null
+++ b/recipes/abiword/files/nodolt.patch
@@ -0,0 +1,12 @@
+Index: abiword-2.8.1/configure.in
+===================================================================
+--- abiword-2.8.1.orig/configure.in
++++ abiword-2.8.1/configure.in
+@@ -132,7 +132,6 @@ AC_PROG_INSTALL
+ #AC_DISABLE_STATIC
+ AC_LIBTOOL_WIN32_DLL
+ AC_PROG_LIBTOOL
+-DOLT
+ AC_PROG_LN_S
+
+ AC_MSG_CHECKING([for platform and toolkit])