aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/agg/agg-minimal_2.5.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/agg/agg-minimal_2.5.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/agg/agg-minimal_2.5.bb')
-rw-r--r--recipes/agg/agg-minimal_2.5.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes/agg/agg-minimal_2.5.bb b/recipes/agg/agg-minimal_2.5.bb
new file mode 100644
index 0000000000..7d5979a609
--- /dev/null
+++ b/recipes/agg/agg-minimal_2.5.bb
@@ -0,0 +1,43 @@
+DESCRIPTION = "Anti Grain Geometry - A High Quality Rendering Engine for C++"
+AUTHOR = "mcseem@antigrain.com"
+HOMEPAGE = "http://www.antigrain.com"
+SECTION = "libs"
+LICENSE = "AGG License"
+DEPENDS = "freetype"
+
+PR = "r0"
+
+SRC_URI = "http://www.antigrain.com/agg-${PV}.tar.gz"
+SRC_URI += "http://www.wxsvg.org/files/agg-2.5_cygming.patch;patch=1"
+S = "${WORKDIR}/agg-${PV}"
+
+inherit autotools pkgconfig
+
+CFLAGS += " -I{$STAGING_INCDIR} "
+
+FILES_${PN} = "${libdir}/libagg.so.* \
+ ${libdir}/libaggfontfreetype.so.*"
+
+LEAD_SONAME = "libagg.so"
+
+EXTRA_OECONF = "--disable-gpc --without-x --disable-examples --disable-ctrl \
+--disable-platform --disable-win32tt --disable-sdltest"
+
+do_stage() {
+ oe_libinstall -a -so libagg ${STAGING_LIBDIR}
+ oe_libinstall -a -so libaggfontfreetype ${STAGING_LIBDIR}
+ install -m 0644 libagg.m4 ${STAGING_DATADIR}/aclocal/
+ install -d ${STAGING_INCDIR}/agg2
+
+ for f in font_freetype font_win32_tt gpc
+ do
+ install -m 0644 ${S}/$f/*.h ${STAGING_INCDIR}/agg2/
+ done
+
+ cd include
+ headers=`find . -name "*.h"`
+ for f in $headers
+ do
+ install -D -m 0644 $f ${STAGING_INCDIR}/agg2/$f
+ done
+}