aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/angstrom
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-09-07 15:40:32 +0200
committerKoen Kooi <koen@openembedded.org>2009-09-07 15:40:32 +0200
commit4f2d73c53ab0b10d5c9660c14611a0e65773ad2f (patch)
treecfb46a2bb373a632ad4efc3e59ebd509f4e6b878 /recipes/angstrom
parent02f5d01a47890f80e8e0800adbd99a1bb1590cae (diff)
downloadopenembedded-4f2d73c53ab0b10d5c9660c14611a0e65773ad2f.tar.gz
angstrom-uboot-scripts: add recipe to generate .scr files easily
* the recipe puts them both in deploy and in ${datadir}/u-boot-scripts
Diffstat (limited to 'recipes/angstrom')
-rw-r--r--recipes/angstrom/angstrom-uboot-scripts.bb36
-rw-r--r--recipes/angstrom/angstrom-uboot-scripts/pico.cmd3
2 files changed, 39 insertions, 0 deletions
diff --git a/recipes/angstrom/angstrom-uboot-scripts.bb b/recipes/angstrom/angstrom-uboot-scripts.bb
new file mode 100644
index 0000000000..bcdba45d9f
--- /dev/null
+++ b/recipes/angstrom/angstrom-uboot-scripts.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Various uboot scripts"
+
+DEPENDS = "u-boot-mkimage-native"
+
+SRC_URI = "file://*.cmd"
+
+do_configure() {
+ cp ${WORKDIR}/*.cmd ${S}
+}
+
+do_compile() {
+ for i in *.cmd ; do
+ uboot-mkimage -A ${TARGET_ARCH} -O linux -T script -C none -a 0 -e 0 -n "Angstrom $i" -d $i $i.scr
+ done
+}
+
+do_install() {
+ install -d ${D}${datadir}/u-boot-scripts
+ for i in *.scr ; do
+ install -m 0644 $i ${D}${datadir}/u-boot-scripts
+ done
+}
+
+FILES_${PN} += "${datadir}"
+
+addtask deploy before do_package after do_install
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ for i in *.scr ; do
+ cp $i ${DEPLOY_DIR_IMAGE}
+ package_stagefile_shell ${DEPLOY_DIR_IMAGE}/$i
+ done
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes/angstrom/angstrom-uboot-scripts/pico.cmd b/recipes/angstrom/angstrom-uboot-scripts/pico.cmd
new file mode 100644
index 0000000000..695ee26357
--- /dev/null
+++ b/recipes/angstrom/angstrom-uboot-scripts/pico.cmd
@@ -0,0 +1,3 @@
+setenv dvimode '640x480MR-24@60'
+run loaduimage
+run mmcboot