aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/angstrom
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-04-16 12:04:22 +0200
committerKoen Kooi <koen@openembedded.org>2009-04-16 12:04:22 +0200
commit77623602a270af4c73e41a7ea12ec97c0fbf6b7a (patch)
tree3ed301bf907afabb075fcc9bf8797aa1a300dba4 /recipes/angstrom
parent48488aba060dfe38cac61707df7f812a6230b83b (diff)
downloadopenembedded-77623602a270af4c73e41a7ea12ec97c0fbf6b7a.tar.gz
exquisite-theme-angstrom: add angstrom theme as a quick hack
Diffstat (limited to 'recipes/angstrom')
-rw-r--r--recipes/angstrom/exquisite-theme-angstrom.bb41
-rw-r--r--recipes/angstrom/exquisite-theme-angstrom/exq-logo.pngbin0 -> 8221 bytes
-rw-r--r--recipes/angstrom/exquisite-theme-angstrom/exq-logoglow.pngbin0 -> 19164 bytes
3 files changed, 41 insertions, 0 deletions
diff --git a/recipes/angstrom/exquisite-theme-angstrom.bb b/recipes/angstrom/exquisite-theme-angstrom.bb
new file mode 100644
index 0000000000..9716214388
--- /dev/null
+++ b/recipes/angstrom/exquisite-theme-angstrom.bb
@@ -0,0 +1,41 @@
+DDESCRIPTION = "Angstrom theme for exquisite"
+HOMEPAGE = "http://www.enlightenment.org"
+LICENSE = "MIT/BSD"
+SECTION = "x11"
+
+DEPENDS = "edje-native"
+RRECOMMENDS_${PN} = "exquisite"
+
+SRCREV = "${EFL_SRCREV}"
+PV = "1.0+svnr${SRCREV}"
+PR = "r1"
+
+inherit update-alternatives
+
+ALTERNATIVE_NAME = "exquisite-config"
+ALTERNATIVE_LINK = "${sysconfdir}/exquisite/config"
+ALTERNATIVE_PATH = "${sysconfdir}/exquisite/config-angstrom"
+ALTERNATIVE_PRIORITY = "20"
+
+SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk;module=THEMES/b_and_w;proto=http \
+ file://exq-logo.png \
+ file://exq-logoglow.png \
+"
+
+S = "${WORKDIR}/THEMES/b_and_w"
+
+do_compile() {
+ cp ${WORKDIR}/*png ${S}/
+ edje_cc exquisite.edc angstrom.edj
+}
+
+do_install() {
+ install -d ${D}${sysconfdir}/exquisite
+ install -d ${D}${datadir}/exquisite/data/themes
+ install -m 0644 ${S}/angstrom.edj ${D}${datadir}/exquisite/data/themes/
+ echo 'THEME="-t angstrom"' > ${D}${sysconfdir}/exquisite/config-angstrom
+}
+
+PACKAGE_ARCH = "all"
+CONFFILES_${PN} = "${sysconfdir}/exquisite/config-angstrom"
+FILES_${PN} = "${sysconfdir}/exquisite ${datadir}/exquisite/data/themes"
diff --git a/recipes/angstrom/exquisite-theme-angstrom/exq-logo.png b/recipes/angstrom/exquisite-theme-angstrom/exq-logo.png
new file mode 100644
index 0000000000..2d79a1cbdb
--- /dev/null
+++ b/recipes/angstrom/exquisite-theme-angstrom/exq-logo.png
Binary files differ
diff --git a/recipes/angstrom/exquisite-theme-angstrom/exq-logoglow.png b/recipes/angstrom/exquisite-theme-angstrom/exq-logoglow.png
new file mode 100644
index 0000000000..d4edf84931
--- /dev/null
+++ b/recipes/angstrom/exquisite-theme-angstrom/exq-logoglow.png
Binary files differ