aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/apache2
diff options
context:
space:
mode:
authorEric Bénard <eric@eukrea.com>2010-09-21 10:16:05 +0200
committerEric Bénard <eric@eukrea.com>2010-09-24 15:15:03 +0200
commit1316a0c0c4fe95bf6abce0b2f6aec32fabf17637 (patch)
treec4af12c9cfc17eb4f9bc9f92eeac594bce4c21bc /recipes/apache2
parent2168dba79f77ba1d3edc5fd687c599bed4048645 (diff)
downloadopenembedded-1316a0c0c4fe95bf6abce0b2f6aec32fabf17637.tar.gz
apache2: unbreak recipe
* tested on armv5te / angstrom Signed-off-by: Eric Bénard <eric@eukrea.com>
Diffstat (limited to 'recipes/apache2')
-rw-r--r--recipes/apache2/apache2_2.2.14.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes/apache2/apache2_2.2.14.bb b/recipes/apache2/apache2_2.2.14.bb
index 1c425b70fe..b39f14ca5a 100644
--- a/recipes/apache2/apache2_2.2.14.bb
+++ b/recipes/apache2/apache2_2.2.14.bb
@@ -1,6 +1,6 @@
SECTION = "net"
DESCRIPTION = "The apache v2 web server"
-DEPENDS = "apache2-native openssl expat pcre"
+DEPENDS = "libtool-native apache2-native openssl expat pcre"
RDEPENDS_${PN} += "openssl"
PR = "r2"
@@ -89,6 +89,11 @@ EXTRA_OECONF = "--enable-ssl \
#
# here we over-ride the autotools provided do_configure.
#
+
+do_configure_prepend() {
+ sed -e 's,libtool libtool15,${TARGET_PREFIX}libtool libtool115,' -i ${S}/srclib/apr/build/buildcheck.sh
+}
+
do_configure() {
( cd srclib/apr; ./buildconf )
oe_runconf