aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/autofs
diff options
context:
space:
mode:
authorChris Larson <clarson@mvista.com>2009-11-03 13:31:27 -0700
committerChris Larson <clarson@mvista.com>2009-11-03 13:33:47 -0700
commit5c4f5bec443bd8733b3accceb90d73c267d46c58 (patch)
treee3ab8d36833ae1584bb25b7ebe748caa0cdd6bb2 /recipes/autofs
parentfbccdee191234fe422df187261de313eb7c15257 (diff)
downloadopenembedded-5c4f5bec443bd8733b3accceb90d73c267d46c58.tar.gz
autofs: switch to a .inc.
Signed-off-by: Chris Larson <clarson@mvista.com>
Diffstat (limited to 'recipes/autofs')
-rw-r--r--recipes/autofs/autofs.inc18
-rw-r--r--recipes/autofs/autofs_3.1.7.bb20
-rw-r--r--recipes/autofs/autofs_4.0.0.bb17
-rw-r--r--recipes/autofs/autofs_4.1.4.bb19
4 files changed, 26 insertions, 48 deletions
diff --git a/recipes/autofs/autofs.inc b/recipes/autofs/autofs.inc
new file mode 100644
index 0000000000..08c0074428
--- /dev/null
+++ b/recipes/autofs/autofs.inc
@@ -0,0 +1,18 @@
+DESCRIPTION = "Kernel based automounter for linux."
+SECTION = "base"
+LICENSE = "GPL"
+INC_PR = "r3"
+
+inherit autotools
+
+do_configure_prepend () {
+ if [ ! -e acinclude.m4 ]; then
+ cp aclocal.m4 acinclude.m4
+ fi
+}
+
+do_install () {
+ install -d ${D}${mandir}/man5 ${D}${mandir}/man8 \
+ ${D}${sbindir}
+ oe_runmake 'INSTALLROOT=${D}' install
+}
diff --git a/recipes/autofs/autofs_3.1.7.bb b/recipes/autofs/autofs_3.1.7.bb
index 05481ed46c..10840d8d33 100644
--- a/recipes/autofs/autofs_3.1.7.bb
+++ b/recipes/autofs/autofs_3.1.7.bb
@@ -1,18 +1,4 @@
-DESCRIPTION = "Kernel based automounter for linux."
-SECTION = "base"
-LICENSE = "GPL"
-SRC_URI = "${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v3/autofs-${PV}.tar.bz2"
-
-inherit autotools
+require autofs.inc
-do_configure_prepend () {
- if [ ! -e acinclude.m4 ]; then
- cp aclocal.m4 acinclude.m4
- fi
-}
-
-do_install () {
- install -d ${D}${mandir}/man5 ${D}${mandir}/man8 \
- ${D}${sbindir}
- oe_runmake 'INSTALLROOT=${D}' install
-}
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v3/autofs-${PV}.tar.bz2"
+PR = "${INC_PR}"
diff --git a/recipes/autofs/autofs_4.0.0.bb b/recipes/autofs/autofs_4.0.0.bb
index 6033b8a09a..b08d6aa3bf 100644
--- a/recipes/autofs/autofs_4.0.0.bb
+++ b/recipes/autofs/autofs_4.0.0.bb
@@ -1,17 +1,4 @@
-DESCRIPTION = "Kernel based automounter for linux."
-SECTION = "base"
-LICENSE = "GPL"
+require autofs.inc
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/old/autofs-${PV}-1.tar.bz2"
-
-inherit autotools
-
-do_configure_prepend () {
- if [ ! -e acinclude.m4 ]; then
- cp aclocal.m4 acinclude.m4
- fi
-}
-
-do_install () {
- oe_runmake 'INSTALLROOT=${D}' install
-}
+PR = "${INC_PR}"
diff --git a/recipes/autofs/autofs_4.1.4.bb b/recipes/autofs/autofs_4.1.4.bb
index 2f998ab220..0ec818a046 100644
--- a/recipes/autofs/autofs_4.1.4.bb
+++ b/recipes/autofs/autofs_4.1.4.bb
@@ -1,8 +1,4 @@
-DESCRIPTION = "Kernel based automounter for linux."
-SECTION = "base"
-LICENSE = "GPL"
-
-PR = "r3"
+require autofs.inc
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-${PV}.tar.bz2 \
${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-misc-fixes.patch;patch=1 \
@@ -14,8 +10,9 @@ SRC_URI = "${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-${PV}.tar.bz2
file://auto.net-sort-option-fix.patch;patch=1 \
file://autofs-additional-distros.patch;patch=1 \
file://no-bash.patch;patch=1"
+PR = "${INC_PR}"
-inherit autotools update-rc.d
+inherit update-rc.d
INITSCRIPT_NAME = "autofs"
INITSCRIPT_PARAMS = "defaults"
@@ -24,13 +21,3 @@ INITSCRIPT_PARAMS = "defaults"
CFLAGS += "${LDFLAGS}"
EXTRA_OEMAKE = "STRIP=/bin/true"
PARALLEL_MAKE = ""
-
-do_configure_prepend () {
- if [ ! -e acinclude.m4 ]; then
- cp aclocal.m4 acinclude.m4
- fi
-}
-
-do_install () {
- oe_runmake 'INSTALLROOT=${D}' install
-}