aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/automake/files/path_prog_fixes.patch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/automake/files/path_prog_fixes.patch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/automake/files/path_prog_fixes.patch')
-rw-r--r--recipes/automake/files/path_prog_fixes.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/recipes/automake/files/path_prog_fixes.patch b/recipes/automake/files/path_prog_fixes.patch
new file mode 100644
index 0000000000..69cea77035
--- /dev/null
+++ b/recipes/automake/files/path_prog_fixes.patch
@@ -0,0 +1,55 @@
+Index: automake-1.10.2/Makefile.am
+===================================================================
+--- automake-1.10.2.orig/Makefile.am
++++ automake-1.10.2/Makefile.am
+@@ -75,7 +75,8 @@
+ -e 's,[@]SHELL[@],$(SHELL),g' \
+ -e 's,[@]VERSION[@],$(VERSION),g' \
+ -e 's,[@]configure_input[@],Generated from $@.in; do not edit by hand.,g' \
+- -e 's,[@]datadir[@],$(datadir),g'
++ -e 's,[@]datadir[@],$(datadir),g' \
++ -e 's,[@]bindir[@],$(bindir),g'
+
+ ## These files depend on Makefile so they are rebuilt if $(VERSION),
+ ## $(datadir) or other do_subst'ituted variables change.
+Index: automake-1.10.2/Makefile.in
+===================================================================
+--- automake-1.10.2.orig/Makefile.in
++++ automake-1.10.2/Makefile.in
+@@ -186,7 +186,8 @@
+ -e 's,[@]SHELL[@],$(SHELL),g' \
+ -e 's,[@]VERSION[@],$(VERSION),g' \
+ -e 's,[@]configure_input[@],Generated from $@.in; do not edit by hand.,g' \
+- -e 's,[@]datadir[@],$(datadir),g'
++ -e 's,[@]datadir[@],$(datadir),g' \
++ -e 's,[@]bindir[@],$(bindir),g'
+
+ WGET = wget
+ WGET_SV_CVS = $(WGET) http://savannah.gnu.org/cgi-bin/viewcvs/~checkout~/
+Index: automake-1.10.2/automake.in
+===================================================================
+--- automake-1.10.2.orig/automake.in
++++ automake-1.10.2/automake.in
+@@ -1,8 +1,10 @@
+-#!@PERL@ -w
++#!@bindir@/env perl
+ # -*- perl -*-
+ # @configure_input@
+
+-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
++use warnings;
++
++eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @bindir@/env perl -S "$0" "$@";; esac'
+ if 0;
+
+ # automake - create Makefile.in from Makefile.am
+Index: automake-1.10.2/aclocal.in
+===================================================================
+--- automake-1.10.2.orig/aclocal.in
++++ automake-1.10.2/aclocal.in
+@@ -1,4 +1,4 @@
+-#!@PERL@ -w
++#!@bindir@/env perl -w
+ # -*- perl -*-
+ # @configure_input@
+