aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/automake
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2009-03-20 00:51:26 +0100
committerRobert Schuster <thebohemian@gmx.net>2009-03-20 00:55:25 +0100
commit3eaf6239186f82ac37e8e9772d51b1d686f36c1b (patch)
tree82489de6056a0b9a1b5aba70920a8f020be55962 /recipes/automake
parent35b91db2b10270d2a2bc0cc02dc695d196958762 (diff)
downloadopenembedded-3eaf6239186f82ac37e8e9772d51b1d686f36c1b.tar.gz
automake 1.9.6: Retrieve recipe from history.
automake-native 1.9.6: Retrieve recipe from history.
Diffstat (limited to 'recipes/automake')
-rw-r--r--recipes/automake/automake-native_1.9.6.bb3
-rw-r--r--recipes/automake/automake_1.9.6.bb31
2 files changed, 34 insertions, 0 deletions
diff --git a/recipes/automake/automake-native_1.9.6.bb b/recipes/automake/automake-native_1.9.6.bb
new file mode 100644
index 0000000000..92c861f49c
--- /dev/null
+++ b/recipes/automake/automake-native_1.9.6.bb
@@ -0,0 +1,3 @@
+PV := "${PV}"
+
+require automake-native.inc
diff --git a/recipes/automake/automake_1.9.6.bb b/recipes/automake/automake_1.9.6.bb
new file mode 100644
index 0000000000..eef69f4e4a
--- /dev/null
+++ b/recipes/automake/automake_1.9.6.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "A tool for automatically generating Makefiles."
+LICENSE = "GPL"
+HOMEPAGE = "http://www.gnu.org/software/automake/"
+SECTION = "devel"
+
+SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2 \
+ ${@['file://path_prog_fixes.patch;patch=1', ''][bb.data.inherits_class('native', d)]}"
+
+S = "${WORKDIR}/automake-${PV}"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/automake-${PV}"
+
+inherit autotools
+
+export AUTOMAKE = "${@bb.which('automake', bb.data.getVar('PATH', d, 1))}"
+FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
+
+require automake.inc
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+ install -d ${D}${datadir}
+ if [ ! -e ${D}${datadir}/aclocal ]; then
+ ln -sf aclocal-1.9 ${D}${datadir}/aclocal
+ fi
+ if [ ! -e ${D}${datadir}/automake ]; then
+ ln -sf automake-1.9 ${D}${datadir}/automake
+ fi
+}
+
+DEFAULT_PREFERENCE = "-1"