aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/automake
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2010-03-01 12:36:31 +0100
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2010-03-01 13:56:06 +0100
commitb6faf3681a61ede4d806ce0465f953d600e388e8 (patch)
tree165af587037dc2ffe13aa2e1305391406cb76f7f /recipes/automake
parent7dccaf76a7eff758b8a05cbf8c816f87aaf3e5b0 (diff)
downloadopenembedded-b6faf3681a61ede4d806ce0465f953d600e388e8.tar.gz
autoconf: merged Poky changes (BBEXTENDCLASS + new staging)
Signed-off-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
Diffstat (limited to 'recipes/automake')
-rw-r--r--recipes/automake/automake-native.inc11
-rw-r--r--recipes/automake/automake-native_1.10.2.bb3
-rw-r--r--recipes/automake/automake-native_1.11.1.bb5
-rw-r--r--recipes/automake/automake-native_1.9.6.bb3
-rw-r--r--recipes/automake/automake.inc6
5 files changed, 5 insertions, 23 deletions
diff --git a/recipes/automake/automake-native.inc b/recipes/automake/automake-native.inc
deleted file mode 100644
index 4e2ac41d81..0000000000
--- a/recipes/automake/automake-native.inc
+++ /dev/null
@@ -1,11 +0,0 @@
-SECTION = "devel"
-require automake_${PV}.bb
-DEPENDS += "autoconf-native"
-RDEPENDS_automake-native += "autoconf-native perl-native-runtime"
-
-inherit native
-
-do_stage () {
- oe_runmake install
- install -d ${datadir}/aclocal
-}
diff --git a/recipes/automake/automake-native_1.10.2.bb b/recipes/automake/automake-native_1.10.2.bb
deleted file mode 100644
index 92c861f49c..0000000000
--- a/recipes/automake/automake-native_1.10.2.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-PV := "${PV}"
-
-require automake-native.inc
diff --git a/recipes/automake/automake-native_1.11.1.bb b/recipes/automake/automake-native_1.11.1.bb
deleted file mode 100644
index a7857c562d..0000000000
--- a/recipes/automake/automake-native_1.11.1.bb
+++ /dev/null
@@ -1,5 +0,0 @@
-PV := "${PV}"
-
-require automake-native.inc
-
-DEFAULT_PREFERENCE = "-1"
diff --git a/recipes/automake/automake-native_1.9.6.bb b/recipes/automake/automake-native_1.9.6.bb
deleted file mode 100644
index 92c861f49c..0000000000
--- a/recipes/automake/automake-native_1.9.6.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-PV := "${PV}"
-
-require automake-native.inc
diff --git a/recipes/automake/automake.inc b/recipes/automake/automake.inc
index 74957cc9e9..662f9f8722 100644
--- a/recipes/automake/automake.inc
+++ b/recipes/automake/automake.inc
@@ -2,6 +2,8 @@ DESCRIPTION = "A tool for automatically generating Makefiles."
LICENSE = "GPL"
HOMEPAGE = "http://www.gnu.org/software/automake/"
SECTION = "devel"
+DEPENDS_virtclass-native = "autoconf-native"
+RDEPENDS_automake-native = "autoconf-native perl-native-runtime"
RDEPENDS_automake += "\
autoconf \
perl \
@@ -27,7 +29,7 @@ RDEPENDS_automake += "\
perl-module-text-parsewords \
perl-module-vars "
SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2"
-INC_PR = "r2"
+INC_PR = "r3"
AUTOMAKE_API = "${@".".join(bb.data.getVar("PV",d,1).split(".")[0:2])}"
inherit autotools
@@ -47,3 +49,5 @@ do_install_append () {
ln -sf automake-${AUTOMAKE_API} ${D}${bindir}/automake
install -d ${D}${datadir}/aclocal
}
+
+BBCLASSEXTEND = "native"