aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/avr-libc
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/avr-libc
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/avr-libc')
-rw-r--r--recipes/avr-libc/avr-libc-1.0.3/configure.patch57
-rw-r--r--recipes/avr-libc/avr-libc_1.0.3.bb38
2 files changed, 95 insertions, 0 deletions
diff --git a/recipes/avr-libc/avr-libc-1.0.3/configure.patch b/recipes/avr-libc/avr-libc-1.0.3/configure.patch
new file mode 100644
index 0000000000..3bfc8394c4
--- /dev/null
+++ b/recipes/avr-libc/avr-libc-1.0.3/configure.patch
@@ -0,0 +1,57 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- avr-libc-1.0/./configure.in~configure
++++ avr-libc-1.0/./configure.in
+@@ -26,8 +26,9 @@
+ # ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+ # POSSIBILITY OF SUCH DAMAGE.
+
+-AC_PREREQ(2.13)
+-AC_INIT(libc)
++AC_PREREQ(2.57)
++AC_INIT
++AC_CONFIG_SRCDIR([libc])
+
+ dnl Default to --enable-multilib
+ AC_ARG_ENABLE(multilib,
+@@ -132,7 +133,7 @@
+ AC_SUBST(avrlib_basedir)
+
+ # Determine the host, build, and target systems
+-AC_CANONICAL_SYSTEM
++AC_CANONICAL_TARGET([])
+
+ dnl NOTE: Don't put a '-' in the version number or rpm will puke
+ dnl when building the package.
+@@ -357,17 +358,16 @@
+ fi
+
+ dnl the top Makefile must be the last of the list
+-AC_OUTPUT(crt1/Makefile libc/Makefile libc/stdlib/Makefile
++AC_CONFIG_FILES([crt1/Makefile libc/Makefile libc/stdlib/Makefile
+ libc/pmstring/Makefile libc/string/Makefile libc/misc/Makefile
+ libc/stdio/Makefile
+ libm/Makefile libm/fplib/Makefile avr-libc.spec
+ doc/Makefile doc/examples/Makefile
+ doc/api/Makefile doc/api/doxygen.config
+- Makefile,
+-[if test -n "$CONFIG_FILES"; then
++ Makefile])
++AC_CONFIG_COMMANDS([default],[[if test -n "$CONFIG_FILES"; then
+ . ${avrlib_basedir}/config-ml.in
+-fi],
+-srcdir=${srcdir}
++fi]],[[srcdir=${srcdir}
+ host=${host}
+ target=${target}
+ with_multisubdir=${with_multisubdir}
+@@ -375,4 +375,5 @@
+ CONFIG_SHELL=${CONFIG_SHELL-/bin/sh}
+ avrlib_basedir=${avrlib_basedir}
+ CC="${CC}"
+-)
++]])
++AC_OUTPUT
diff --git a/recipes/avr-libc/avr-libc_1.0.3.bb b/recipes/avr-libc/avr-libc_1.0.3.bb
new file mode 100644
index 0000000000..20a2850958
--- /dev/null
+++ b/recipes/avr-libc/avr-libc_1.0.3.bb
@@ -0,0 +1,38 @@
+HOMEPAGE = "http://www.nongnu.org/avr-libc"
+DESCRIPTION = "C library for use with GCC on Atmel AVR microcontrollers"
+PROVIDES = "virtual/libc"
+SECTION = "libs"
+LICENSE = "BSD"
+
+python __anonymous () {
+ import bb, re
+ if (re.match('avr', bb.data.getVar('TARGET_ARCH', d, 1)) == None):
+ raise bb.parse.SkipPackage("incompatible with arch %s" %
+ bb.data.getVar('TARGET_ARCH', d, 1))
+}
+
+SRC_URI = "http://savannah.nongnu.org/download/avr-libc/avr-libc-${PV}.tar.bz2 \
+ file://configure.patch;patch=1"
+B = "${WORKDIR}/build.${BUILD_SYS}.${TARGET_SYS}"
+
+inherit autotools
+
+export tooldir = "${prefix}"
+prefix = "${CROSS_DIR}"
+exec_prefix = "${prefix}"
+
+do_stage () {
+ # install into CROSS_DIR
+ oe_runmake install
+ # install into staging
+ oe_runmake "prefix=${STAGING_DIR_HOST}${layout_prefix}" \
+ "exec_prefix=${STAGING_DIR_HOST}${layout_exec_prefix}" \
+ "bindir=${STAGING_BINDIR}" "libdir=${STAGING_LIBDIR}" \
+ "tooldir=${STAGING_DIR_HOST}" "toolibdir=${STAGING_LIBDIR}" \
+ install
+}
+
+do_install () {
+# install into D
+ oe_runmake "DESTDIR=${D}" "tooldir=/" install
+}