aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bc
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-12-06 12:12:32 +0100
committerKoen Kooi <koen@openembedded.org>2010-12-06 13:50:57 +0100
commit276cdd45784abe9573e98eb1442e4c82c442d1f1 (patch)
tree20ef94bbbb76e4ac82c3d39666cd2c857db631fd /recipes/bc
parent99479ceeca016dcbf5fe88d4e7645a4df09aa4b4 (diff)
downloadopenembedded-276cdd45784abe9573e98eb1442e4c82c442d1f1.tar.gz
bc 1.06: fix segfault when using -l
Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/bc')
-rw-r--r--recipes/bc/bc/bc-1.06-fixes-1.patch27
-rw-r--r--recipes/bc/bc_1.06.bb14
2 files changed, 36 insertions, 5 deletions
diff --git a/recipes/bc/bc/bc-1.06-fixes-1.patch b/recipes/bc/bc/bc-1.06-fixes-1.patch
new file mode 100644
index 0000000000..afcdba20d9
--- /dev/null
+++ b/recipes/bc/bc/bc-1.06-fixes-1.patch
@@ -0,0 +1,27 @@
+Submitted By: Jim Gifford (jim at linuxfromscratch dot org)
+Date: 2003-09-26
+Initial Package Version: 1.06
+Origin: Mandrake CVS
+Description: Fixes a few typos
+
+--- bc-1.06/lib/number.c.orig 2003-09-26 21:14:02.000000000 +0000
++++ bc-1.06/lib/number.c 2003-09-26 21:14:26.000000000 +0000
+@@ -34,6 +34,7 @@
+ #include <number.h>
+ #include <assert.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <ctype.h>/* Prototypes needed for external utility routines. */
+
+ #define bc_rt_warn rt_warn
+--- bc-1.06/bc/load.c.orig 2003-09-26 21:14:14.000000000 +0000
++++ bc-1.06/bc/load.c 2003-09-26 21:14:26.000000000 +0000
+@@ -156,7 +156,7 @@
+ long label_no;
+ long vaf_name; /* variable, array or function number. */
+ long func;
+- program_counter save_adr;
++ static program_counter save_adr;
+
+ /* Initialize. */
+ str = code;
diff --git a/recipes/bc/bc_1.06.bb b/recipes/bc/bc_1.06.bb
index 151ab1c27f..8cce522464 100644
--- a/recipes/bc/bc_1.06.bb
+++ b/recipes/bc/bc_1.06.bb
@@ -1,8 +1,14 @@
DESCRIPTION = "An arbitrary precision calculator language."
SECTION = "console/utils"
-SRC_URI = "${GNU_MIRROR}/bc/bc-${PV}.tar.gz"
-LICENSE = "GPL"
-PR = "r1"
+LICENSE = "GPLv2 LGPLv2.1"
+
+PR = "r2"
+
+SRC_URI = "${GNU_MIRROR}/bc/bc-${PV}.tar.gz \
+ file://bc-1.06-fixes-1.patch"
+
+SRC_URI[md5sum] = "d44b5dddebd8a7a7309aea6c36fda117"
+SRC_URI[sha256sum] = "4ef6d9f17c3c0d92d8798e35666175ecd3d8efac4009d6457b5c99cea72c0e33"
inherit autotools
@@ -19,5 +25,3 @@ pkg_prerm_${PN} () {
update-alternatives --remove dc dc.${PN}
}
-SRC_URI[md5sum] = "d44b5dddebd8a7a7309aea6c36fda117"
-SRC_URI[sha256sum] = "4ef6d9f17c3c0d92d8798e35666175ecd3d8efac4009d6457b5c99cea72c0e33"