aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bcel
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2009-09-18 13:53:07 +0200
committerRobert Schuster <robertschuster@fsfe.org>2009-09-18 13:53:07 +0200
commite48d77d6dca005d16345c004caf1be716db12e3b (patch)
treed57719d1e0458a58a9c1da3007e3395d2199640c /recipes/bcel
parentf380fe99daeec7a31b9f094d06c54eaa3c5770bd (diff)
downloadopenembedded-e48d77d6dca005d16345c004caf1be716db12e3b.tar.gz
bcel 5.2: New recipe (from Jalimo SVN).
bcel-native 5.2: Dito.
Diffstat (limited to 'recipes/bcel')
-rw-r--r--recipes/bcel/bcel-native_5.2.bb6
-rw-r--r--recipes/bcel/bcel_5.2.bb19
2 files changed, 25 insertions, 0 deletions
diff --git a/recipes/bcel/bcel-native_5.2.bb b/recipes/bcel/bcel-native_5.2.bb
new file mode 100644
index 0000000000..478b770bff
--- /dev/null
+++ b/recipes/bcel/bcel-native_5.2.bb
@@ -0,0 +1,6 @@
+require bcel_${PV}.bb
+
+inherit java-native
+
+DEPENDS = "fastjar-native xerces-j-native regexp-native"
+
diff --git a/recipes/bcel/bcel_5.2.bb b/recipes/bcel/bcel_5.2.bb
new file mode 100644
index 0000000000..faf6043c00
--- /dev/null
+++ b/recipes/bcel/bcel_5.2.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Java Bytecode manipulation library"
+LICENSE = "AL2.0"
+AUTHOR = "Apache Software Foundation"
+
+SRC_URI = "http://archive.apache.org/dist/jakarta/bcel/source/${BP}-src.tar.gz"
+
+inherit java-library
+
+DEPENDS = "fastjar-native xerces-j regexp"
+
+do_compile() {
+ mkdir -p build
+
+ oe_makeclasspath cp -s xercesImpl regexp
+
+ javac -sourcepath src/java -d build -cp $cp `find src/java -name \*.java`
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}