aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bluez
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-04-12 11:06:28 +0200
committerKoen Kooi <koen@openembedded.org>2009-04-12 11:06:28 +0200
commit2b20f795e32bab6ce8ae9c3cce1892073e9b7c7a (patch)
tree80435caeeacd55991f95ab83735c72a0e760183d /recipes/bluez
parent0757a01c8ce32871e4f8c769563aa3b9ffa1a2a0 (diff)
downloadopenembedded-2b20f795e32bab6ce8ae9c3cce1892073e9b7c7a.tar.gz
bluez4: fix HUGE bug
* the recipe installed the .pc file, but not headers and libs, so application checking for bluez4 would actually build against bluez3 headers and libs * for angstrom, replace bluez-libs3 with bluez4 at buildtime
Diffstat (limited to 'recipes/bluez')
-rw-r--r--recipes/bluez/bluez4_4.35.bb12
1 files changed, 8 insertions, 4 deletions
diff --git a/recipes/bluez/bluez4_4.35.bb b/recipes/bluez/bluez4_4.35.bb
index 8c86a1a574..fec1411d00 100644
--- a/recipes/bluez/bluez4_4.35.bb
+++ b/recipes/bluez/bluez4_4.35.bb
@@ -5,6 +5,11 @@ DEPENDS = "gst-plugins-base alsa-lib libusb-compat dbus-glib"
HOMEPAGE = "http://www.bluez.org"
LICENSE = "GPL"
+# For angstrom we want this to replace at least bluez-libs
+PROVIDES_append_angstrom = " bluez-libs"
+
+PR = "r1"
+
SRC_URI = "\
http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz \
file://fix-dfutool-usb-declaration-mismatch.patch;patch=1 \
@@ -13,10 +18,8 @@ SRC_URI = "\
"
S = "${WORKDIR}/bluez-${PV}"
-inherit autotools pkgconfig
-
-OE_LT_RPATH_ALLOW = "any"
-OE_LT_RPATH_ALLOW[export] = "1"
+inherit autotools_stage
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
EXTRA_OECONF = "\
--enable-gstreamer \
@@ -56,6 +59,7 @@ FILES_${PN}-dev += "\
${libdir}/alsa-lib/*.la \
${libdir}/gstreamer-0.10/*.la \
"
+
FILES_${PN}-dbg += "\
${libdir}/bluetooth/plugins/.debug \
${libdir}/*/.debug \