aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bluez
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-04-08 19:21:51 +0200
committerKoen Kooi <koen@openembedded.org>2009-04-08 19:21:51 +0200
commit6f89098a071d8c1cb87c403a7d2f5f7f3ce14f70 (patch)
treed0629d67901abe13d40be2730f2660c6c39f68e0 /recipes/bluez
parent9bf9f5e64e6167d8a42ab960e67bf6fc6a258626 (diff)
downloadopenembedded-6f89098a071d8c1cb87c403a7d2f5f7f3ce14f70.tar.gz
bluez4: add less restrictive (and hence less secure) bluetooth dbus config
* this makes bluetooth actually work for non-root users and when using ssh/vnc/etc
Diffstat (limited to 'recipes/bluez')
-rw-r--r--recipes/bluez/bluez4_4.31.bb5
-rw-r--r--recipes/bluez/files/bluetooth.conf29
2 files changed, 20 insertions, 14 deletions
diff --git a/recipes/bluez/bluez4_4.31.bb b/recipes/bluez/bluez4_4.31.bb
index 15e8b00ef5..fe58426640 100644
--- a/recipes/bluez/bluez4_4.31.bb
+++ b/recipes/bluez/bluez4_4.31.bb
@@ -4,12 +4,13 @@ PRIORITY = "optional"
DEPENDS = "gst-plugins-base alsa-lib libusb-compat dbus-glib"
HOMEPAGE = "http://www.bluez.org"
LICENSE = "GPL"
-PR = "r4"
+PR = "r5"
SRC_URI = "\
http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz \
file://fix-dfutool-usb-declaration-mismatch.patch;patch=1 \
file://sbc-thumb.patch;patch=1 \
+ file://bluetooth.conf \
# file://hid2hci_usb_init.patch;patch=1 \
"
S = "${WORKDIR}/bluez-${PV}"
@@ -43,6 +44,8 @@ do_install_append() {
install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
+ # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
+ install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
}
PACKAGES =+ "gst-plugin-bluez libasound-module-bluez"
diff --git a/recipes/bluez/files/bluetooth.conf b/recipes/bluez/files/bluetooth.conf
index 872084702a..1b357eabca 100644
--- a/recipes/bluez/files/bluetooth.conf
+++ b/recipes/bluez/files/bluetooth.conf
@@ -1,13 +1,16 @@
-#
-# additional cards for /etc/pcmcia/bluetooth.conf
-# Note for OE: This file is _appended_ to the stock
-# bluetooth.conf in bluez-utils, so no need to duplicate
-# entries for individual cards.
-#
-card "CSR BT01x0M Bluetooth CF Card"
- version "Bluetooth BT0100M", "", ""
- bind "serial_cs" class "bluetooth"
-
-card "Socket Bluetooth CF Card Rev. G"
- manfid 0x0104, 0x0096
- bind "serial_cs" class "bluetooth"
+<!-- This configuration file specifies the required security policies
+ for Bluetooth core daemon to work. -->
+
+<!DOCTYPE busconfig PUBLIC "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
+ "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
+<busconfig>
+
+ <!-- ../system.conf have denied everything, so we just punch some holes -->
+
+ <policy>
+ <allow own="org.bluez"/>
+ <allow send_destination="org.bluez"/>
+ <allow send_interface="org.bluez.Agent"/>
+ </policy>
+
+</busconfig>