aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/boost-asio
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/boost-asio
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/boost-asio')
-rw-r--r--recipes/boost-asio/boost-asio_0.3.7.bb35
-rw-r--r--recipes/boost-asio/files/disable-epoll.patch11
2 files changed, 46 insertions, 0 deletions
diff --git a/recipes/boost-asio/boost-asio_0.3.7.bb b/recipes/boost-asio/boost-asio_0.3.7.bb
new file mode 100644
index 0000000000..94a29b700c
--- /dev/null
+++ b/recipes/boost-asio/boost-asio_0.3.7.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Asio 0.3.7 for work with boost, should be moved into boost package once integrated into the boost distribution."
+HOMEPAGE = "http://asio.sf.net/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "Boost Software License"
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/asio/boost_asio_0_3_7.tar.bz2"
+
+# mtx-[12] use 2.4 kernels but the kernel-libc-headers are from kernel 2.6,
+# thus the automatic epoll detection does not work in epoll_reactor_fwd.hpp.
+SRC_URI_append_mtx-1 = " file://disable-epoll.patch;patch=1"
+SRC_URI_append_mtx-2 = " file://disable-epoll.patch;patch=1"
+
+S = "${WORKDIR}/boost_asio_0_3_7"
+
+do_configure() {
+}
+
+do_compile() {
+}
+
+do_install() {
+ cd ${S}
+ install -d ${D}/usr/include
+ cp -dpR boost ${D}/usr/include
+}
+
+do_stage() {
+ cd ${S}
+ install -d -m 775 ${STAGING_INCDIR}
+ cp -dpR boost ${STAGING_INCDIR}
+}
+
+FILES_${PN}-dev = "/usr/include"
diff --git a/recipes/boost-asio/files/disable-epoll.patch b/recipes/boost-asio/files/disable-epoll.patch
new file mode 100644
index 0000000000..2d251f6440
--- /dev/null
+++ b/recipes/boost-asio/files/disable-epoll.patch
@@ -0,0 +1,11 @@
+--- boost_asio_0_3_7-orig/boost/asio/detail/epoll_reactor_fwd.hpp 2006-10-27 09:59:16.622530738 +0200
++++ boost_asio_0_3_7/boost/asio/detail/epoll_reactor_fwd.hpp 2006-10-27 09:59:41.131614794 +0200
+@@ -17,7 +17,7 @@
+
+ #include <boost/asio/detail/push_options.hpp>
+
+-#if !defined(BOOST_ASIO_DISABLE_EPOLL)
++#if !defined(BOOST_ASIO_DISABLE_EPOLL) && 0 // mtx-[12] uses 2.4 kernels!
+ #if defined(__linux__) // This service is only supported on Linux.
+
+ #include <boost/asio/detail/push_options.hpp>