aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/busybox/busybox_1.15.3.bb
diff options
context:
space:
mode:
authorDirk Opfer <dirk@opfer-online.de>2010-01-04 15:35:52 +0100
committerDirk Opfer <dirk@opfer-online.de>2010-01-06 13:58:10 +0100
commitd48c5b17a2b1b6f086faf16f85019a4454c5436d (patch)
tree2c31a7c79f47bb59370c30d383249bcab534eed7 /recipes/busybox/busybox_1.15.3.bb
parent87e9614480f16ccc422416271979c155d8b9faf6 (diff)
downloadopenembedded-d48c5b17a2b1b6f086faf16f85019a4454c5436d.tar.gz
busybox: Add new version 1.15.3
Diffstat (limited to 'recipes/busybox/busybox_1.15.3.bb')
-rw-r--r--recipes/busybox/busybox_1.15.3.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/busybox/busybox_1.15.3.bb b/recipes/busybox/busybox_1.15.3.bb
new file mode 100644
index 0000000000..3f8e40c6ec
--- /dev/null
+++ b/recipes/busybox/busybox_1.15.3.bb
@@ -0,0 +1,42 @@
+require busybox.inc
+PR = "${INC_PR}.0"
+
+SRC_URI = "\
+ http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
+ \
+ file://udhcpscript.patch;patch=1 \
+ file://udhcpc-fix-nfsroot.patch;patch=1 \
+ file://B921600.patch;patch=1 \
+ file://get_header_tar.patch;patch=1 \
+ file://busybox-appletlib-dependency.patch;patch=1 \
+ file://find-touchscreen.sh \
+ file://busybox-cron \
+ file://busybox-httpd \
+ file://busybox-udhcpd \
+ file://default.script file://simple.script \
+ file://hwclock.sh \
+ file://mount.busybox \
+ file://mountall \
+ file://syslog \
+ file://syslog.conf \
+ file://umount.busybox \
+ file://defconfig \
+ file://mdev \
+ file://mdev.conf \
+"
+
+EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX}"
+
+do_configure_prepend () {
+ if [ "${TARGET_ARCH}" = "avr32" ] ; then
+ sed -i s:CONFIG_FEATURE_OSF_LABEL=y:CONFIG_FEATURE_OSF_LABEL=n: ${WORKDIR}/defconfig
+ fi
+}
+
+do_install_append() {
+ install -m 0644 ${WORKDIR}/mdev.conf ${D}${sysconfdir}/
+ install -d ${D}${sysconfdir}/init.d/
+ install -d ${D}${sysconfdir}/mdev
+ install -m 0755 ${WORKDIR}/find-touchscreen.sh ${D}${sysconfdir}/mdev/
+ install -m 0755 ${WORKDIR}/mdev ${D}${sysconfdir}/init.d/
+}