summaryrefslogtreecommitdiffstats
path: root/recipes/busybox
diff options
context:
space:
mode:
authorDirk Opfer <dirk@opfer-online.de>2010-07-01 09:33:38 +0200
committerDirk Opfer <dirk@opfer-online.de>2010-07-01 09:48:49 +0200
commit7ce06f37cd800d12ee085554fad235cb7a85e21b (patch)
treefc5dc62466030d305ea6f42edcbe416df956d9bc /recipes/busybox
parent6b32b377524cb51907c12686a7babda685be52d8 (diff)
downloadopenembedded-7ce06f37cd800d12ee085554fad235cb7a85e21b.tar.gz
busybox 1.16.2: Fix udhcpd and udhcpc in config
Starting with version 1.16.x busybox changed CONFIG_APP_UDHCPxxx into CONFIG_UDHCPCxxx. - Change defconfigs - Fix do_install_append to install the scritps if these options are set
Diffstat (limited to 'recipes/busybox')
-rw-r--r--recipes/busybox/busybox-1.16.2/angstrom/defconfig8
-rw-r--r--recipes/busybox/busybox-1.16.2/defconfig8
-rw-r--r--recipes/busybox/busybox_1.16.2.bb13
3 files changed, 20 insertions, 9 deletions
diff --git a/recipes/busybox/busybox-1.16.2/angstrom/defconfig b/recipes/busybox/busybox-1.16.2/angstrom/defconfig
index 8934890ef4..0ecb0f2c32 100644
--- a/recipes/busybox/busybox-1.16.2/angstrom/defconfig
+++ b/recipes/busybox/busybox-1.16.2/angstrom/defconfig
@@ -710,12 +710,12 @@ CONFIG_TRACEROUTE=y
CONFIG_FEATURE_TRACEROUTE_VERBOSE=y
CONFIG_FEATURE_TRACEROUTE_SOURCE_ROUTE=y
CONFIG_FEATURE_TRACEROUTE_USE_ICMP=y
-CONFIG_APP_UDHCPD=y
-CONFIG_APP_DHCPRELAY=y
-CONFIG_APP_DUMPLEASES=y
+CONFIG_UDHCPD=y
+CONFIG_DHCPRELAY=y
+CONFIG_DUMPLEASES=y
# CONFIG_FEATURE_UDHCPD_WRITE_LEASES_EARLY is not set
CONFIG_DHCPD_LEASES_FILE="/var/lib/misc/udhcpd.leases"
-CONFIG_APP_UDHCPC=y
+CONFIG_UDHCPC=y
CONFIG_FEATURE_UDHCPC_ARPING=y
# CONFIG_FEATURE_UDHCP_PORT is not set
# CONFIG_UDHCP_DEBUG is not set
diff --git a/recipes/busybox/busybox-1.16.2/defconfig b/recipes/busybox/busybox-1.16.2/defconfig
index ddbaa0839d..5a6870c110 100644
--- a/recipes/busybox/busybox-1.16.2/defconfig
+++ b/recipes/busybox/busybox-1.16.2/defconfig
@@ -710,12 +710,12 @@ CONFIG_TRACEROUTE=y
CONFIG_FEATURE_TRACEROUTE_VERBOSE=y
CONFIG_FEATURE_TRACEROUTE_SOURCE_ROUTE=y
CONFIG_FEATURE_TRACEROUTE_USE_ICMP=y
-CONFIG_APP_UDHCPD=y
-CONFIG_APP_DHCPRELAY=y
-CONFIG_APP_DUMPLEASES=y
+CONFIG_UDHCPD=y
+CONFIG_DHCPRELAY=y
+CONFIG_DUMPLEASES=y
# CONFIG_FEATURE_UDHCPD_WRITE_LEASES_EARLY is not set
CONFIG_DHCPD_LEASES_FILE="/var/lib/misc/udhcpd.leases"
-CONFIG_APP_UDHCPC=y
+CONFIG_UDHCPC=y
CONFIG_FEATURE_UDHCPC_ARPING=y
# CONFIG_FEATURE_UDHCP_PORT is not set
# CONFIG_UDHCP_DEBUG is not set
diff --git a/recipes/busybox/busybox_1.16.2.bb b/recipes/busybox/busybox_1.16.2.bb
index 25f69f3dd0..2502c52512 100644
--- a/recipes/busybox/busybox_1.16.2.bb
+++ b/recipes/busybox/busybox_1.16.2.bb
@@ -1,5 +1,5 @@
require busybox.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
DEFAULT_PREFERENCE = "-1"
@@ -46,4 +46,15 @@ do_install_append() {
install -d ${D}${sysconfdir}/mdev
install -m 0755 ${WORKDIR}/find-touchscreen.sh ${D}${sysconfdir}/mdev/
install -m 0755 ${WORKDIR}/mdev ${D}${sysconfdir}/init.d/
+
+ if grep "CONFIG_UDHCPD=y" ${WORKDIR}/defconfig; then
+ install -m 0755 ${WORKDIR}/busybox-udhcpd ${D}${sysconfdir}/init.d/
+ fi
+
+ if grep "CONFIG_UDHCPC=y" ${WORKDIR}/defconfig; then
+ install -d ${D}${sysconfdir}/udhcpc.d
+ install -d ${D}${datadir}/udhcpc
+ install -m 0755 ${WORKDIR}/simple.script ${D}${sysconfdir}/udhcpc.d/50default
+ install -m 0755 ${WORKDIR}/default.script ${D}${datadir}/udhcpc/default.script
+ fi
}