aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cdfs
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2010-10-01 01:17:33 +0000
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-10-16 22:36:49 +0200
commite23a8ff9c41d4dd28e68e8289c976ffde25c585b (patch)
tree8a3747a4e20691f48fb9c5525519c868d376cfdf /recipes/cdfs
parentbeec49df850ca634719457595ec7a658a649f6ee (diff)
downloadopenembedded-e23a8ff9c41d4dd28e68e8289c976ffde25c585b.tar.gz
cdfs-2.6.27: initial recipe
Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/cdfs')
-rw-r--r--recipes/cdfs/cdfs_2.6.27.bb20
-rw-r--r--recipes/cdfs/files/0001-Fix-compile-error-with-linux-2.6.32.patch30
2 files changed, 50 insertions, 0 deletions
diff --git a/recipes/cdfs/cdfs_2.6.27.bb b/recipes/cdfs/cdfs_2.6.27.bb
new file mode 100644
index 0000000000..282bed724b
--- /dev/null
+++ b/recipes/cdfs/cdfs_2.6.27.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "CDfs filesystem"
+HOMEPAGE = "http://users.elis.ugent.be/~mronsse/cdfs/"
+SECTION = "kernel/modules"
+LICENSE = "GPL"
+
+SRC_URI = " \
+ http://users.elis.ugent.be/~mronsse/cdfs/download/${P}.tar.bz2 \
+ file://0001-Fix-compile-error-with-linux-2.6.32.patch \
+"
+SRC_URI[md5sum] = "ac64c014a90e3c488394832ea29605b3"
+SRC_URI[sha256sum] = "d034f6c6d9578fe2addfaeceaa101584a4a1fc9f27d825c340baebd345d8d724"
+
+inherit module
+
+do_install() {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake -C "${STAGING_KERNEL_DIR}" DEPMOD=echo INSTALL_MOD_PATH="${D}" SUBDIRS="${S}" ${MODULE_MAKE_FLAGS} modules_install
+}
+
+PACKAGES = "${PN}"
diff --git a/recipes/cdfs/files/0001-Fix-compile-error-with-linux-2.6.32.patch b/recipes/cdfs/files/0001-Fix-compile-error-with-linux-2.6.32.patch
new file mode 100644
index 0000000000..742164da8f
--- /dev/null
+++ b/recipes/cdfs/files/0001-Fix-compile-error-with-linux-2.6.32.patch
@@ -0,0 +1,30 @@
+From 4aff257b7615a1b387797cd8dcc76aed3cc69ab8 Mon Sep 17 00:00:00 2001
+From: Andreas Oberritter <obi@opendreambox.org>
+Date: Mon, 7 Jun 2010 12:05:19 +0000
+Subject: [PATCH] Fix compile error with linux-2.6.32
+
+root.c: In function 'cdfs_init':
+root.c:646: error: 'CLONE_FS' undeclared (first use in this function)
+root.c:646: error: (Each undeclared identifier is reported only once
+root.c:646: error: for each function it appears in.)
+root.c:646: error: 'CLONE_FILES' undeclared (first use in this function)
+root.c:646: error: 'CLONE_SIGHAND' undeclared (first use in this function)
+---
+ root.c | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/root.c b/root.c
+index 966a855..0801051 100644
+--- a/root.c
++++ b/root.c
+@@ -25,6 +25,7 @@
+ #include "cdfs.h"
+
+ #include <linux/module.h>
++#include <linux/sched.h>
+
+
+ /*++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++*
+--
+1.5.6.5
+