aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cdrkit/cdrkit
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-10-02 17:11:34 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-10-02 17:11:34 +0200
commitc4ae6e3ba424d4e47d1728041c04745c8e160518 (patch)
treee22fb295f224877f9e31cfef98b768f0bc83eef9 /recipes/cdrkit/cdrkit
parentd3cf329f4dc97fb7468e9ea46fe926db5f7bded0 (diff)
downloadopenembedded-c4ae6e3ba424d4e47d1728041c04745c8e160518.tar.gz
cdrkit: files dir renamed to cdrkit
Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/cdrkit/cdrkit')
-rw-r--r--recipes/cdrkit/cdrkit/xconfig.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/cdrkit/cdrkit/xconfig.patch b/recipes/cdrkit/cdrkit/xconfig.patch
new file mode 100644
index 0000000000..866b602a35
--- /dev/null
+++ b/recipes/cdrkit/cdrkit/xconfig.patch
@@ -0,0 +1,25 @@
+--- cdrkit-1.1.9/include/xconfig.h.in.orig 2006-12-02 12:10:05.000000000 +0100
++++ cdrkit-1.1.9/include/xconfig.h.in 2009-03-08 13:29:05.000000000 +0100
+@@ -233,7 +233,11 @@
+ /* If using network byte order */
+ #cmakedefine WORDS_BIGENDIAN
+ /* If high bits come first in structures */
+-#cmakedefine BITFIELDS_HTOL
++#ifdef WORDS_BIGENDIAN
++#define BITFIELDS_HTOL
++#else
++#define BITFIELDS_LTOH
++#endif
+ #define HAVE_C_BIGENDIAN /* Flag that WORDS_BIGENDIAN test was done */
+ #define HAVE_C_BITFIELDS /* Flag that BITFIELDS_HTOL test was done */
+
+--- cdrkit-1.1.9/include/CMakeLists.txt.orig 2010-09-27 23:17:34.000000000 +0000
++++ cdrkit-1.1.9/include/CMakeLists.txt 2010-09-27 23:17:58.000000000 +0000
+@@ -35,7 +35,6 @@
+ INCLUDE(TestBigEndian)
+ TEST_BIG_ENDIAN(WORDS_BIGENDIAN)
+
+-TRY_RUN(BITFIELDS_HTOL TEST_DUMMY ${CMAKE_BINARY_DIR} ${CMAKE_CURRENT_SOURCE_DIR}/test_BITFIELDS_HTOL.c)
+
+ INCLUDE(CheckIncludeFiles)
+