summaryrefslogtreecommitdiffstats
path: root/recipes/cdump
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/cdump
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/cdump')
-rw-r--r--recipes/cdump/abiword-2.0.12/cdump.c110
-rw-r--r--recipes/cdump/cdump-native.bb17
2 files changed, 127 insertions, 0 deletions
diff --git a/recipes/cdump/abiword-2.0.12/cdump.c b/recipes/cdump/abiword-2.0.12/cdump.c
new file mode 100644
index 0000000000..4089690222
--- /dev/null
+++ b/recipes/cdump/abiword-2.0.12/cdump.c
@@ -0,0 +1,110 @@
+/* AbiSource Build Tools
+ * Copyright (C) 1998 AbiSource, Inc.
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License
+ * as published by the Free Software Foundation; either version 2
+ * of the License, or (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
+ * 02111-1307, USA.
+ */
+
+#include <stdio.h>
+#include <stdlib.h>
+
+long _getFileLength(const char* pszFileName)
+{
+ long iLengthOfFile;
+
+ FILE* fp = fopen(pszFileName, "rb");
+ if (!fp)
+ {
+ return -1;
+ }
+
+ if (0 != fseek(fp, 0, SEEK_END))
+ {
+ fclose(fp);
+
+ return -1;
+ }
+
+ iLengthOfFile = ftell(fp);
+
+ fclose(fp);
+
+ return iLengthOfFile;
+}
+
+long _readEntireFile(const char* pszFileName, unsigned char* pBytes, unsigned long iLen)
+{
+ FILE* fp = fopen(pszFileName, "rb");
+
+ if (!fp)
+ {
+ return -1;
+ }
+
+ if (iLen != fread(pBytes, 1, iLen, fp))
+ {
+ fclose(fp);
+
+ return -1;
+ }
+
+ fclose(fp);
+
+ return iLen;
+}
+
+void _dumpHexCBytes(FILE* fp, const unsigned char* pBytes, long iLen)
+{
+ long i;
+
+ for (i=0; i<iLen; i++)
+ {
+ if (i
+ && ((i % 16) == 0))
+ {
+ fprintf(fp, "\n");
+ }
+
+ fprintf(fp, "0x%02x,", pBytes[i]);
+ }
+
+ fprintf(fp, "\n");
+}
+
+int main(int argc, char** argv)
+{
+ long iLen;
+ unsigned char* pBytes;
+
+ if (argc != 3)
+ {
+ fprintf(stderr, "Usage: %s datafile arrayname\n", argv[0]);
+
+ return -1;
+ }
+
+ iLen = _getFileLength(argv[1]);
+ pBytes = malloc(iLen);
+
+ _readEntireFile(argv[1], pBytes, iLen);
+
+ printf("unsigned char %s[] = {\n", argv[2]);
+ _dumpHexCBytes(stdout, pBytes, iLen);
+ printf("};\n");
+
+ printf("unsigned long %s_sizeof = sizeof(%s);\n",argv[2],argv[2]);
+
+ return 0;
+}
diff --git a/recipes/cdump/cdump-native.bb b/recipes/cdump/cdump-native.bb
new file mode 100644
index 0000000000..3b14884a33
--- /dev/null
+++ b/recipes/cdump/cdump-native.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Cdump tool from abiword - needed for building abiword"
+inherit native
+
+S = "${WORKDIR}/abiword-2.0.12/"
+SRC_URI = "file://abiword-2.0.12/cdump.c"
+
+do_compile() {
+ gcc -o cdump cdump.c
+}
+
+do_stage() {
+ install -m 755 cdump ${STAGING_BINDIR}
+}
+
+do_install() {
+ true
+}