aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/chicken
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/chicken
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/chicken')
-rw-r--r--recipes/chicken/chicken2.inc19
-rw-r--r--recipes/chicken/chicken3.inc36
-rw-r--r--recipes/chicken/chicken_2.6.bb1
-rw-r--r--recipes/chicken/chicken_3.3.0.bb1
4 files changed, 57 insertions, 0 deletions
diff --git a/recipes/chicken/chicken2.inc b/recipes/chicken/chicken2.inc
new file mode 100644
index 0000000000..fbaf971f88
--- /dev/null
+++ b/recipes/chicken/chicken2.inc
@@ -0,0 +1,19 @@
+DESCRIPTION = "A compiler that translates Scheme source files to C, and an interpreter"
+HOMEPAGE = "http://www.call-with-current-continuation.org/"
+SECTION = "interpreters"
+PRIORITY = "optional"
+LICENSE = "BSD"
+
+SRC_URI = "http://www.call-with-current-continuation.org/chicken-${PV}.tar.gz"
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}${docdir}/${P}
+ mv ${D}/${datadir}/chicken/doc ${D}${docdir}/${P}
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
diff --git a/recipes/chicken/chicken3.inc b/recipes/chicken/chicken3.inc
new file mode 100644
index 0000000000..2feebfb48a
--- /dev/null
+++ b/recipes/chicken/chicken3.inc
@@ -0,0 +1,36 @@
+DESCRIPTION = "A compiler that translates Scheme source files to C, and an interpreter"
+HOMEPAGE = "http://www.call-with-current-continuation.org/"
+SECTION = "interpreters"
+PRIORITY = "optional"
+LICENSE = "BSD"
+
+SRC_URI = "http://chicken.wiki.br/releases/${PV}/chicken-${PV}.tar.gz"
+
+inherit autotools
+
+do_compile() {
+ export PLATFORM=linux
+ export PREFIX=${prefix}
+ export HOST=${TARGET_ARCH}-${DISTRO}-${TARGET_OS}
+ export C_COMPILER=${HOST}-gcc
+ export LIBRARIAN=${HOST}-ar
+ # ARCH= is weird... but it's not enough to export this variable.
+ # If ARCH is not set to empty-string, then the Makefile will try to
+ # use the apply-hack.s file applicable to the machine doing the compiling.
+ # There is no such apply-hack assembler code for arm, at least not yet.
+ make ARCH=
+}
+
+do_install() {
+ export PLATFORM=linux
+ export PREFIX=${prefix}
+ export HOST=${TARGET_ARCH}-${DISTRO}-${TARGET_OS}
+ export C_COMPILER=${HOST}-gcc
+ export LIBRARIAN=${HOST}-ar
+ make ARCH= DESTDIR=${D} install
+}
+
+FILES_${PN} = "${bindir}/csi ${bindir}/chicken-bug"
+FILES_${PN} += "${libdir}/lib*.so.* ${libdir}/chicken"
+FILES_${PN} += "${datadir}/chicken/*.*"
+FILES_${PN}-dev += "${bindir}"
diff --git a/recipes/chicken/chicken_2.6.bb b/recipes/chicken/chicken_2.6.bb
new file mode 100644
index 0000000000..934ef4a218
--- /dev/null
+++ b/recipes/chicken/chicken_2.6.bb
@@ -0,0 +1 @@
+require chicken2.inc
diff --git a/recipes/chicken/chicken_3.3.0.bb b/recipes/chicken/chicken_3.3.0.bb
new file mode 100644
index 0000000000..7d9fc69419
--- /dev/null
+++ b/recipes/chicken/chicken_3.3.0.bb
@@ -0,0 +1 @@
+require chicken3.inc