aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/clamsmtp
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/clamsmtp
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/clamsmtp')
-rw-r--r--recipes/clamsmtp/clamsmtp_1.8.bb40
-rw-r--r--recipes/clamsmtp/files/clamsmtp.init33
-rw-r--r--recipes/clamsmtp/files/doc.configure.txt15
-rw-r--r--recipes/clamsmtp/files/update-config.patch23
4 files changed, 111 insertions, 0 deletions
diff --git a/recipes/clamsmtp/clamsmtp_1.8.bb b/recipes/clamsmtp/clamsmtp_1.8.bb
new file mode 100644
index 0000000000..984d203e36
--- /dev/null
+++ b/recipes/clamsmtp/clamsmtp_1.8.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "ClamSMTP is an SMTP filter that allows you to check for \
+viruses using the ClamAV anti-virus software. It accepts SMTP connections \
+and forwards the SMTP commands and responses to another SMTP server. The \
+'DATA' email body is intercepted and scanned before forwarding. ClamSMTP \
+has an optional transparent proxy mode."
+HOMEPAGE = "http://memberwebs.com/nielsen/software/clamsmtp/"
+SECTION = "network"
+LICENSE = "BSD"
+DEPENDS = "clamav"
+RDEPENDS_${PN} = "clamav-daemon"
+PR = "r2"
+
+SRC_URI = "http://memberwebs.com/nielsen/software/clamsmtp/clamsmtp-${PV}.tar.gz \
+ file://update-config.patch;patch=1 \
+ file://clamsmtp.init \
+ file://doc.configure.txt"
+
+inherit autotools update-rc.d
+
+do_configure () {
+ # no autoreconf please
+ aclocal
+ autoconf
+ libtoolize --force
+ oe_runconf
+}
+do_install_append () {
+ install -m 0755 -d ${D}${sysconfdir}/init.d \
+ ${D}${docdir}/clamsmtp
+ install -m 755 ${WORKDIR}/clamsmtp.init ${D}${sysconfdir}/init.d/clamsmtpd
+ install -m 644 doc/clamsmtpd.conf ${D}${sysconfdir}/clamsmtpd.conf
+ install -m 644 README ${D}${docdir}/clamsmtp
+ install -m 644 ${WORKDIR}/doc.configure.txt ${D}${docdir}/clamsmtp/configure.txt
+ install -m 644 scripts/virus_action.sh ${D}${docdir}/clamsmtp
+}
+
+CONFFILES_${PN} = "${sysconfdir}/clamsmtpd.conf"
+
+INITSCRIPT_NAME = "clamsmtpd"
+INITSCRIPT_PARAMS = "defaults 65 35"
diff --git a/recipes/clamsmtp/files/clamsmtp.init b/recipes/clamsmtp/files/clamsmtp.init
new file mode 100644
index 0000000000..7f30d1f724
--- /dev/null
+++ b/recipes/clamsmtp/files/clamsmtp.init
@@ -0,0 +1,33 @@
+#!/bin/sh
+DAEMON=/usr/sbin/clamsmtpd
+CLAMSMTPD_CONFIG=/etc/clamsmtpd.conf
+PIDFILE=/var/run/clamav/clamsmtpd.pid
+NAME="clamsmtpd"
+DESC="ClamSMTPD"
+
+test -r /etc/default/$NAME && . /etc/default/$NAME
+test -x "$DAEMON" || exit 0
+test ! -r "$CLAMSMTPD_CONFIG" && exit 0
+
+case "$1" in
+ start)
+ echo "Starting $DESC: "
+ start-stop-daemon --oknodo -S -x $DAEMON -- -p $PIDFILE -f $CLAMSMTPD_CONFIG
+ echo "$NAME."
+ ;;
+
+ stop)
+ echo "Stopping $DESC:"
+ start-stop-daemon -K -p $PIDFILE
+ ;;
+
+ restart)
+ $0 stop >/dev/null 2>&1
+ $0 start
+ ;;
+
+ *)
+ echo "Usage: $0 {start|stop|restart}"
+ exit 0
+ ;;
+esac
diff --git a/recipes/clamsmtp/files/doc.configure.txt b/recipes/clamsmtp/files/doc.configure.txt
new file mode 100644
index 0000000000..b06487f31a
--- /dev/null
+++ b/recipes/clamsmtp/files/doc.configure.txt
@@ -0,0 +1,15 @@
+The following items needs to be considered when using clamsmtp:
+
+1. Scanning is done via clamd (clamav-daemon)
+
+ The clamd daemon must be running for scanning to take place.
+
+2. Transparent proxy
+
+ For transparent proxying you need an IP tables rule such as:
+
+ iptables -t nat -A PREROUTING -i eth0 -p tcp -m tcp --dport 25 -j REDIRECT --to-ports 10025
+
+ where eth0 is the incomming port, and 10025 is the port that clamsmtpd
+ is running on. Also remember to enable transparent proxy support in the
+ configuration file.
diff --git a/recipes/clamsmtp/files/update-config.patch b/recipes/clamsmtp/files/update-config.patch
new file mode 100644
index 0000000000..dd67c39e19
--- /dev/null
+++ b/recipes/clamsmtp/files/update-config.patch
@@ -0,0 +1,23 @@
+Run as the clamav user.
+Use the sock that clamd actually creates.
+
+--- clamsmtp-1.8/doc/clamsmtpd.conf 2006/10/11 06:43:31 1.1
++++ clamsmtp-1.8/doc/clamsmtpd.conf 2006/10/11 06:44:04
+@@ -29,7 +29,7 @@
+ #Listen: 0.0.0.0:10025
+
+ # The address clamd is listening on
+-#ClamAddress: /var/run/clamav/clamd
++ClamAddress: /var/run/clamav/clamd.ctl
+
+ # A header to add to all scanned email
+ #Header: X-Virus-Scanned: ClamAV using ClamSMTP
+@@ -47,7 +47,7 @@
+ #TransparentProxy: off
+
+ # User to switch to
+-#User: clamav
++User: clamav
+
+ # Virus actions: There's an option to run a script every time a virus is found.
+ # !IMPORTANT! This can open a hole in your server's security big enough to drive