aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/classpath/classpath-native_0.98.bb
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2009-03-19 19:16:05 +0100
committerRobert Schuster <thebohemian@gmx.net>2009-03-20 00:55:20 +0100
commit665ae4e5422293c50400b3ab778311e199d3a5f5 (patch)
tree5551a2e6cf6b28a41ffbeb7abf1451bfb9fbc5d9 /recipes/classpath/classpath-native_0.98.bb
parent595952e9bbff5d25c370fd140d58c3aae9434690 (diff)
downloadopenembedded-665ae4e5422293c50400b3ab778311e199d3a5f5.tar.gz
classpath-native: Clean up
- removed 0.96.1, 0.97.2: Unable to guarantee that these work with current VMs - added 0.98 - removed superfluous patches
Diffstat (limited to 'recipes/classpath/classpath-native_0.98.bb')
-rw-r--r--recipes/classpath/classpath-native_0.98.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/classpath/classpath-native_0.98.bb b/recipes/classpath/classpath-native_0.98.bb
new file mode 100644
index 0000000000..dfbaad8369
--- /dev/null
+++ b/recipes/classpath/classpath-native_0.98.bb
@@ -0,0 +1,28 @@
+require classpath-native.inc
+
+PR = "r0"
+
+# The code affected by the javanet-local patch
+# is usually not compiled. However if someone changes
+# to --enable-local-sockets it will.
+SRC_URI += "\
+ file://SimpleName.diff;patch=1;pnum=0 \
+ file://sun-security-getproperty.patch;patch=1;pnum=0 \
+ file://ecj_java_dir.patch;patch=1 \
+ file://autotools.patch;patch=1 \
+ file://miscompilation.patch;patch=1 \
+ "
+
+do_unpackpost() {
+ # Kind of patch: Moves package "org.w3c.dom.html2" to "org.w3c.dom.html"
+ mv external/w3c_dom/org/w3c/dom/html2 \
+ external/w3c_dom/org/w3c/dom/html
+
+ find examples/gnu/classpath/examples/html gnu/xml/dom/html2 external/w3c_dom/org/w3c/dom/html -name "*.java" \
+ -exec sed -i -e"s|org.w3c.dom.html2|org.w3c.dom.html|" {} \;
+
+ sed -i -e"s|org/w3c/dom/html2|org/w3c/dom/html|" external/w3c_dom/Makefile.am
+}
+
+addtask unpackpost after do_unpack before do_patch
+