summaryrefslogtreecommitdiffstats
path: root/recipes/classpathx/gnumail_1.1.2.bb
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2009-09-18 14:07:14 +0200
committerRobert Schuster <robertschuster@fsfe.org>2009-09-18 14:07:14 +0200
commit9360aebebce14938c89e5f7f9c411573f541d899 (patch)
tree726cf287bdce6a68fb9bd802a24f55e5fab2bbac /recipes/classpathx/gnumail_1.1.2.bb
parente90cec1338a3a60cbabaff3590c503edd0e10033 (diff)
downloadopenembedded-9360aebebce14938c89e5f7f9c411573f541d899.tar.gz
gnujaf 1.1.1: New recipe (from Jalimo SVN).
gnujaf-native 1.1.1: Dito. gnumail 1.1.2: Dito. gnumail-native 1.1.2: Dito.
Diffstat (limited to 'recipes/classpathx/gnumail_1.1.2.bb')
-rw-r--r--recipes/classpathx/gnumail_1.1.2.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/classpathx/gnumail_1.1.2.bb b/recipes/classpathx/gnumail_1.1.2.bb
new file mode 100644
index 0000000000..adcb1e8c1f
--- /dev/null
+++ b/recipes/classpathx/gnumail_1.1.2.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "GNU's free implementation of the JavaMail API specification"
+LICENSE = "GPL + library exception"
+AUTHOR = "GNU ClasspathX"
+
+SRC_URI = "\
+ http://ftp.gnu.org/gnu/classpathx/mail-${PV}.tar.gz \
+ file://datadir_java.patch;patch=1 \
+ "
+
+inherit java-library autotools
+
+S = "${WORKDIR}/mail-${PV}"
+
+DEPENDS = "fastjar-native gnujaf inetlib"
+
+export JAVAC = "javac"
+export JAVA = "java"
+
+# Fake javadoc
+export JAVADOC = "true"
+
+EXTRA_OECONF = "\
+ --with-inetlib-jar=${STAGING_DATADIR_JAVA} \
+ --with-activation-jar=${STAGING_DATADIR_JAVA} \
+ "
+
+do_compile() {
+ oe_runmake \
+ JARDIR=${datadir_java} \
+ gnumail_jar=${JARFILENAME} \
+ providers_jar=${P}-providers.jar
+}
+
+do_install() {
+ java_install
+ oe_jarinstall ${P}-providers.jar ${PN}-providers.jar
+}
+
+do_stage() {
+ java_stage
+ oe_jarinstall -s ${P}-providers.jar ${PN}-providers.jar
+}