aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/clearsilver
diff options
context:
space:
mode:
authorCliff Brake <cbrake@bec-systems.com>2009-09-09 09:20:02 -0400
committerCliff Brake <cbrake@bec-systems.com>2009-09-09 09:20:02 -0400
commit008c8d35e0a65a732a4ea078ffa9adc1d1c93db3 (patch)
treeca5550518c4325314a6e4d8efbd68e91185232c2 /recipes/clearsilver
parentdb852227f1ed420bd850d3fe31392b66b544cf4f (diff)
downloadopenembedded-008c8d35e0a65a732a4ea078ffa9adc1d1c93db3.tar.gz
clearsilver: fix various build issues
- fix hardcoded Python 2.4 path in patch - fix missing env variables by inheriting distutils-common-base
Diffstat (limited to 'recipes/clearsilver')
-rw-r--r--recipes/clearsilver/clearsilver_0.10.3.bb6
-rw-r--r--recipes/clearsilver/files/crosscompile.patch2
2 files changed, 4 insertions, 4 deletions
diff --git a/recipes/clearsilver/clearsilver_0.10.3.bb b/recipes/clearsilver/clearsilver_0.10.3.bb
index 6c41497ef4..752223d998 100644
--- a/recipes/clearsilver/clearsilver_0.10.3.bb
+++ b/recipes/clearsilver/clearsilver_0.10.3.bb
@@ -3,16 +3,16 @@ SECTION = "net"
DESCRIPTION = "Clearsilver is a fast, powerful, and language-neutral HTML template system"
LICENSE = "Neotonic ClearSilver License"
DEPENDS = "python"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://www.clearsilver.net/downloads/${P}.tar.gz \
file://crosscompile.patch;patch=1"
EXTRA_OECONF = "--disable-apache --disable-perl --disable-ruby --disable-java --disable-csharp --enable-gettext --with-python=${STAGING_BINDIR_NATIVE}/python"
-inherit autotools
+inherit autotools distutils-common-base
-FILES_${PN} += "/usr/lib/python*"
+export PYTHON_DIR
do_compile() {
BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} oe_runmake
diff --git a/recipes/clearsilver/files/crosscompile.patch b/recipes/clearsilver/files/crosscompile.patch
index 1b73bd5576..a19506d48c 100644
--- a/recipes/clearsilver/files/crosscompile.patch
+++ b/recipes/clearsilver/files/crosscompile.patch
@@ -52,7 +52,7 @@ Index: clearsilver-0.10.3/python/Makefile
TARGETS = $(NEO_UTIL_SO)
endif
-+PYTHON_SITE = /usr/lib/python2.4/site-packages/
++PYTHON_SITE = /usr/lib/${PYTHON_DIR}/site-packages/
+
all: $(TARGETS)