summaryrefslogtreecommitdiffstats
path: root/recipes/clutter/clutter-gtk-0.10.2/gtk-deprecated.patch
diff options
context:
space:
mode:
authorAndreas Mueller <schnitzeltony@gmx.de>2010-09-07 10:07:54 +0200
committerKoen Kooi <koen@openembedded.org>2010-09-07 10:07:54 +0200
commit8d64681eb7e2fa74be5dfd2f5a945f57d61113b9 (patch)
tree8fcba04a1f89f10cd065f2f3b80fc023efaafba5 /recipes/clutter/clutter-gtk-0.10.2/gtk-deprecated.patch
parent2eca1eb59ccb0890e4db078a4af456c9f2d194ad (diff)
downloadopenembedded-8d64681eb7e2fa74be5dfd2f5a945f57d61113b9.tar.gz
clutter: clean builds for clutter 1.0
* all 0.9 recipes (are actually 1.0rc) & files referenced were removed * all 0.8 recipes were renamed to clutter*-0.8 to ensure parallel installation with later versions * clutter-common.inc as container for helpers was created (also from clutter-fpu.inc) * clutter-1.0_1.0.10.bb was renamed to clutter_1.0.10.bb * clutter-gst_1.2.0.bb introduced the first ever buildable in GLES environment without further effords * clutter-gtk_0.10.2.bb is the latest version which supports clutter 1.0.x (later ones complain on configure for clutter 1.2.x) * clutter* examples / tests are build properly and packed in extra packages. For clutter-interactive tests menu entries (graphics) are added / test-conformance-run runs all conformance tests (crashing tests do not abort) Signed-off-by: Andreas Mueller <schnitzeltony@gmx.de> Acked-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/clutter/clutter-gtk-0.10.2/gtk-deprecated.patch')
-rw-r--r--recipes/clutter/clutter-gtk-0.10.2/gtk-deprecated.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/clutter/clutter-gtk-0.10.2/gtk-deprecated.patch b/recipes/clutter/clutter-gtk-0.10.2/gtk-deprecated.patch
new file mode 100644
index 0000000000..93eb6a97aa
--- /dev/null
+++ b/recipes/clutter/clutter-gtk-0.10.2/gtk-deprecated.patch
@@ -0,0 +1,29 @@
+--- a/clutter-gtk/gtk-clutter-embed.c.old 2009-06-27 16:21:06.000000000 +0200
++++ b/clutter-gtk/gtk-clutter-embed.c 2010-09-01 12:46:25.000000000 +0200
+@@ -131,7 +131,7 @@
+ {
+ GtkClutterEmbedPrivate *priv = GTK_CLUTTER_EMBED (widget)->priv;
+
+- if (GTK_WIDGET_REALIZED (widget))
++ if (gtk_widget_get_realized (widget))
+ clutter_actor_show (priv->stage);
+
+ GTK_WIDGET_CLASS (gtk_clutter_embed_parent_class)->show (widget);
+@@ -222,7 +222,7 @@
+
+ clutter_actor_realize (priv->stage);
+
+- if (GTK_WIDGET_VISIBLE (widget))
++ if (gtk_widget_get_visible (widget))
+ clutter_actor_show (priv->stage);
+
+ gtk_clutter_embed_send_configure (GTK_CLUTTER_EMBED (widget));
+@@ -246,7 +246,7 @@
+
+ widget->allocation = *allocation;
+
+- if (GTK_WIDGET_REALIZED (widget))
++ if (gtk_widget_get_realized (widget))
+ {
+ gdk_window_move_resize (widget->window,
+ allocation->x, allocation->y,