aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/clutter/clutter/enable_tests-0.4.patch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/clutter/clutter/enable_tests-0.4.patch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/clutter/clutter/enable_tests-0.4.patch')
-rw-r--r--recipes/clutter/clutter/enable_tests-0.4.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/recipes/clutter/clutter/enable_tests-0.4.patch b/recipes/clutter/clutter/enable_tests-0.4.patch
new file mode 100644
index 0000000000..3178a2cd6c
--- /dev/null
+++ b/recipes/clutter/clutter/enable_tests-0.4.patch
@@ -0,0 +1,52 @@
+---
+ tests/Makefile.am | 7 ++++++-
+ tests/test-actors.c | 2 +-
+ tests/test-text.c | 2 +-
+ 3 files changed, 8 insertions(+), 3 deletions(-)
+
+Index: clutter-0-4/tests/Makefile.am
+===================================================================
+--- clutter-0-4.orig/tests/Makefile.am 2007-11-06 21:49:25.000000000 +0000
++++ clutter-0-4/tests/Makefile.am 2007-11-06 21:49:48.000000000 +0000
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
++bin_PROGRAMS = test-textures test-events test-offscreen test-scale \
+ test-actors test-behave test-text test-entry test-project \
+ test-boxes test-perspective test-rotate test-depth \
+ test-threads test-timeline
+@@ -24,4 +24,9 @@ test_depth_SOURCES = test-depth.c
+ test_threads_SOURCES = test-threads.c
+ test_timeline_SOURCES = test-timeline.c
+
++test_textdir = $(pkgdatadir)
++test_text_DATA = test-text.c
++test_actorsdir = $(pkgdatadir)
++test_actors_DATA = redhand.png
++
+ EXTRA_DIST = redhand.png
+Index: clutter-0-4/tests/test-actors.c
+===================================================================
+--- clutter-0-4.orig/tests/test-actors.c 2007-11-06 21:49:25.000000000 +0000
++++ clutter-0-4/tests/test-actors.c 2007-11-06 21:49:28.000000000 +0000
+@@ -143,7 +143,7 @@ main (int argc, char *argv[])
+ stage = clutter_stage_get_default ();
+ clutter_actor_set_size (stage, 800, 600);
+
+- pixbuf = gdk_pixbuf_new_from_file ("redhand.png", NULL);
++ pixbuf = gdk_pixbuf_new_from_file ("/usr/share/clutter/redhand.png", NULL);
+
+ if (!pixbuf)
+ g_error("pixbuf load failed");
+Index: clutter-0-4/tests/test-text.c
+===================================================================
+--- clutter-0-4.orig/tests/test-text.c 2007-11-06 21:49:25.000000000 +0000
++++ clutter-0-4/tests/test-text.c 2007-11-06 21:49:28.000000000 +0000
+@@ -27,7 +27,7 @@ main (int argc, char *argv[])
+
+ stage = clutter_stage_get_default ();
+
+- if (!g_file_get_contents ("test-text.c", &text, &size, NULL))
++ if (!g_file_get_contents ("/usr/share/clutter/test-text.c", &text, &size, NULL))
+ g_error("g_file_get_contents() of test-text.c failed");
+
+ clutter_actor_set_size (stage, 800, 600);