summaryrefslogtreecommitdiffstats
path: root/recipes/clutter/clutter/enable_tests.patch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/clutter/clutter/enable_tests.patch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/clutter/clutter/enable_tests.patch')
-rw-r--r--recipes/clutter/clutter/enable_tests.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/recipes/clutter/clutter/enable_tests.patch b/recipes/clutter/clutter/enable_tests.patch
new file mode 100644
index 0000000000..4a99968fa3
--- /dev/null
+++ b/recipes/clutter/clutter/enable_tests.patch
@@ -0,0 +1,48 @@
+---
+ tests/Makefile.am | 7 ++++++-
+ tests/test-actors.c | 2 +-
+ tests/test-text.c | 2 +-
+ 3 files changed, 8 insertions(+), 3 deletions(-)
+
+Index: clutter/tests/Makefile.am
+===================================================================
+--- clutter.orig/tests/Makefile.am 2008-04-25 16:45:17.000000000 +0100
++++ clutter/tests/Makefile.am 2008-04-25 16:47:12.000000000 +0100
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
++bin_PROGRAMS = test-textures test-events test-offscreen test-scale \
+ test-actors test-behave test-text test-entry test-project \
+ test-perspective test-rotate test-depth \
+ test-threads test-timeline test-timeline-dup-frames \
+@@ -14,7 +14,7 @@
+ test-cogl-tex-polygon test-stage-read-pixels
+
+ if X11_TESTS
+-noinst_PROGRAMS += test-pixmap
++bin_PROGRAMS += test-pixmap
+ endif
+
+ INCLUDES = -I$(top_srcdir)/ -I$(top_builddir)/clutter
+@@ -61,4 +61,9 @@
+ test_cogl_offscreen_SOURCES = test-cogl-offscreen.c
+ test_stage_read_pixels_SOURCES = test-stage-read-pixels.c
+
++test_textdir = $(pkgdatadir)
++test_text_DATA = test-text.c
++test_actorsdir = $(pkgdatadir)
++test_actors_DATA = redhand.png
++
+ EXTRA_DIST = redhand.png test-script.json
+Index: clutter/tests/test-actors.c
+===================================================================
+--- clutter.orig/tests/test-actors.c 2008-04-25 16:45:17.000000000 +0100
++++ clutter/tests/test-actors.c 2008-04-25 16:45:17.000000000 +0100
+@@ -184,7 +184,7 @@
+ /* Create a texture from file, then clone in to same resources */
+ if (i == 0)
+ {
+- if ((oh->hand[i] = clutter_texture_new_from_file ("redhand.png",
++ if ((oh->hand[i] = clutter_texture_new_from_file ("/usr/share/clutter/redhand.png",
+ &error)) == NULL)
+ {
+ g_error ("image load failed: %s", error->message);