aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/clutter/clutter_1.0.10.bb
diff options
context:
space:
mode:
authorAndreas Mueller <schnitzeltony@gmx.de>2010-09-07 10:07:54 +0200
committerKoen Kooi <koen@openembedded.org>2010-09-07 10:07:54 +0200
commit8d64681eb7e2fa74be5dfd2f5a945f57d61113b9 (patch)
tree8fcba04a1f89f10cd065f2f3b80fc023efaafba5 /recipes/clutter/clutter_1.0.10.bb
parent2eca1eb59ccb0890e4db078a4af456c9f2d194ad (diff)
downloadopenembedded-8d64681eb7e2fa74be5dfd2f5a945f57d61113b9.tar.gz
clutter: clean builds for clutter 1.0
* all 0.9 recipes (are actually 1.0rc) & files referenced were removed * all 0.8 recipes were renamed to clutter*-0.8 to ensure parallel installation with later versions * clutter-common.inc as container for helpers was created (also from clutter-fpu.inc) * clutter-1.0_1.0.10.bb was renamed to clutter_1.0.10.bb * clutter-gst_1.2.0.bb introduced the first ever buildable in GLES environment without further effords * clutter-gtk_0.10.2.bb is the latest version which supports clutter 1.0.x (later ones complain on configure for clutter 1.2.x) * clutter* examples / tests are build properly and packed in extra packages. For clutter-interactive tests menu entries (graphics) are added / test-conformance-run runs all conformance tests (crashing tests do not abort) Signed-off-by: Andreas Mueller <schnitzeltony@gmx.de> Acked-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/clutter/clutter_1.0.10.bb')
-rw-r--r--recipes/clutter/clutter_1.0.10.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/clutter/clutter_1.0.10.bb b/recipes/clutter/clutter_1.0.10.bb
new file mode 100644
index 0000000000..020ebf20da
--- /dev/null
+++ b/recipes/clutter/clutter_1.0.10.bb
@@ -0,0 +1,29 @@
+require clutter.inc
+
+PR = "${INC_PR}.0"
+
+SRC_URI = "http://source.clutter-project.org/sources/clutter/1.0/clutter-${PV}.tar.bz2 \
+ ${INC_SRC_URI} \
+ "
+
+# recommended for --clutter-debug / --cogl-debug params
+BASE_CONF += " --enable-debug"
+
+do_compile_prepend() {
+ rebuild_shader_sources ${S}/clutter/cogl/cogl/driver/gles
+ # align test data location
+ for full_name in $(find ${S}/tests/data -name *.png -o -name *.json) ; do
+ data_name=${full_name##*/}
+ for i in $(find ${S}/tests -name *.c -o -name *.json) ; do
+ sed -i -e s:${data_name}:${datadir}/${PN}-tests/${data_name}:g $i
+ done
+ done
+}
+
+do_install() {
+ autotools_do_install
+ install_tests
+}
+
+SRC_URI[md5sum] = "bf48e85291cba33f3f149f4eefe759f0"
+SRC_URI[sha256sum] = "6fb98dc4d16a3a98be734cf0a6cc4f8d8179800603c3e41011c414eeaf1f456b"