aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/clutter
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-06-05 14:29:36 +0200
committerKoen Kooi <koen@Powerbook-3.local>2009-06-05 17:48:14 +0200
commit854e7493b3fb354a9dde29324db398026ee32379 (patch)
tree17723a683b80f0ac93ada483d9755484a58b96f8 /recipes/clutter
parent42870b21740b4de888f62915d2422a0008ba45d0 (diff)
downloadopenembedded-854e7493b3fb354a9dde29324db398026ee32379.tar.gz
clutter-gst-0.9: fix build
Diffstat (limited to 'recipes/clutter')
-rw-r--r--recipes/clutter/clutter-gst-0.9_git.bb8
-rw-r--r--recipes/clutter/files/0001-clutter-gst-videosink-guard-GL-calls-with-ifdef-CL.patch60
2 files changed, 65 insertions, 3 deletions
diff --git a/recipes/clutter/clutter-gst-0.9_git.bb b/recipes/clutter/clutter-gst-0.9_git.bb
index 4b4529574c..f875c5d5fa 100644
--- a/recipes/clutter/clutter-gst-0.9_git.bb
+++ b/recipes/clutter/clutter-gst-0.9_git.bb
@@ -1,10 +1,12 @@
require clutter-gst.inc
-SRCREV = "a9a259bfcd8488a101df5c687366ca763c69b7ef"
+SRCREV = "460826267cbb50c257cf7d957f8f9483a678da4e"
PV = "0.9.0"
+PR = "r1"
PR_append = "+git${SRCREV}"
-SRC_URI = "git://git.clutter-project.org/clutter-gst.git;protocol=git \
- file://autofoo.patch;patch=1"
+SRC_URI = "git://git.clutter-project.org/clutter-gst.git;protocol=git;branch=1.0-integration \
+ file://autofoo.patch;patch=1 \
+ file://0001-clutter-gst-videosink-guard-GL-calls-with-ifdef-CL.patch;patch=1"
S = "${WORKDIR}/git"
diff --git a/recipes/clutter/files/0001-clutter-gst-videosink-guard-GL-calls-with-ifdef-CL.patch b/recipes/clutter/files/0001-clutter-gst-videosink-guard-GL-calls-with-ifdef-CL.patch
new file mode 100644
index 0000000000..d73ebe5877
--- /dev/null
+++ b/recipes/clutter/files/0001-clutter-gst-videosink-guard-GL-calls-with-ifdef-CL.patch
@@ -0,0 +1,60 @@
+From 69f75d284caed6c38ccbdc4479f69fb16bb3ec46 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Fri, 5 Jun 2009 14:21:34 +0200
+Subject: [PATCH] clutter-gst videosink: guard GL calls with #ifdef CLUTTER_COGL_HAS_GL so it can be compiled against the GLES backend
+
+---
+ clutter-gst/clutter-gst-video-sink.c | 8 ++++++++
+ 1 files changed, 8 insertions(+), 0 deletions(-)
+
+diff --git a/clutter-gst/clutter-gst-video-sink.c b/clutter-gst/clutter-gst-video-sink.c
+index c20fbd7..2f2d27b 100644
+--- a/clutter-gst/clutter-gst-video-sink.c
++++ b/clutter-gst/clutter-gst-video-sink.c
+@@ -245,6 +245,8 @@ _string_array_to_char_array (char *dst,
+ *dst = '\0';
+ }
+
++#ifdef CLUTTER_COGL_HAS_GL
++
+ static void
+ clutter_gst_video_sink_fp_paint (ClutterActor *actor,
+ ClutterGstVideoSink *sink)
+@@ -284,6 +286,8 @@ clutter_gst_video_sink_set_fp_shader (ClutterGstVideoSink *sink,
+
+ }
+
++#endif /* CLUTTER_COGL_HAS_GL */
++
+ static void
+ clutter_gst_video_sink_paint (ClutterActor *actor,
+ ClutterGstVideoSink *sink)
+@@ -746,14 +750,17 @@ clutter_gst_build_renderers_list (ClutterGstSymbols *syms)
+ {
+ &rgb24_renderer,
+ &rgb32_renderer,
++#ifdef CLUTTER_COGL_HAS_GL
+ &yv12_glsl_renderer,
+ &yv12_fp_renderer,
+ &i420_glsl_renderer,
+ &i420_fp_renderer,
+ &ayuv_glsl_renderer,
++#endif /* CLUTTER_COGL_HAS_GL */
+ NULL
+ };
+
++#ifdef CLUTTER_COGL_HAS_GL
+ /* get the features */
+ gl_extensions = (const gchar*) glGetString (GL_EXTENSIONS);
+ if (cogl_check_extension ("GL_ARB_multitexture", gl_extensions))
+@@ -773,6 +780,7 @@ clutter_gst_build_renderers_list (ClutterGstSymbols *syms)
+ features |= CLUTTER_GST_MULTI_TEXTURE;
+ }
+ }
++#endif /* CLUTTER_COGL_HAS_GL */
+
+ if (cogl_check_extension ("GL_ARB_fragment_program", gl_extensions))
+ {
+--
+1.6.1
+