aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cmake
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-09-17 12:08:24 -0700
committerTom Rini <tom_rini@mentor.com>2010-09-17 12:18:08 -0700
commit007c97cab5f7a4d5ee0a62b061e50b919b912455 (patch)
tree4379f0f083914ac536a0cbba2eb3d1aa59f57ff7 /recipes/cmake
parentcb86425268d0dadcaa383ef6c410e50bd525225d (diff)
downloadopenembedded-007c97cab5f7a4d5ee0a62b061e50b919b912455.tar.gz
cmake-native: Disable ncurses
Enrico mentioned how to do this on the ML and it's that or add ncurses-native to the dependency list. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/cmake')
-rw-r--r--recipes/cmake/cmake-2.8.2/tinfo.patch10
-rw-r--r--recipes/cmake/cmake-native_2.8.2.bb7
2 files changed, 6 insertions, 11 deletions
diff --git a/recipes/cmake/cmake-2.8.2/tinfo.patch b/recipes/cmake/cmake-2.8.2/tinfo.patch
deleted file mode 100644
index 5c332ccdd7..0000000000
--- a/recipes/cmake/cmake-2.8.2/tinfo.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff -Nurd cmake-2.8.2.orig/Source/CursesDialog/CMakeLists.txt cmake-2.8.2/Source/CursesDialog/CMakeLists.txt
---- cmake-2.8.2.orig/Source/CursesDialog/CMakeLists.txt 2010-06-28 11:16:00.000000000 -0400
-+++ cmake-2.8.2/Source/CursesDialog/CMakeLists.txt 2010-08-23 10:36:31.936455461 -0400
-@@ -33,5 +33,6 @@
- ADD_EXECUTABLE(ccmake ${CURSES_SRCS} )
- TARGET_LINK_LIBRARIES(ccmake CMakeLib)
- TARGET_LINK_LIBRARIES(ccmake cmForm)
-+TARGET_LINK_LIBRARIES(ccmake tinfo)
-
- INSTALL_TARGETS(/bin ccmake)
diff --git a/recipes/cmake/cmake-native_2.8.2.bb b/recipes/cmake/cmake-native_2.8.2.bb
index 2713e9b3d3..c7b3d80155 100644
--- a/recipes/cmake/cmake-native_2.8.2.bb
+++ b/recipes/cmake/cmake-native_2.8.2.bb
@@ -1,7 +1,12 @@
inherit native
require cmake.inc
-SRC_URI += "file://tinfo.patch;patch=1"
+PR = "r1"
SRC_URI[md5sum] = "8c967d5264657a798f22ee23976ff0d9"
SRC_URI[sha256sum] = "766ff169af798599d7dd42e41e9f4533d73942a2bb928235115412dce5b81406"
+
+do_configure_append () {
+ sed -e 's/BUILD_CursesDialog:BOOL=ON/BUILD_CursesDialog:BOOL=OFF/' \
+ -i CMakeCache.txt
+}