aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cmake
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2010-08-23 15:12:49 -0400
committerPhilip Balister <philip@balister.org>2010-08-23 15:15:30 -0400
commit5ea3047995421d99f7f3537cb8f9ae23f3185a9f (patch)
tree18590ae1a64c9a0dcfaaf0d1f31d61d8a207de7c /recipes/cmake
parent70b3cf1ad375773597ae545fedff710bdbd28e58 (diff)
downloadopenembedded-5ea3047995421d99f7f3537cb8f9ae23f3185a9f.tar.gz
cmake-native_2.8.2.bb : Force ccmake to link against -ltinfo.
I needed this to build cmake-native for angstrom-2010 on a F13 machine. Hopefully, this does not break other builds.
Diffstat (limited to 'recipes/cmake')
-rw-r--r--recipes/cmake/cmake-2.8.2/tinfo.patch10
-rw-r--r--recipes/cmake/cmake-native_2.8.2.bb2
2 files changed, 12 insertions, 0 deletions
diff --git a/recipes/cmake/cmake-2.8.2/tinfo.patch b/recipes/cmake/cmake-2.8.2/tinfo.patch
new file mode 100644
index 0000000000..5c332ccdd7
--- /dev/null
+++ b/recipes/cmake/cmake-2.8.2/tinfo.patch
@@ -0,0 +1,10 @@
+diff -Nurd cmake-2.8.2.orig/Source/CursesDialog/CMakeLists.txt cmake-2.8.2/Source/CursesDialog/CMakeLists.txt
+--- cmake-2.8.2.orig/Source/CursesDialog/CMakeLists.txt 2010-06-28 11:16:00.000000000 -0400
++++ cmake-2.8.2/Source/CursesDialog/CMakeLists.txt 2010-08-23 10:36:31.936455461 -0400
+@@ -33,5 +33,6 @@
+ ADD_EXECUTABLE(ccmake ${CURSES_SRCS} )
+ TARGET_LINK_LIBRARIES(ccmake CMakeLib)
+ TARGET_LINK_LIBRARIES(ccmake cmForm)
++TARGET_LINK_LIBRARIES(ccmake tinfo)
+
+ INSTALL_TARGETS(/bin ccmake)
diff --git a/recipes/cmake/cmake-native_2.8.2.bb b/recipes/cmake/cmake-native_2.8.2.bb
index a6235254ef..2713e9b3d3 100644
--- a/recipes/cmake/cmake-native_2.8.2.bb
+++ b/recipes/cmake/cmake-native_2.8.2.bb
@@ -1,5 +1,7 @@
inherit native
require cmake.inc
+SRC_URI += "file://tinfo.patch;patch=1"
+
SRC_URI[md5sum] = "8c967d5264657a798f22ee23976ff0d9"
SRC_URI[sha256sum] = "766ff169af798599d7dd42e41e9f4533d73942a2bb928235115412dce5b81406"