aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cmake
diff options
context:
space:
mode:
authorYuri Bushmelev <jay4mail@gmail.com>2010-06-10 18:55:23 +0400
committerYuri Bushmelev <jay4mail@gmail.com>2010-06-10 19:53:41 +0400
commitb8599e06e759f7975a366940eeaddc43fc631b3a (patch)
treed985d2228f6c57435d46bb4f1abb18220a44cc8d /recipes/cmake
parent8b29951fa776fa30d02a2bffab2caffdf13b0ce7 (diff)
downloadopenembedded-b8599e06e759f7975a366940eeaddc43fc631b3a.tar.gz
cmake_2.6.4: Patch added to fix compilation when FORTIFY_SOURCE is enabled
Diffstat (limited to 'recipes/cmake')
-rw-r--r--recipes/cmake/cmake-2.6.4/fix_fortify_source_compilation.patch32
-rw-r--r--recipes/cmake/cmake-native_2.6.4.bb1
-rw-r--r--recipes/cmake/cmake_2.6.4.bb2
3 files changed, 34 insertions, 1 deletions
diff --git a/recipes/cmake/cmake-2.6.4/fix_fortify_source_compilation.patch b/recipes/cmake/cmake-2.6.4/fix_fortify_source_compilation.patch
new file mode 100644
index 0000000000..316ab0c061
--- /dev/null
+++ b/recipes/cmake/cmake-2.6.4/fix_fortify_source_compilation.patch
@@ -0,0 +1,32 @@
+upstream: http://public.kitware.com/mantis/view.php?id=9267
+status: pending
+origin: http://sisyphus.ru/ru/srpm/Sisyphus/cmake/patches/0
+comment: fix cmake building when FORTIFY_SOURCE is enabled
+--- a/Source/kwsys/SystemInformation.cxx
++++ b/Source/kwsys/SystemInformation.cxx
+@@ -1896,9 +1896,14 @@
+ case 5: sprintf (this->ChipID.ProcessorName,"Pentium II (0.25 micron)"); break;
+ case 6: sprintf (this->ChipID.ProcessorName,"Pentium II With On-Die L2 Cache"); break;
+ case 7: sprintf (this->ChipID.ProcessorName,"Pentium III (0.25 micron)"); break;
++/*
+ case 8: sprintf (this->ChipID.ProcessorName,"Pentium III (0.18 micron) With 256 KB On-Die L2 Cache "); break;
+ case 0xa: sprintf (this->ChipID.ProcessorName,"Pentium III (0.18 micron) With 1 Or 2 MB On-Die L2 Cache "); break;
+ case 0xb: sprintf (this->ChipID.ProcessorName,"Pentium III (0.13 micron) With 256 Or 512 KB On-Die L2 Cache "); break;
++*/
++ case 8: sprintf (this->ChipID.ProcessorName,"Pentium III (0.18 micron) With 256 KB L2 Cache "); break;
++ case 0xa: sprintf (this->ChipID.ProcessorName,"Pentium III (0.18 micron), 1/2 MB L2 Cache "); break;
++ case 0xb: sprintf (this->ChipID.ProcessorName,"Pentium III (0.13 micron), 256/512 KB L2 Cache "); break;
+ default: sprintf (this->ChipID.ProcessorName,"Unknown P6 family"); return false;
+ }
+ break;
+--- a/Utilities/cmtar/encode.c
++++ b/Utilities/cmtar/encode.c
+@@ -32,7 +32,7 @@ th_finish(TAR *t)
+ int i, sum = 0;
+
+ if (t->options & TAR_GNU)
+- strncpy(t->th_buf.magic, "ustar ", 8);
++ memcpy(t->th_buf.magic, "ustar ", 8);
+ else
+ {
+ strncpy(t->th_buf.version, TVERSION, TVERSLEN);
diff --git a/recipes/cmake/cmake-native_2.6.4.bb b/recipes/cmake/cmake-native_2.6.4.bb
index 887db1432d..aab6b62a0c 100644
--- a/recipes/cmake/cmake-native_2.6.4.bb
+++ b/recipes/cmake/cmake-native_2.6.4.bb
@@ -5,5 +5,6 @@ do_install() {
oe_runmake install
}
+SRC_URI += "file://fix_fortify_source_compilation.patch"
SRC_URI[md5sum] = "50f387d0436696c4a68b5512a72c9cde"
SRC_URI[sha256sum] = "9cdd2152e37b05d0d40d334a1bb2dfc0250021797360f971c6ea3d457ac9fdf2"
diff --git a/recipes/cmake/cmake_2.6.4.bb b/recipes/cmake/cmake_2.6.4.bb
index 15981ce3a5..b5a47a88f0 100644
--- a/recipes/cmake/cmake_2.6.4.bb
+++ b/recipes/cmake/cmake_2.6.4.bb
@@ -6,6 +6,6 @@ do_configure_append() {
sed -i -e 's,HAVE_GLIBC_STRERROR_R__TRYRUN_OUTPUT-ADVANCED:INTERNAL=1,HAVE_GLIBC_STRERROR_R__TRYRUN_OUTPUT-ADVANCED:INTERNAL=0,' CMakeCache.txt
}
-
+SRC_URI += "file://fix_fortify_source_compilation.patch"
SRC_URI[md5sum] = "50f387d0436696c4a68b5512a72c9cde"
SRC_URI[sha256sum] = "9cdd2152e37b05d0d40d334a1bb2dfc0250021797360f971c6ea3d457ac9fdf2"