aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cmake
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-03-28 11:19:12 +0200
committerKoen Kooi <koen@openembedded.org>2010-03-28 11:19:12 +0200
commitef9803f0e5fa66c7741263285e6d4904960e27d9 (patch)
tree698f598ee4c82b48975adae303b80d4cc663070c /recipes/cmake
parenta69ae9db060d0930c24d6b6c686ba589375c4bee (diff)
downloadopenembedded-ef9803f0e5fa66c7741263285e6d4904960e27d9.tar.gz
cmake 2.6.4: convert native to new style staging and add (currenly non working) 2.6.4 for target
* does anyone know how pass only 3 vars to cmakecache instead everything?
Diffstat (limited to 'recipes/cmake')
-rw-r--r--recipes/cmake/cmake-native_2.6.4.bb7
-rw-r--r--recipes/cmake/cmake_2.6.4.bb8
2 files changed, 9 insertions, 6 deletions
diff --git a/recipes/cmake/cmake-native_2.6.4.bb b/recipes/cmake/cmake-native_2.6.4.bb
index faf397614b..662a6a72aa 100644
--- a/recipes/cmake/cmake-native_2.6.4.bb
+++ b/recipes/cmake/cmake-native_2.6.4.bb
@@ -1,11 +1,6 @@
inherit native
require cmake.inc
-do_stage() {
- oe_runmake install
- autotools_stage_all
-}
-
do_install() {
- :
+ oe_runmake install
}
diff --git a/recipes/cmake/cmake_2.6.4.bb b/recipes/cmake/cmake_2.6.4.bb
new file mode 100644
index 0000000000..53a4c13d2e
--- /dev/null
+++ b/recipes/cmake/cmake_2.6.4.bb
@@ -0,0 +1,8 @@
+require cmake.inc
+
+inherit cmake
+
+do_configure_append() {
+ sed -i -e 's,HAVE_GLIBC_STRERROR_R__TRYRUN_OUTPUT-ADVANCED:INTERNAL=1,HAVE_GLIBC_STRERROR_R__TRYRUN_OUTPUT-ADVANCED:INTERNAL=0,' CMakeCache.txt
+}
+