summaryrefslogtreecommitdiffstats
path: root/recipes/corosync/corosync_1.2.7.bb
diff options
context:
space:
mode:
authorVladimir Sorokin <sorokin@altell.ru>2010-08-03 12:15:42 +0400
committerRoman I Khimov <khimov@altell.ru>2010-08-05 09:28:45 +0400
commit95fb07577f7cddc1686d7277f78da6222a596369 (patch)
tree99cd8227ab77e40bdfecdabf342ca4261dad5d3c /recipes/corosync/corosync_1.2.7.bb
parent7fe3d2f8ac8af009170ea03d81b87a77c4898506 (diff)
downloadopenembedded-95fb07577f7cddc1686d7277f78da6222a596369.tar.gz
corosync: new version 1.2.7
* bugfix release, considered as safe upgrade Signed-off-by: Vladimir Sorokin <sorokin@altell.ru> Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/corosync/corosync_1.2.7.bb')
-rw-r--r--recipes/corosync/corosync_1.2.7.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes/corosync/corosync_1.2.7.bb b/recipes/corosync/corosync_1.2.7.bb
new file mode 100644
index 0000000000..c77054be66
--- /dev/null
+++ b/recipes/corosync/corosync_1.2.7.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "OSI Certified implementation of a complete cluster engine"
+LICENSE = "BSD"
+
+PR = "r0"
+
+SRC_URI = " \
+ ftp://ftp@corosync.org/downloads/corosync-${PV}/corosync-${PV}.tar.gz \
+ file://fix-lcrso-linkage.patch \
+ file://init \
+ file://corosync.conf \
+ file://volatiles \
+ file://fix-define-semun-union.patch \
+ "
+SRC_URI[md5sum] = "a1f5b03512977d495819e2ed05ba645b"
+SRC_URI[sha256sum] = "0f774cee5d9f5d3e20b146c8719115c029815015952b48de1b99b61b462367d1"
+
+
+inherit autotools_stage update-rc.d
+
+INITSCRIPT_NAME = "corosync-daemon"
+
+EXTRA_OECONF = "--disable-nss"
+
+FILES_${PN}-dbg += "${libexecdir}/lcrso/.debug"
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/init.d
+ install -d ${D}${sysconfdir}/default/volatiles
+ # Original init script is too bashy
+ rm -f ${D}/${sysconfdir}/init.d/corosync
+ install -m 0755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/corosync-daemon
+ install -m 0644 ${WORKDIR}/corosync.conf ${D}/${sysconfdir}/corosync/corosync.conf.example
+ install -m 0644 ${WORKDIR}/volatiles ${D}${sysconfdir}/default/volatiles/05_corosync
+}
+
+pkg_postinst_${PN} () {
+ set -e
+ grep haclient /etc/group || addgroup haclient
+ grep hacluster /etc/passwd || adduser --disabled-password --home=/var/lib/heartbeat --ingroup haclient -g "HA cluster" hacluster
+ /etc/init.d/populate-volatile.sh update
+}