aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/corosync
diff options
context:
space:
mode:
authorVladimir Sorokin <sorokin@altell.ru>2010-08-03 12:15:42 +0400
committerRoman I Khimov <khimov@altell.ru>2010-08-05 09:28:45 +0400
commit95fb07577f7cddc1686d7277f78da6222a596369 (patch)
tree99cd8227ab77e40bdfecdabf342ca4261dad5d3c /recipes/corosync
parent7fe3d2f8ac8af009170ea03d81b87a77c4898506 (diff)
downloadopenembedded-95fb07577f7cddc1686d7277f78da6222a596369.tar.gz
corosync: new version 1.2.7
* bugfix release, considered as safe upgrade Signed-off-by: Vladimir Sorokin <sorokin@altell.ru> Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/corosync')
-rw-r--r--recipes/corosync/corosync_1.2.7.bb (renamed from recipes/corosync/corosync_1.2.6.bb)7
-rw-r--r--recipes/corosync/files/fix-define-semun-union.patch22
2 files changed, 26 insertions, 3 deletions
diff --git a/recipes/corosync/corosync_1.2.6.bb b/recipes/corosync/corosync_1.2.7.bb
index 41287a0c02..c77054be66 100644
--- a/recipes/corosync/corosync_1.2.6.bb
+++ b/recipes/corosync/corosync_1.2.7.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "OSI Certified implementation of a complete cluster engine"
LICENSE = "BSD"
-PR = "r1"
+PR = "r0"
SRC_URI = " \
ftp://ftp@corosync.org/downloads/corosync-${PV}/corosync-${PV}.tar.gz \
@@ -9,9 +9,10 @@ SRC_URI = " \
file://init \
file://corosync.conf \
file://volatiles \
+ file://fix-define-semun-union.patch \
"
-SRC_URI[md5sum] = "82d91373585f0d48cb98a8599a237e48"
-SRC_URI[sha256sum] = "ad41e3133659a5fb32e878aa85199aba6cc84aa5e0e913b4f6e31c4a4805f9d9"
+SRC_URI[md5sum] = "a1f5b03512977d495819e2ed05ba645b"
+SRC_URI[sha256sum] = "0f774cee5d9f5d3e20b146c8719115c029815015952b48de1b99b61b462367d1"
inherit autotools_stage update-rc.d
diff --git a/recipes/corosync/files/fix-define-semun-union.patch b/recipes/corosync/files/fix-define-semun-union.patch
new file mode 100644
index 0000000000..7ce5ab6733
--- /dev/null
+++ b/recipes/corosync/files/fix-define-semun-union.patch
@@ -0,0 +1,22 @@
+diff -rupN corosync-1.2.7/lib/coroipcc.c corosync-1.2.7.new/lib/coroipcc.c
+--- corosync-1.2.7/lib/coroipcc.c 2010-07-22 03:13:42.000000000 +0400
++++ corosync-1.2.7.new/lib/coroipcc.c 2010-08-03 12:06:36.000000000 +0400
+@@ -68,6 +68,18 @@
+ #include <semaphore.h>
+ #else
+ #include <sys/sem.h>
++
++#if _SEM_SEMUN_UNDEFINED
++ union semun
++ {
++ int val; // value for SETVAL
++ struct semid_ds *buf; // buffer for IPC_STAT & IPC_SET
++ unsigned short int *array; // array for GETALL & SETALL
++ struct seminfo *__buf; // buffer for IPC_INFO
++ };
++
++#endif
++
+ #endif
+
+ #include "util.h"