summaryrefslogtreecommitdiffstats
path: root/recipes/ctrlproxy
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/ctrlproxy
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/ctrlproxy')
-rw-r--r--recipes/ctrlproxy/ctrlproxy_2.6.2.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/ctrlproxy/ctrlproxy_2.6.2.bb b/recipes/ctrlproxy/ctrlproxy_2.6.2.bb
new file mode 100644
index 0000000000..53be0cef76
--- /dev/null
+++ b/recipes/ctrlproxy/ctrlproxy_2.6.2.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "ctrlproxy is an IRC server with multiserver support."
+SECTION = "console/network"
+PRIORITY = "optional"
+DEPENDS = "glib-2.0 libxml2 popt libpcre openssl"
+PR = "r1"
+LICENSE = "GPL"
+
+SRC_URI = "http://sources.nslu2-linux.org/sources/ctrlproxy-2.6.2.tar.gz"
+S = "${WORKDIR}/ctrlproxy-2.6.2/"
+
+inherit autotools
+# update-rc.d
+
+#INITSCRIPT_NAME = "ctrlproxy"
+#INITSCRIPT_PARAMS = "defaults 84"
+# CONFFILES_${PN} = "${sysconfdir}/foo.conf"
+
+# To fix this error in autotools_do_configure (which arises after a
+# change to pkg-config pkg.m4):
+#configure:314: error: possibly undefined macro: PKG_LIBS
+do_configure() {
+ oe_runconf
+}
+
+CFLAGS += "-L${STAGING_LIBDIR}"
+
+#do_install() {
+# autotools_do_install
+# install -d ${D}${sysconfdir}
+# install -d ${D}${sysconfdir}/init.d
+# install -m 0644 ${S}contrib/foo.conf ${D}${sysconfdir}
+# install -m 0755 ${WORKDIR}/foo.init ${D}${sysconfdir}/init.d/foo
+#}
+