aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cyrus-imapd/cyrus-imapd_2.2.12.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/cyrus-imapd/cyrus-imapd_2.2.12.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/cyrus-imapd/cyrus-imapd_2.2.12.bb')
-rw-r--r--recipes/cyrus-imapd/cyrus-imapd_2.2.12.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/recipes/cyrus-imapd/cyrus-imapd_2.2.12.bb b/recipes/cyrus-imapd/cyrus-imapd_2.2.12.bb
new file mode 100644
index 0000000000..e80340f080
--- /dev/null
+++ b/recipes/cyrus-imapd/cyrus-imapd_2.2.12.bb
@@ -0,0 +1,53 @@
+SECTION = "console/network"
+DEPENDS = "cyrus-sasl virtual/db"
+LICENSE = "BSD"
+PR = "r12"
+DEPENDS += "install-native"
+
+SRC_URI = "ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-imapd-${PV}.tar.gz \
+ file://autotools.patch;patch=1 \
+ file://tail.patch;patch=1 \
+ file://imapopts.c.gcc4.patch;patch=1 \
+ file://imapopts.h.gcc4.patch;patch=1 \
+ file://cyrus \
+ file://cyrus.conf_2.2 \
+ file://imapd.conf_2.2 \
+ file://volatiles \
+ file://remove-install-strip.patch;patch=1 \
+ "
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "cyrus"
+INITSCRIPT_PARAMS = "start 56 3 4 5 . stop 15 0 1 6 ."
+
+TARGET_LDFLAGS_append_thumb = " -lpthread"
+EXTRA_OECONF = "--with-auth=unix \
+ --with-dblib=berkeley \
+ --with-bdb-libdir=${STAGING_LIBDIR} \
+ --with-bdb-incdir=${STAGING_INCDIR} \
+ --without-perl \
+ --without-snmp"
+
+FILES_${PN} += "${prefix}/cyrus/bin"
+
+# All, lib/foo.c includes <config.h> from the top level directory and
+# is natively compiled
+BUILD_CPPFLAGS += " -I${S} -I${S}/et"
+
+do_install_append () {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/cyrus ${D}${sysconfdir}/init.d/cyrus
+ install -m 644 ${WORKDIR}/cyrus.conf_2.2 ${D}${sysconfdir}/cyrus.conf
+ install -m 644 ${WORKDIR}/imapd.conf_2.2 ${D}${sysconfdir}/imapd.conf
+ install -d ${D}${sysconfdir}/default/volatiles
+ install -m 644 ${WORKDIR}/volatiles ${D}${sysconfdir}/default/volatiles/01_cyrus-imapd
+}
+
+pkg_postinst () {
+ /etc/init.d/populate-volatile.sh update
+}
+
+pkg_postrm () {
+}
+