aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dbus
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-11-13 11:31:47 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-11-13 13:09:03 +0100
commit2f08fd26b2b70ce798115bb406702f02c5fdc310 (patch)
treeadfa3f231c364ec6489fd7a2e4f0331055df67d5 /recipes/dbus
parent8e39848b2a3a55440a5557ca9e5ae10de412acc9 (diff)
downloadopenembedded-2f08fd26b2b70ce798115bb406702f02c5fdc310.tar.gz
dbus: disable libaudit for all and X for native packages (from POKY)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/dbus')
-rw-r--r--recipes/dbus/dbus-native_1.0.3.bb2
-rw-r--r--recipes/dbus/dbus-native_1.2.1.bb2
-rw-r--r--recipes/dbus/dbus.inc7
3 files changed, 9 insertions, 2 deletions
diff --git a/recipes/dbus/dbus-native_1.0.3.bb b/recipes/dbus/dbus-native_1.0.3.bb
index 6ec0fc870d..98b389e4e6 100644
--- a/recipes/dbus/dbus-native_1.0.3.bb
+++ b/recipes/dbus/dbus-native_1.0.3.bb
@@ -5,6 +5,8 @@ DEFAULT_PREFERENCE = "-1"
inherit native
+EXTRA_OECONF_X = "--without-x"
+
DEPENDS = "glib-2.0-native libxml2-native expat-native"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-${PV}"
diff --git a/recipes/dbus/dbus-native_1.2.1.bb b/recipes/dbus/dbus-native_1.2.1.bb
index ffdddf2b97..f9f87dc440 100644
--- a/recipes/dbus/dbus-native_1.2.1.bb
+++ b/recipes/dbus/dbus-native_1.2.1.bb
@@ -4,6 +4,8 @@ RRECOMMENDS_${PN} = ""
RDEPENDS_${PN} = ""
inherit native
+EXTRA_OECONF_X = "--without-x"
+
DEPENDS = "glib-2.0-native libxml2-native expat-native"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-${PV}"
diff --git a/recipes/dbus/dbus.inc b/recipes/dbus/dbus.inc
index 202aec432d..0477a27474 100644
--- a/recipes/dbus/dbus.inc
+++ b/recipes/dbus/dbus.inc
@@ -4,7 +4,7 @@ SECTION = "base"
LICENSE = "GPL"
DEPENDS = "expat glib-2.0 virtual/libintl libsm libice virtual/libx11"
-INC_PR = "r16"
+INC_PR = "r17"
SRC_URI = "\
http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
@@ -19,6 +19,8 @@ S = "${WORKDIR}/dbus-${PV}"
inherit autotools pkgconfig update-rc.d gettext
+EXTRA_OECONF_X = "--with-x"
+
EXTRA_OECONF = "\
--disable-qt \
--disable-qt3 \
@@ -27,9 +29,10 @@ EXTRA_OECONF = "\
--disable-checks \
--disable-xml-docs \
--disable-doxygen-docs \
+ --disable-libaudit \
--with-xml=expat \
- --with-x \
--with-dbus-default-reply-timeout=200000 \
+ ${EXTRA_OECONF_X} \
"
do_compile_prepend_mipsel() {