aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dejagnu
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/dejagnu
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/dejagnu')
-rw-r--r--recipes/dejagnu/dejagnu-native_1.4.4.bb6
-rw-r--r--recipes/dejagnu/dejagnu-qemu/arm-qemu.exp30
-rw-r--r--recipes/dejagnu/dejagnu-qemu_1.0.bb20
-rw-r--r--recipes/dejagnu/dejagnu_1.4.4.bb9
4 files changed, 65 insertions, 0 deletions
diff --git a/recipes/dejagnu/dejagnu-native_1.4.4.bb b/recipes/dejagnu/dejagnu-native_1.4.4.bb
new file mode 100644
index 0000000000..07c4cffdc6
--- /dev/null
+++ b/recipes/dejagnu/dejagnu-native_1.4.4.bb
@@ -0,0 +1,6 @@
+PR = "r1"
+
+require dejagnu_${PV}.bb
+S = "${WORKDIR}/dejagnu-${PV}"
+inherit native
+
diff --git a/recipes/dejagnu/dejagnu-qemu/arm-qemu.exp b/recipes/dejagnu/dejagnu-qemu/arm-qemu.exp
new file mode 100644
index 0000000000..f6d2f8a7de
--- /dev/null
+++ b/recipes/dejagnu/dejagnu-qemu/arm-qemu.exp
@@ -0,0 +1,30 @@
+# Copyright (C) 1997, 1998, 1999, 2000, 2001, 2002, 2003 Free Software
+# Foundation, Inc.
+#
+# This file is part of DejaGnu.
+#
+# DejaGnu is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# DejaGnu is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with DejaGnu; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+set_board_info is_simulator 1
+set_board_info sim "qemu-arm-test-wrapper"
+
+load_generic_config "unix"
+process_multilib_options ""
+
+set_board_info compiler "[find_gcc]"
+
+set_board_info bmk,use_alarm 1
+
+
diff --git a/recipes/dejagnu/dejagnu-qemu_1.0.bb b/recipes/dejagnu/dejagnu-qemu_1.0.bb
new file mode 100644
index 0000000000..2eef27e9a3
--- /dev/null
+++ b/recipes/dejagnu/dejagnu-qemu_1.0.bb
@@ -0,0 +1,20 @@
+LICENSE = "GPL"
+
+inherit cross
+
+SRC_URI = "file://arm-qemu.exp"
+
+# fixme
+QEMU = "qemu-arm"
+LD_SO = "lib/ld-linux.so.2"
+
+do_stage() {
+ install -d ${STAGING_DATADIR}/dejagnu/baseboards
+ install -m 0644 ${WORKDIR}/arm-qemu.exp ${STAGING_DATADIR}/dejagnu/baseboards/
+ cat <<EOF >${STAGING_BINDIR_NATIVE}/${QEMU}-test-wrapper
+#!/bin/sh
+exec ${QEMU} ${CROSS_DIR}/${TARGET_SYS}/${LD_SO} --library-path ${CROSS_DIR}/${TARGET_SYS}/lib:${STAGING_DIR_TARGET}${layout_libdir} \$1
+EOF
+ chmod 755 ${STAGING_BINDIR_NATIVE}/arm-qemu-test-wrapper
+}
+
diff --git a/recipes/dejagnu/dejagnu_1.4.4.bb b/recipes/dejagnu/dejagnu_1.4.4.bb
new file mode 100644
index 0000000000..9d5d7f740a
--- /dev/null
+++ b/recipes/dejagnu/dejagnu_1.4.4.bb
@@ -0,0 +1,9 @@
+DESCRIPTION = "GNU unit testing framework, written in Expect and Tcl"
+LICENSE = "GPL"
+SECTION = "devel"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.gnu.org/gnu/dejagnu/dejagnu-${PV}.tar.gz"
+
+inherit autotools
+